aboutsummaryrefslogtreecommitdiff
path: root/french
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-01-02 21:50:40 +0000
committerThierry Thomas <thierry@FreeBSD.org>2020-01-02 21:50:40 +0000
commit4d877350e82556713fa84ecdf903093f6aa83e74 (patch)
tree009c8c9122f672d73b9fc9dd1587e7e13bc809d6 /french
parent1bb2249365095a3ef7a1938c82c54a72e436bbf3 (diff)
downloadports-4d877350e82556713fa84ecdf903093f6aa83e74.tar.gz
ports-4d877350e82556713fa84ecdf903093f6aa83e74.zip
- Do not try to get VmSize on -CURRENT
- Add a dependency on xterm + Some minor fixes.
Notes
Notes: svn path=/head/; revision=521882
Diffstat (limited to 'french')
-rw-r--r--french/aster/Makefile8
-rw-r--r--french/aster/files/patch-as_setup.py11
-rw-r--r--french/aster/files/patch-products__data.py10
-rw-r--r--french/aster/files/post-patch-bibc__utilitai__mempid.c14
-rw-r--r--french/aster/files/post-patch-bibfor__jeveux__jedebu.F9018
5 files changed, 48 insertions, 13 deletions
diff --git a/french/aster/Makefile b/french/aster/Makefile
index 089e39032b58..4b6cfb7271d0 100644
--- a/french/aster/Makefile
+++ b/french/aster/Makefile
@@ -3,7 +3,7 @@
PORTNAME= aster
DISTVERSION= ${ASTER_DISTVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= french cad
MAINTAINER= thierry@FreeBSD.org
@@ -39,6 +39,7 @@ BUILD_DEPENDS+= astk-serveur>0:cad/astk-serveur \
${LOCALBASE}/lib/libscotch.a:cad/scotch \
gnproc:sysutils/coreutils \
bash:shells/bash \
+ xterm:x11/xterm \
${PYNUMPY}
# pylupdate5:textproc/py-qt5-xml
LIB_DEPENDS+= libhdf5.so:science/hdf5 \
@@ -47,7 +48,8 @@ LIB_DEPENDS+= libhdf5.so:science/hdf5 \
# libAsterInterface.so:science/mfront
# libAsterInterface.so:science/tfel
RUN_DEPENDS+= ${SHELL_INSTALL_ASTER}:shells/${SHIADEP} \
- astk-serveur>0:cad/astk-serveur
+ astk-serveur>0:cad/astk-serveur \
+ xterm:x11/xterm
USES= bison fortran gettext python:3.6+ qt:5 tk
USE_BINUTILS= yes
@@ -366,6 +368,8 @@ pre-build:
.for pp in ${POSTPY2FIX}
${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|' ${WRKDIR}/post_patches/${pp}
.endfor
+ ${REINPLACE_CMD} -e "s|%%WRKDIR%%|${WRKDIR}|" \
+ ${WRKDIR}/post_patches/post-patch-bibfor__jeveux__jedebu.F90
do-build:
(cd ${BUILD_WRKSRC} && \
diff --git a/french/aster/files/patch-as_setup.py b/french/aster/files/patch-as_setup.py
index ba6d291d68b7..7d349c06c04a 100644
--- a/french/aster/files/patch-as_setup.py
+++ b/french/aster/files/patch-as_setup.py
@@ -17,7 +17,7 @@
self._print(self._fmt_title % _('Extraction'))
if kargs.get('external')!=None:
self._call_external(**kargs)
-@@ -518,6 +521,78 @@ class SETUP:
+@@ -518,6 +521,81 @@ class SETUP:
if iextr_as:
self.Clean(to_delete=path)
@@ -81,8 +81,11 @@
+ ligne =ligne.replace("getopt ", "getopts ")
+ sys.stdout.write(ligne)
+ self._print('FreeBSD patches: waf.engine and data/post_install in %s' % os.path.join(self.workdir, self.content))
-+ os.system('cd ' + os.path.join(self.workdir, self.content) + ' && patch -p0 < /usr/ports/french/aster/work/post_patches/post-patch-waf.engine')
-+ os.system('cd ' + os.path.join(self.workdir, self.content) + ' && patch -p0 < /usr/ports/french/aster/work/post_patches/post-patch-data__post_install')
++ os.system('cd ' + os.path.join(self.workdir, self.content) + ' && patch -p0 < %%WRKDIR%%/post_patches/post-patch-waf.engine')
++ os.system('cd ' + os.path.join(self.workdir, self.content) + ' && patch -p0 < %%WRKDIR%%/post_patches/post-patch-data__post_install')
++ self._print('FreeBSD patches: memory detection in bibc/utilitai/mempid.c in %s' % os.path.join(self.workdir, self.content))
++ os.system('cd ' + os.path.join(self.workdir, self.content) + ' && patch -p0 < %%WRKDIR%%/post_patches/post-patch-bibc__utilitai__mempid.c')
++ os.system('cd ' + os.path.join(self.workdir, self.content) + ' && patch -p0 < %%WRKDIR%%/post_patches/post-patch-bibfor__jeveux__jedebu.F90')
+ file2patch = os.path.join(self.workdir, self.content, 'waftools/mathematics.py')
+ self._print('FreeBSD patch: nproc => gnproc ' + file2patch)
+ for ligne in fileinput.input(file2patch, inplace=1):
@@ -96,7 +99,7 @@
#-------------------------------------------------------------------------------
def Configure(self, **kargs):
"""Configuration of the product.
-@@ -1454,7 +1529,7 @@ class SYSTEM:
+@@ -1454,7 +1532,7 @@ class SYSTEM:
if type(profile) is str:
ftmp = osp.join(self._tmpdir, 'temp.opt_env')
open(ftmp, 'w').write(profile)
diff --git a/french/aster/files/patch-products__data.py b/french/aster/files/patch-products__data.py
index 2c1f4e6a7055..0da09a03d36a 100644
--- a/french/aster/files/patch-products__data.py
+++ b/french/aster/files/patch-products__data.py
@@ -1,11 +1,7 @@
---- products_data.py.orig 2017-08-26 13:56:41 UTC
+--- products_data.py.orig 2019-10-01 12:45:34 UTC
+++ products_data.py
-@@ -107,13 +107,11 @@ def configure(self):
- ])
-
- self.env.append_value('INCLUDES', [
-- '%(HOME_HDF)s/include',
-+ '%(HOME_HDF)s/include/hdf5-18',
+@@ -110,10 +110,8 @@ def configure(self):
+ '%(HOME_HDF)s/include',
'%(HOME_MED)s/include',
'%(HOME_MUMPS)s/include',
- '%(HOME_MUMPS)s/include_seq',
diff --git a/french/aster/files/post-patch-bibc__utilitai__mempid.c b/french/aster/files/post-patch-bibc__utilitai__mempid.c
new file mode 100644
index 000000000000..6389882624a3
--- /dev/null
+++ b/french/aster/files/post-patch-bibc__utilitai__mempid.c
@@ -0,0 +1,14 @@
+--- bibc/utilitai/mempid.c.orig 2019-09-25 21:45:54.000000000 +0200
++++ bibc/utilitai/mempid.c 2020-01-02 22:28:47.035670000 +0100
+@@ -77,7 +77,11 @@
+ kvm_close(kd);
+
+ /* VmSize */
++# if __FreeBSD_version > 1300000
++ val[0] = 0;
++# else
+ val[0] = B2K((uintmax_t)kp->ki_size);
++# endif
+ /* VmPeak - not defined in /compat/linux/proc/pid/status */
+ val[1] = -1;
+ iret = 0;
diff --git a/french/aster/files/post-patch-bibfor__jeveux__jedebu.F90 b/french/aster/files/post-patch-bibfor__jeveux__jedebu.F90
new file mode 100644
index 000000000000..cc18870edbe6
--- /dev/null
+++ b/french/aster/files/post-patch-bibfor__jeveux__jedebu.F90
@@ -0,0 +1,18 @@
+--- ./bibfor/jeveux/jedebu.F90.orig 2019-09-25 21:45:58.000000000 +0200
++++ ./bibfor/jeveux/jedebu.F90 2019-12-31 12:21:04.131247000 +0100
+@@ -225,6 +225,7 @@
+ k8tab(2) = 'VMPEAK'
+ k8tab(3) = 'VMSIZE'
+ call utgtme(3, k8tab, rval, iret)
++ call utmess('I', 'DEBUG_1', nr=3, valr=rval, fname='%%WRKDIR%%/aster_debug1.log')
+ if (rval(2) .le. 0 .or. rval(3) .le. 0) then
+ call utmess('I', 'JEVEUX1_75')
+ endif
+@@ -232,6 +233,7 @@
+ if (rval(3) .gt. 0) then
+ !
+ call utptme('RLQ_MEM ', rval(3), iret)
++ call utmess('I', 'DEBUG_1', nr=3, valr=rval, fname='%%WRKDIR%%/aster_debug2.log')
+ if (rval(1)-rval(3) .le. 0) then
+ call utmess('F', 'JEVEUX1_71', nr=3, valr=rval)
+ endif