aboutsummaryrefslogtreecommitdiff
path: root/french
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2020-07-24 17:10:51 +0000
committerKyle Evans <kevans@FreeBSD.org>2020-07-24 17:10:51 +0000
commit5bc1617efc876b99a806f7de78a9fe94a07304b7 (patch)
treebfbfce29f0c9b229834a1f0536dd6d8022ce8104 /french
parentd841eb94b16fac58b307b35f0c2849842e5eea54 (diff)
downloadports-5bc1617efc876b99a806f7de78a9fe94a07304b7.tar.gz
ports-5bc1617efc876b99a806f7de78a9fe94a07304b7.zip
Multiple ports: improve regex compliance (part 2)
This is again a part of the project to stop extraneous escaping of ordinary characters and redefine some ordinary escapes as special behavior. Most of these ports are pushed over to use textproc/gsed because they want to use GNU extensions. Others are fixed to either escape appropriately (e.g. $$ rather than \$ in Makefiles!) or just remove redundant escapes (e.g. backtick in single quotes doesn't need escaped). PR: 229925 MFH: no (invasive risk)
Notes
Notes: svn path=/head/; revision=543267
Diffstat (limited to 'french')
-rw-r--r--french/aster/files/patch-as_setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/french/aster/files/patch-as_setup.py b/french/aster/files/patch-as_setup.py
index 7d349c06c04a..b81531ba8c17 100644
--- a/french/aster/files/patch-as_setup.py
+++ b/french/aster/files/patch-as_setup.py
@@ -17,7 +17,7 @@
self._print(self._fmt_title % _('Extraction'))
if kargs.get('external')!=None:
self._call_external(**kargs)
-@@ -518,6 +521,81 @@ class SETUP:
+@@ -518,6 +521,88 @@ class SETUP:
if iextr_as:
self.Clean(to_delete=path)
@@ -65,6 +65,13 @@
+ sys.stdout.write(ligne)
+ system=SYSTEM({ 'verbose' : True, 'debug' : False },
+ **{'maxcmdlen' : 2**31, 'log' : self})
++ file2patch = os.path.join(self.workdir, self.content, 'waf.main')
++ self._print('FreeBSD patch: remove extraneous escape => modify waf.main')
++ for ligne in fileinput.input(file2patch, inplace=1):
++ nl = ligne.find("\main$")
++ if nl > 0:
++ ligne =ligne.replace("\main$", "main$")
++ sys.stdout.write(ligne)
+ for f2p in ('waf', 'waf.main', 'waf_variant', 'waf_std', 'waf_mpi', 'bibpyt/Macro/macr_ecre_calc_ops.py'):
+ file2patch = os.path.join(self.workdir, self.content, f2p)
+ self._print('FreeBSD patch: /bin/bash => modify ' + file2patch)