aboutsummaryrefslogtreecommitdiff
path: root/french
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2019-12-25 13:35:06 +0000
committerThierry Thomas <thierry@FreeBSD.org>2019-12-25 13:35:06 +0000
commitbda7766bf02f3fed569755d08ed512dc737f3d9f (patch)
tree859ea050b84131bd626586ec893593156ac72526 /french
parent2f79480472f1c6ab5a69d1b63fcd768ed48b0d67 (diff)
downloadports-bda7766bf02f3fed569755d08ed512dc737f3d9f.tar.gz
ports-bda7766bf02f3fed569755d08ed512dc737f3d9f.zip
Let Code_Aster use Python-3.7.
Notes
Notes: svn path=/head/; revision=520858
Diffstat (limited to 'french')
-rw-r--r--french/aster/Makefile5
-rw-r--r--french/homard/Makefile9
2 files changed, 8 insertions, 6 deletions
diff --git a/french/aster/Makefile b/french/aster/Makefile
index fe08d8df5da7..9476b64591be 100644
--- a/french/aster/Makefile
+++ b/french/aster/Makefile
@@ -3,6 +3,7 @@
PORTNAME= aster
DISTVERSION= ${ASTER_DISTVERSION}
+PORTREVISION= 1
CATEGORIES= french cad
MAINTAINER= thierry@FreeBSD.org
@@ -48,7 +49,7 @@ LIB_DEPENDS+= libhdf5.so:science/hdf5 \
RUN_DEPENDS+= ${SHELL_INSTALL_ASTER}:shells/${SHIADEP} \
astk-serveur>0:cad/astk-serveur
-USES= bison fortran gettext python:3.6 qt:5 tk
+USES= bison fortran gettext python:3.6+ qt:5 tk
USE_BINUTILS= yes
USE_QT= linguisttools_build
@@ -88,7 +89,7 @@ INTERACTIVE_SCRIPTS= check_compilers.py setup.py
.if ${OPSYS} == FreeBSD && ((${OSREL:R} <= 12 && ${OSVERSION} < 1201506) \
|| (${OSREL:R} > 12 && ${OSVERSION} < 1300068))
-BROKEN= a larger value of ARG_MAX is needed for Code_Aster, please upgrade your system
+#BROKEN= a larger value of ARG_MAX is needed for Code_Aster, please upgrade your system
.endif
.if ${ARCH} == "i386"
diff --git a/french/homard/Makefile b/french/homard/Makefile
index 8fc98ce6c9ab..2687f9410550 100644
--- a/french/homard/Makefile
+++ b/french/homard/Makefile
@@ -3,22 +3,23 @@
PORTNAME= homard
DISTVERSION= 11.12-aster2
+PORTREVISION= 1
CATEGORIES= french cad linux
MAINTAINER= thierry@FreeBSD.org
COMMENT= Refinement and de-refinement mesh tool
+ONLY_FOR_ARCHS= amd64 i386
+
BUILD_DEPENDS= ${LOCALBASE}/aster/${VER}/bin/aster:french/aster
RUN_DEPENDS= ${LOCALBASE}/bin/bash:shells/bash \
${LOCALBASE}/aster/${VER}/bin/aster:french/aster
+USES= linux python:3.6+ shebangfix
+
RESTRICTED= The free downloading of HOMARD software is only allowed for coupling\
with Code_Aster. For any other use, a license agreement is requested.\
Please contact HOMARD project: <homard@edf.fr>.
-
-ONLY_FOR_ARCHS= amd64 i386
-
-USES= linux python:3.6 shebangfix
SHEBANG_FILES= ${WRKSRC}/ASTER_HOMARD/homard \
${WRKSRC}/homard_base ${WRKSRC}/setup_homard.py
REINPLACE_ARGS= -i ""