aboutsummaryrefslogtreecommitdiff
path: root/ftp/R-cran-curl
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2016-01-27 05:47:13 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2016-01-27 05:47:13 +0000
commit1419bfea36801032e127f9d1cfaf3ee250e35e9f (patch)
tree39f01e8be6dca7ce741c5fc91e7aadcb294ab3f7 /ftp/R-cran-curl
parentfc696a0ac037364eb26dcb1cde25350cebca2f2d (diff)
downloadports-1419bfea36801032e127f9d1cfaf3ee250e35e9f.tar.gz
ports-1419bfea36801032e127f9d1cfaf3ee250e35e9f.zip
- Update to 0.9.5
- Cosmetic change
Notes
Notes: svn path=/head/; revision=407337
Diffstat (limited to 'ftp/R-cran-curl')
-rw-r--r--ftp/R-cran-curl/Makefile4
-rw-r--r--ftp/R-cran-curl/distinfo4
-rw-r--r--ftp/R-cran-curl/files/patch-src_nslookup.c11
3 files changed, 15 insertions, 4 deletions
diff --git a/ftp/R-cran-curl/Makefile b/ftp/R-cran-curl/Makefile
index 145d81e1bd88..756edd85d0d7 100644
--- a/ftp/R-cran-curl/Makefile
+++ b/ftp/R-cran-curl/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= curl
-PORTVERSION= 0.9.4
+PORTVERSION= 0.9.5
CATEGORIES= ftp
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -17,6 +17,6 @@ LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
USES= cran:auto-plist
post-patch:
- @${REINPLACE_CMD} -e 's|bin/bash|bin/sh|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/bin\//s|bash|sh|' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/ftp/R-cran-curl/distinfo b/ftp/R-cran-curl/distinfo
index 9bf42ff8d519..f4ea94fb2e2e 100644
--- a/ftp/R-cran-curl/distinfo
+++ b/ftp/R-cran-curl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (curl_0.9.4.tar.gz) = 86bab55fb6097adf27c43c5cb45515533fbfe2a7a7666a5217b6f0ac6a88bcd9
-SIZE (curl_0.9.4.tar.gz) = 245598
+SHA256 (curl_0.9.5.tar.gz) = f5832e217b04c600da85be9661b113694c67c32516c947433c02d28d2d69a833
+SIZE (curl_0.9.5.tar.gz) = 261496
diff --git a/ftp/R-cran-curl/files/patch-src_nslookup.c b/ftp/R-cran-curl/files/patch-src_nslookup.c
new file mode 100644
index 000000000000..06318651b2dc
--- /dev/null
+++ b/ftp/R-cran-curl/files/patch-src_nslookup.c
@@ -0,0 +1,11 @@
+--- src/nslookup.c.orig 2016-01-23 20:44:53 UTC
++++ src/nslookup.c
+@@ -8,6 +8,8 @@ const char *inet_ntop(int af, const void
+ #else
+ #include <netdb.h>
+ #include <arpa/inet.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
+ #endif
+
+ SEXP R_nslookup(SEXP hostname) {