aboutsummaryrefslogtreecommitdiff
path: root/ftp/R-cran-curl
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2015-08-09 21:46:54 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2015-08-09 21:46:54 +0000
commitc48e3b93ec663808f529b7821526e1c0ddd85d92 (patch)
treee2d9176fa26cbea166f70b69bb9470d28be062c1 /ftp/R-cran-curl
parentf345a9f4535bac1a5997bc0777071deb93edebac (diff)
downloadports-c48e3b93ec663808f529b7821526e1c0ddd85d92.tar.gz
ports-c48e3b93ec663808f529b7821526e1c0ddd85d92.zip
- Add new port: ftp/R-cran-curl
The curl() and curl_download() functions provide highly configurable drop-in replacements for base url() and download.file() with better performance, support for encryption (https://, ftps://), 'gzip' compression, authentication, and other 'libcurl' goodies. The core of the package implements a framework for performing fully customized requests where data can be processed either in memory, on disk, or streaming via the callback or connection interfaces. Some knowledge of 'libcurl' is recommended; for a more-user-friendly web client see the 'httr' package which builds on this package with HTTP specific tools and logic. WWW: https://cran.r-project.org/web/packages/curl/
Notes
Notes: svn path=/head/; revision=393829
Diffstat (limited to 'ftp/R-cran-curl')
-rw-r--r--ftp/R-cran-curl/Makefile19
-rw-r--r--ftp/R-cran-curl/distinfo2
-rw-r--r--ftp/R-cran-curl/pkg-descr12
3 files changed, 33 insertions, 0 deletions
diff --git a/ftp/R-cran-curl/Makefile b/ftp/R-cran-curl/Makefile
new file mode 100644
index 000000000000..b051c8ddf1ef
--- /dev/null
+++ b/ftp/R-cran-curl/Makefile
@@ -0,0 +1,19 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= curl
+PORTVERSION= 0.9.2
+CATEGORIES= ftp
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Modern and Flexible Web Client for R
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${LOCALBASE}/include/curl/curl.h:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>
diff --git a/ftp/R-cran-curl/distinfo b/ftp/R-cran-curl/distinfo
new file mode 100644
index 000000000000..07ae63d2d9f6
--- /dev/null
+++ b/ftp/R-cran-curl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (curl_0.9.2.tar.gz) = a6fe7126586cb9dee7128884b41667f68637c45931313628e475b27960efc966
+SIZE (curl_0.9.2.tar.gz) = 244688
diff --git a/ftp/R-cran-curl/pkg-descr b/ftp/R-cran-curl/pkg-descr
new file mode 100644
index 000000000000..0c00ff616b55
--- /dev/null
+++ b/ftp/R-cran-curl/pkg-descr
@@ -0,0 +1,12 @@
+The curl() and curl_download() functions provide highly configurable
+drop-in replacements for base url() and download.file() with better
+performance, support for encryption (https://, ftps://), 'gzip'
+compression, authentication, and other 'libcurl' goodies. The core
+of the package implements a framework for performing fully customized
+requests where data can be processed either in memory, on disk, or
+streaming via the callback or connection interfaces. Some knowledge
+of 'libcurl' is recommended; for a more-user-friendly web client
+see the 'httr' package which builds on this package with HTTP
+specific tools and logic.
+
+WWW: https://cran.r-project.org/web/packages/curl/