aboutsummaryrefslogtreecommitdiff
path: root/ftp/axel
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-18 09:22:52 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-18 09:22:52 +0000
commit0d3389bd1ea809bdf8dcacf3fb0e338560520e87 (patch)
tree18ae8b6418ec188581f5bb9de0751655df03f0d7 /ftp/axel
parente5e1edcd733ef12c5b8cbef6de33aa41082afa22 (diff)
downloadports-0d3389bd1ea809bdf8dcacf3fb0e338560520e87.tar.gz
ports-0d3389bd1ea809bdf8dcacf3fb0e338560520e87.zip
- Support PTHREAD_CFLAGS properly
- Support install macros PR: 29820 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Notes
Notes: svn path=/head/; revision=46431
Diffstat (limited to 'ftp/axel')
-rw-r--r--ftp/axel/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/ftp/axel/Makefile b/ftp/axel/Makefile
index 36eceed994ca..f042cda8bec5 100644
--- a/ftp/axel/Makefile
+++ b/ftp/axel/Makefile
@@ -17,15 +17,23 @@ LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt \
intl:${PORTSDIR}/devel/gettext
USE_GMAKE= yes
-CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
MAKE_ENV= LFLAGS="-L${LOCALBASE}/lib -lgnugetopt -lintl"
-MANCOMPRESSED= no
-MAN1= axel.1
+MAN1= axel.1
post-patch:
@${PERL} -pi -e "s,-pthread,${PTHREAD_LIBS},g ; \
s,^(CFLAGS = -O3),#\1,g ; \
s,gcc,${CC},g" ${WRKSRC}/Makefile
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/axel ${PREFIX}/bin/axel
+ ${INSTALL_DATA} ${WRKSRC}/axelrc.example ${PREFIX}/etc/axelrc
+ ${INSTALL_MAN} ${WRKSRC}/axel.1 ${PREFIX}/man/man1/axel.1
+.for lang in de nl
+ ${INSTALL_DATA} ${WRKSRC}/${lang}.mo \
+ ${PREFIX}/share/locale/${lang}/LC_MESSAGES/axel.mo
+.endfor
+
.include <bsd.port.mk>