aboutsummaryrefslogtreecommitdiff
path: root/ftp/axel
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-15 07:00:57 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-15 07:00:57 +0000
commit5a9ffdda7cd87a63421282a4de7e525d2d07d3ec (patch)
tree74d8d5ad57caced58527b8698a8b2fc493afa7d2 /ftp/axel
parentb0b1faedf190e0d279e17371ad0faa619dc9f2a5 (diff)
downloadports-5a9ffdda7cd87a63421282a4de7e525d2d07d3ec.tar.gz
ports-5a9ffdda7cd87a63421282a4de7e525d2d07d3ec.zip
upgrade to 0.96
Notes
Notes: svn path=/head/; revision=46267
Diffstat (limited to 'ftp/axel')
-rw-r--r--ftp/axel/Makefile17
-rw-r--r--ftp/axel/distinfo2
-rw-r--r--ftp/axel/files/patch-Makefile46
-rw-r--r--ftp/axel/files/patch-Makefile.settings31
-rw-r--r--ftp/axel/files/patch-axel.c16
-rw-r--r--ftp/axel/files/patch-axel.h20
-rw-r--r--ftp/axel/files/patch-conf.c37
-rw-r--r--ftp/axel/files/patch-conn.c24
-rw-r--r--ftp/axel/pkg-plist2
9 files changed, 19 insertions, 176 deletions
diff --git a/ftp/axel/Makefile b/ftp/axel/Makefile
index 06fefab1af47..36eceed994ca 100644
--- a/ftp/axel/Makefile
+++ b/ftp/axel/Makefile
@@ -7,22 +7,25 @@
#
PORTNAME= axel
-PORTVERSION= 0.94
+PORTVERSION= 0.96
CATEGORIES= ftp
MASTER_SITES= http://www.lintux.cx/downloads/
MAINTAINER= ports@FreeBSD.org
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt \
+ intl:${PORTSDIR}/devel/gettext
+
USE_GMAKE= yes
+CFLAGS+= -I${LOCALBASE}/include
+MAKE_ENV= LFLAGS="-L${LOCALBASE}/lib -lgnugetopt -lintl"
+MANCOMPRESSED= no
MAN1= axel.1
post-patch:
- @${PERL} -pi -e "s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/Makefile
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/axel ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/axelrc.example ${PREFIX}/etc/axelrc
- ${INSTALL_MAN} ${WRKSRC}/axel.1 ${PREFIX}/man/man1
+ @${PERL} -pi -e "s,-pthread,${PTHREAD_LIBS},g ; \
+ s,^(CFLAGS = -O3),#\1,g ; \
+ s,gcc,${CC},g" ${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/ftp/axel/distinfo b/ftp/axel/distinfo
index ef8ff5a5bb25..cbbbdf4f5681 100644
--- a/ftp/axel/distinfo
+++ b/ftp/axel/distinfo
@@ -1 +1 @@
-MD5 (axel-0.94.tar.gz) = 921cf8736645bc3bb8008d359f1e8242
+MD5 (axel-0.96.tar.gz) = 04ff83e283019ea624018d72cda9d004
diff --git a/ftp/axel/files/patch-Makefile b/ftp/axel/files/patch-Makefile
deleted file mode 100644
index bd53439a36ba..000000000000
--- a/ftp/axel/files/patch-Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
---- Makefile.orig Wed Jun 27 16:48:03 2001
-+++ Makefile Sun Aug 5 23:39:13 2001
-@@ -12,11 +12,20 @@
- ifdef DEBUG
- CFLAGS = -DDEBUG -g
- else
--CFLAGS = -O3
-+endif
-+
-+ifndef GETOPTLONG
-+CFLAGS += -DNOGETOPTLONG
- endif
-
- .SUFFIXES: .po .mo
-
-+# determine host OS type
-+HOSTTYPE=$(shell uname)
-+ifeq ($(HOSTTYPE),Darwin)
-+CFLAGS += -DDARWIN
-+endif
-+
- ### Add your translation here..
- MOFILES = nl.mo de.mo
-
-@@ -32,8 +41,12 @@
- endif
-
- ifdef THREADS
-+ifeq ($(HOSTTYPE),FreeBSD)
-+LFLAGS += -pthread
-+else
- LFLAGS += -lpthread
- endif
-+endif
-
- clean:
- rm -f *.o axel *.mo config.h
-@@ -68,7 +81,7 @@
- rm -f $(BINDIR)/axel
-
- config.h: Makefile.settings
-- make clean
-+ $(MAKE) clean
- @echo '/* Generated by Makefile, do not edit! */' > config.h
- @echo '/* Edit Makefile.settings instead */' >> config.h
- @echo >> config.h
diff --git a/ftp/axel/files/patch-Makefile.settings b/ftp/axel/files/patch-Makefile.settings
index 1c2255d12e93..90bd3ddbad91 100644
--- a/ftp/axel/files/patch-Makefile.settings
+++ b/ftp/axel/files/patch-Makefile.settings
@@ -1,32 +1,13 @@
---- Makefile.settings.orig Mon Jun 18 01:18:20 2001
-+++ Makefile.settings Sun Aug 5 23:40:00 2001
-@@ -7,10 +7,9 @@
-
- # File locations
- #
--PREFIX=/usr
+--- Makefile.settings.orig Thu Aug 9 01:41:45 2001
++++ Makefile.settings Wed Aug 15 14:22:02 2001
+@@ -11,8 +11,8 @@
+ PREFIX=/usr/local
+ endif
BINDIR=$(PREFIX)/bin
-ETCDIR=/etc
-MANDIR=$(PREFIX)/share/man
-+ETCDIR=$(PREFIX)/etc
++ETCDIR=${PREFIX}/etc
+MANDIR=$(PREFIX)/man
LOCALE=$(PREFIX)/share/locale
# NOTE: Disabling an option means commenting out the specific line. Changing
-@@ -26,7 +25,7 @@
- # will make the binary 4KB larger. You also have to tell where the
- # translations should be installed.
- #
--I18N=1
-+#I18N=1
-
- # Disabling this converts axel to a simple downloader like wget, without
- # support for multiple connections. Do it if you like small programs. ;)
-@@ -42,3 +41,7 @@
- # Necessary for package creation
- #
- DESTDIR=
-+
-+#
-+# Some OS'es don't have getopt_long
-+#GETOPTLONG=1
diff --git a/ftp/axel/files/patch-axel.c b/ftp/axel/files/patch-axel.c
deleted file mode 100644
index 1bbad1179f25..000000000000
--- a/ftp/axel/files/patch-axel.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- axel.c.orig Sun Aug 5 23:40:26 2001
-+++ axel.c Sun Aug 5 23:41:19 2001
-@@ -797,10 +797,11 @@
- void *setup_thread( void *c )
- {
- conn_t *conn = c;
-+ int oldstate;
-
- /* Allow this thread to be killed at any time. */
-- pthread_setcancelstate( PTHREAD_CANCEL_ENABLE, NULL );
-- pthread_setcanceltype( PTHREAD_CANCEL_ASYNCHRONOUS, NULL );
-+ pthread_setcancelstate( PTHREAD_CANCEL_ENABLE, &oldstate );
-+ pthread_setcanceltype( PTHREAD_CANCEL_ASYNCHRONOUS, &oldstate );
-
- if( conn_setup( conn ) )
- {
diff --git a/ftp/axel/files/patch-axel.h b/ftp/axel/files/patch-axel.h
deleted file mode 100644
index 632349710d73..000000000000
--- a/ftp/axel/files/patch-axel.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- axel.h.orig Sun Aug 5 23:41:50 2001
-+++ axel.h Sun Aug 5 23:42:26 2001
-@@ -30,7 +30,9 @@
- #include <errno.h>
- #include <stdio.h>
- #include <netdb.h>
-+#ifndef NOGETOPTLONG
- #include <getopt.h>
-+#endif
- #include <limits.h>
- #include <stdlib.h>
- #include <unistd.h>
-@@ -41,6 +43,7 @@
- #include <sys/time.h>
- #include <sys/types.h>
- #include <sys/socket.h>
-+#include <netinet/in_systm.h>
- #include <netinet/in.h>
- #include <netinet/ip.h>
-
diff --git a/ftp/axel/files/patch-conf.c b/ftp/axel/files/patch-conf.c
deleted file mode 100644
index 7a5ea16c3548..000000000000
--- a/ftp/axel/files/patch-conf.c
+++ /dev/null
@@ -1,37 +0,0 @@
---- conf.c.orig Sun Aug 5 23:42:46 2001
-+++ conf.c Sun Aug 5 23:44:29 2001
-@@ -39,6 +39,7 @@
- sscanf( value, "%i", &conf->name ); \
- }
-
-+#ifndef NOGETOPTLONG
- struct option axel_options[] =
- {
- /* name has_arg flag val */
-@@ -50,6 +51,7 @@
- { "version", 0, NULL, 'V' },
- { NULL, 0, NULL, 0 }
- };
-+#endif
-
- int conf_loadfile( conf_t *conf, char *file )
- {
-@@ -144,7 +146,17 @@
-
- while( 1 )
- {
-- option = getopt_long( argc, argv, "s:n:NqhV", axel_options, NULL );
-+ option =
-+#ifdef NOGETOPTLONG
-+ getopt
-+#else
-+ getopt_long
-+#endif
-+ ( argc, argv, "s:n:NqhV"
-+#ifndef NOGETOPTLONG
-+ , axel_options, NULL
-+#endif
-+ );
- if( option == -1 )
- break;
-
diff --git a/ftp/axel/files/patch-conn.c b/ftp/axel/files/patch-conn.c
deleted file mode 100644
index 89132cf595e0..000000000000
--- a/ftp/axel/files/patch-conn.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- conn.c.orig Sun Aug 5 23:44:46 2001
-+++ conn.c Sun Aug 5 23:45:38 2001
-@@ -121,6 +121,13 @@
- /* Take default port numbers from /etc/services */
- else
- {
-+#ifdef DARWIN
-+ /* don't want to include a NetInfo interface */
-+ if( conn->proto == PROTO_FTP )
-+ conn->port = 21;
-+ else
-+ conn->port = 80;
-+#else
- struct servent *serv;
-
- /* Never assume the standard 21/80 ports!! */
-@@ -130,6 +137,7 @@
- serv = getservbyname( "www", "tcp" );
-
- conn->port = ntohs( serv->s_port );
-+#endif
- }
-
- return( conn->port > 0 );
diff --git a/ftp/axel/pkg-plist b/ftp/axel/pkg-plist
index 6bb711b43f54..13d4e2c34284 100644
--- a/ftp/axel/pkg-plist
+++ b/ftp/axel/pkg-plist
@@ -1,2 +1,4 @@
bin/axel
etc/axelrc
+share/locale/de/LC_MESSAGES/axel.mo
+share/locale/nl/LC_MESSAGES/axel.mo