aboutsummaryrefslogtreecommitdiff
path: root/ftp/axel
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2005-04-17 15:12:00 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2005-04-17 15:12:00 +0000
commit9005faa3fa0055377a7c1203feafa1c37f983e48 (patch)
treed8283b37572e43698a0900e99748a25d2a2969c3 /ftp/axel
parentb02bef41212c315e23a66c4a69a199e06e31b101 (diff)
downloadports-9005faa3fa0055377a7c1203feafa1c37f983e48.tar.gz
ports-9005faa3fa0055377a7c1203feafa1c37f983e48.zip
Fix remote buffer overflow.
Submitted by: Ulf Harnhammar <metaur@telia.com>
Notes
Notes: svn path=/head/; revision=133525
Diffstat (limited to 'ftp/axel')
-rw-r--r--ftp/axel/Makefile2
-rw-r--r--ftp/axel/files/patch-conn.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/ftp/axel/Makefile b/ftp/axel/Makefile
index 81b26b85144a..91b0e38ea595 100644
--- a/ftp/axel/Makefile
+++ b/ftp/axel/Makefile
@@ -8,7 +8,7 @@
PORTNAME= axel
PORTVERSION= 1.0a
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= ftp
MASTER_SITES= http://www.lintux.cx/downloads/
diff --git a/ftp/axel/files/patch-conn.c b/ftp/axel/files/patch-conn.c
new file mode 100644
index 000000000000..b5d73713eb4f
--- /dev/null
+++ b/ftp/axel/files/patch-conn.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- conn.c.orig
++++ conn.c
+@@ -321,7 +321,7 @@
+ break;
+ if( ( t = http_header( conn->http, "location:" ) ) == NULL )
+ return( 0 );
+- sscanf( t, "%s", s );
++ sscanf( t, "%255s", s );
+ if( strstr( s, "://" ) == NULL)
+ {
+ sprintf( conn->http->headers, "%s%s",