aboutsummaryrefslogtreecommitdiff
path: root/ftp/bsdftpd-ssl
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-04-06 15:06:19 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-04-06 15:06:19 +0000
commit93fd733ccc0106c52a3bdcaf35a09633f4e622f2 (patch)
tree66da86164fbb49211bb34640adc2800698ce9072 /ftp/bsdftpd-ssl
parente6f5bb48bbfabc6388f177687116bdd97900535b (diff)
downloadports-93fd733ccc0106c52a3bdcaf35a09633f4e622f2.tar.gz
ports-93fd733ccc0106c52a3bdcaf35a09633f4e622f2.zip
Add BSDftpd-ssl, an RFC 2228 compliant TLS/SSL-enhanced FTP server.
PR: 44756 Submitted by: Nick Leuta <skynick@stu.lipetsk.ru>
Notes
Notes: svn path=/head/; revision=78426
Diffstat (limited to 'ftp/bsdftpd-ssl')
-rw-r--r--ftp/bsdftpd-ssl/Makefile99
-rw-r--r--ftp/bsdftpd-ssl/distinfo1
-rw-r--r--ftp/bsdftpd-ssl/files/pkg-descr.client7
-rw-r--r--ftp/bsdftpd-ssl/files/pkg-message.server2
-rw-r--r--ftp/bsdftpd-ssl/files/pkg-plist.client20
-rw-r--r--ftp/bsdftpd-ssl/pkg-descr7
-rw-r--r--ftp/bsdftpd-ssl/pkg-plist21
7 files changed, 157 insertions, 0 deletions
diff --git a/ftp/bsdftpd-ssl/Makefile b/ftp/bsdftpd-ssl/Makefile
new file mode 100644
index 000000000000..98bda467fc25
--- /dev/null
+++ b/ftp/bsdftpd-ssl/Makefile
@@ -0,0 +1,99 @@
+# New ports collection makefile for: bsdftpd-ssl
+# Date created: 5 Apr 2003
+# Whom: Nick Leuta
+#
+# $FreeBSD$
+#
+
+PORTNAME= bsdftpd-ssl
+PORTVERSION= 0.6.2
+CATEGORIES= ftp
+MASTER_SITES= http://bsdftpd-ssl.sc.ru/files/bsdftpd-ssl/archive/0.6/src/
+DISTNAME= bsdftpd-6.0-ssl-${PORTVERSION}
+
+MAINTAINER= skynick@mail.sc.ru
+
+# Client only part
+.if defined(CLIENT_ONLY)
+PKGNAMESUFFIX= -client
+COMMENT= FTP command-line client utility with TLS/SSL support
+DESCR= ${FILESDIR}/pkg-descr.client
+PLIST= ${FILESDIR}/pkg-plist.client
+.endif
+# Client part
+MAN1= ftps.1
+# Server part
+.if !defined(CLIENT_ONLY)
+COMMENT= FTP server with TLS/SSL support
+MAN8= ftpd.8
+MLINKS= ftpd.8 ftpd-ssl.8
+PKGMESSAGE= ${FILESDIR}/pkg-message.server
+.endif
+
+MANCOMPRESSED= yes
+USE_OPENSSL= yes
+
+BINOWN= root
+BINGRP= wheel
+SHAREOWN= ${BINOWN}
+SHAREGRP= ${BINGRP}
+MANOWN= ${BINOWN}
+MANGRP= ${BINGRP}
+BINMODE= 555
+SHAREMODE= 444
+MANMODE= ${SHAREMODE}
+
+MANDIR= ${PREFIX}/man/man
+DOCDIR= ${DOCSDIR}${PKGNAMESUFFIX}
+
+pre-build:
+ (cd ${WRKSRC} && ./config.sh FreeBSD) || exit
+do-build:
+# Client part
+ (cd ${WRKSRC}/port && make && cd ${WRKSRC}/ftp && make) || exit
+# Server part
+.if !defined(CLIENT_ONLY)
+ (cd ${WRKSRC}/ftpd && make) || exit
+.endif
+
+do-install:
+# Client part
+ ${INSTALL_PROGRAM} ${WRKSRC}/ftp/ftps ${PREFIX}/bin/ftps
+ ${INSTALL_MAN} ${WRKSRC}/ftp/ftps.1.gz ${MANDIR}1/ftps.1.gz
+# Server part
+.if !defined(CLIENT_ONLY)
+ ${INSTALL_PROGRAM} ${WRKSRC}/ftpd/ftpd ${PREFIX}/libexec/ftpd
+ ${INSTALL_MAN} ${WRKSRC}/ftpd/ftpd.8.gz ${MANDIR}8/ftpd.8.gz
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCDIR}
+ ${INSTALL_DATA} -p ${WRKSRC}/COPYRIGHT ${DOCDIR}/COPYRIGHT
+ ${INSTALL_DATA} -p ${WRKSRC}/README ${DOCDIR}/README
+ ${INSTALL_DATA} -p ${WRKSRC}/INSTALL ${DOCDIR}/INSTALL
+ ${INSTALL_DATA} -p ${WRKSRC}/ChangeLog ${DOCDIR}/ChangeLog
+
+ ${MKDIR} ${DOCDIR}/docs
+ ${INSTALL_DATA} -p ${WRKSRC}/docs/README ${DOCDIR}/docs/README
+ ${INSTALL_DATA} -p ${WRKSRC}/docs/cert-basics.txt ${DOCDIR}/docs/cert-basics.txt
+ ${INSTALL_DATA} -p ${WRKSRC}/docs/cert-howto.txt ${DOCDIR}/docs/cert-howto.txt
+ ${INSTALL_DATA} -p ${WRKSRC}/docs/ciphers.txt ${DOCDIR}/docs/ciphers.txt
+ ${INSTALL_DATA} -p ${WRKSRC}/docs/licenses ${DOCDIR}/docs/licenses
+ ${INSTALL_DATA} -p ${WRKSRC}/docs/standards.txt ${DOCDIR}/docs/standards.txt
+ ${INSTALL_DATA} -p ${WRKSRC}/docs/verify.txt ${DOCDIR}/docs/verify.txt
+ ${INSTALL_DATA} -p ${WRKSRC}/docs/x509_auth.txt ${DOCDIR}/docs/x509_auth.txt
+
+ ${MKDIR} ${DOCDIR}/cert
+ ${INSTALL_SCRIPT} -p ${WRKSRC}/cert/cert-nopass.sh ${DOCDIR}/cert/cert-nopass.sh
+ ${INSTALL_SCRIPT} -p ${WRKSRC}/cert/cert-pass.sh ${DOCDIR}/cert/cert-pass.sh
+ ${INSTALL_SCRIPT} -p ${WRKSRC}/cert/dummy.sh ${DOCDIR}/cert/dummy.sh
+ ${INSTALL_SCRIPT} -p ${WRKSRC}/cert/xCA.sh ${DOCDIR}/cert/xCA.sh
+.endif
+.if !defined(CLIENT_ONLY)
+ @${ECHO_CMD} "*******************************************************************************"
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD} "*******************************************************************************"
+.endif
+
+.include <bsd.port.mk>
diff --git a/ftp/bsdftpd-ssl/distinfo b/ftp/bsdftpd-ssl/distinfo
new file mode 100644
index 000000000000..686e06c566a1
--- /dev/null
+++ b/ftp/bsdftpd-ssl/distinfo
@@ -0,0 +1 @@
+MD5 (bsdftpd-6.0-ssl-0.6.2.tar.gz) = 68cdc150477d494913ffbecb279a32bf
diff --git a/ftp/bsdftpd-ssl/files/pkg-descr.client b/ftp/bsdftpd-ssl/files/pkg-descr.client
new file mode 100644
index 000000000000..8932014f5cea
--- /dev/null
+++ b/ftp/bsdftpd-ssl/files/pkg-descr.client
@@ -0,0 +1,7 @@
+BSDftpd-ssl is a TLS/SSL-enhanced FTP server. This package contains
+command-line FTP client utility (ftps). The TLS/SSL enhancement allows RFC2228
+"FTP Security Extensions"-compliant TLS/SSL support for both control and data
+connections; with standard FTP servers this software operates as the standard
+FTP client.
+
+WWW: http://bsdftpd-ssl.sc.ru
diff --git a/ftp/bsdftpd-ssl/files/pkg-message.server b/ftp/bsdftpd-ssl/files/pkg-message.server
new file mode 100644
index 000000000000..06081d4ac727
--- /dev/null
+++ b/ftp/bsdftpd-ssl/files/pkg-message.server
@@ -0,0 +1,2 @@
+You will also need to read "Configuration" and "Supplement information" parts
+of INSTALL file from package documentation for subsequent configuration issues.
diff --git a/ftp/bsdftpd-ssl/files/pkg-plist.client b/ftp/bsdftpd-ssl/files/pkg-plist.client
new file mode 100644
index 000000000000..9c3b94b79af6
--- /dev/null
+++ b/ftp/bsdftpd-ssl/files/pkg-plist.client
@@ -0,0 +1,20 @@
+bin/ftps
+%%PORTDOCS%%share/doc/bsdftpd-ssl-client/COPYRIGHT
+%%PORTDOCS%%share/doc/bsdftpd-ssl-client/README
+%%PORTDOCS%%share/doc/bsdftpd-ssl-client/INSTALL
+%%PORTDOCS%%share/doc/bsdftpd-ssl-client/ChangeLog
+%%PORTDOCS%%share/doc/bsdftpd-ssl-client/cert/cert-nopass.sh
+%%PORTDOCS%%share/doc/bsdftpd-ssl-client/cert/cert-pass.sh
+%%PORTDOCS%%share/doc/bsdftpd-ssl-client/cert/dummy.sh
+%%PORTDOCS%%share/doc/bsdftpd-ssl-client/cert/xCA.sh
+%%PORTDOCS%%share/doc/bsdftpd-ssl-client/docs/README
+%%PORTDOCS%%share/doc/bsdftpd-ssl-client/docs/cert-basics.txt
+%%PORTDOCS%%share/doc/bsdftpd-ssl-client/docs/cert-howto.txt
+%%PORTDOCS%%share/doc/bsdftpd-ssl-client/docs/ciphers.txt
+%%PORTDOCS%%share/doc/bsdftpd-ssl-client/docs/licenses
+%%PORTDOCS%%share/doc/bsdftpd-ssl-client/docs/standards.txt
+%%PORTDOCS%%share/doc/bsdftpd-ssl-client/docs/verify.txt
+%%PORTDOCS%%share/doc/bsdftpd-ssl-client/docs/x509_auth.txt
+%%PORTDOCS%%@dirrm share/doc/bsdftpd-ssl-client/cert
+%%PORTDOCS%%@dirrm share/doc/bsdftpd-ssl-client/docs
+%%PORTDOCS%%@dirrm share/doc/bsdftpd-ssl-client
diff --git a/ftp/bsdftpd-ssl/pkg-descr b/ftp/bsdftpd-ssl/pkg-descr
new file mode 100644
index 000000000000..3bd1cd598f19
--- /dev/null
+++ b/ftp/bsdftpd-ssl/pkg-descr
@@ -0,0 +1,7 @@
+BSDftpd-ssl is a TLS/SSL-enhanced FTP server. The TLS/SSL enhancement allows
+RFC2228 "FTP Security Extensions"-compliant TLS/SSL support for both control
+and data connections. This package contains FTP server (ftpd) and command-line
+FTP client utility (ftps). Server and client are fully compatible with standard
+FTP protocol.
+
+WWW: http://bsdftpd-ssl.sc.ru
diff --git a/ftp/bsdftpd-ssl/pkg-plist b/ftp/bsdftpd-ssl/pkg-plist
new file mode 100644
index 000000000000..267d218f2f2d
--- /dev/null
+++ b/ftp/bsdftpd-ssl/pkg-plist
@@ -0,0 +1,21 @@
+bin/ftps
+libexec/ftpd
+%%PORTDOCS%%share/doc/bsdftpd-ssl/COPYRIGHT
+%%PORTDOCS%%share/doc/bsdftpd-ssl/README
+%%PORTDOCS%%share/doc/bsdftpd-ssl/INSTALL
+%%PORTDOCS%%share/doc/bsdftpd-ssl/ChangeLog
+%%PORTDOCS%%share/doc/bsdftpd-ssl/cert/cert-nopass.sh
+%%PORTDOCS%%share/doc/bsdftpd-ssl/cert/cert-pass.sh
+%%PORTDOCS%%share/doc/bsdftpd-ssl/cert/dummy.sh
+%%PORTDOCS%%share/doc/bsdftpd-ssl/cert/xCA.sh
+%%PORTDOCS%%share/doc/bsdftpd-ssl/docs/README
+%%PORTDOCS%%share/doc/bsdftpd-ssl/docs/cert-basics.txt
+%%PORTDOCS%%share/doc/bsdftpd-ssl/docs/cert-howto.txt
+%%PORTDOCS%%share/doc/bsdftpd-ssl/docs/ciphers.txt
+%%PORTDOCS%%share/doc/bsdftpd-ssl/docs/licenses
+%%PORTDOCS%%share/doc/bsdftpd-ssl/docs/standards.txt
+%%PORTDOCS%%share/doc/bsdftpd-ssl/docs/verify.txt
+%%PORTDOCS%%share/doc/bsdftpd-ssl/docs/x509_auth.txt
+%%PORTDOCS%%@dirrm share/doc/bsdftpd-ssl/cert
+%%PORTDOCS%%@dirrm share/doc/bsdftpd-ssl/docs
+%%PORTDOCS%%@dirrm share/doc/bsdftpd-ssl