aboutsummaryrefslogtreecommitdiff
path: root/ftp/bsdftpd-ssl
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-02 23:23:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-02 23:23:55 +0000
commitbb56456c2c858df333e8bfdcbcdbc203718a4e81 (patch)
tree54509913e5d0af01c0b72ec9c97ed3dbfbb22446 /ftp/bsdftpd-ssl
parentd37060630bf51cd32d6222d3ade76950e3a71d36 (diff)
downloadports-bb56456c2c858df333e8bfdcbcdbc203718a4e81.tar.gz
ports-bb56456c2c858df333e8bfdcbcdbc203718a4e81.zip
- Update to 1.0.1
PR: ports/63650 Submitted by: Nick Leuta <skynick@mail.sc.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=102777
Diffstat (limited to 'ftp/bsdftpd-ssl')
-rw-r--r--ftp/bsdftpd-ssl/Makefile13
-rw-r--r--ftp/bsdftpd-ssl/distinfo2
-rw-r--r--ftp/bsdftpd-ssl/files/bsdftpd-ssl.sh30
-rw-r--r--ftp/bsdftpd-ssl/files/patch-aa40
-rw-r--r--ftp/bsdftpd-ssl/files/pkg-message.server14
-rw-r--r--ftp/bsdftpd-ssl/pkg-plist1
6 files changed, 54 insertions, 46 deletions
diff --git a/ftp/bsdftpd-ssl/Makefile b/ftp/bsdftpd-ssl/Makefile
index a536d108fba0..6c54184ff3b2 100644
--- a/ftp/bsdftpd-ssl/Makefile
+++ b/ftp/bsdftpd-ssl/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= bsdftpd-ssl
-PORTVERSION= 1.0.0
-PORTREVISION= 1
+PORTVERSION= 1.0.1
+PORTREVISION= 0
CATEGORIES= ftp
MASTER_SITES= http://bsdftpd-ssl.sc.ru/files/bsdftpd-ssl/archive/1.0/src/
DISTNAME= bsdftpd-ssl-${PORTVERSION}
@@ -26,10 +26,11 @@ MAN1= ftps.1
# Server part
.if !defined(CLIENT_ONLY)
COMMENT= Secure FTP server with the TLS/SSL support
-MAN5= ftpchroot.5
+MAN5= ftpchroot.5 xferlog.5
MAN8= ftpd.8
MLINKS= ftpd.8 ftpd-ssl.8
-PKGMESSAGE= ${FILESDIR}/pkg-message.server
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SED_ARG= 's|%%PREFIX%%|${PREFIX}|g; s|%%DOCSDIR%%|${DOCSDIR}|g'
.endif
MANCOMPRESSED= yes
@@ -56,6 +57,8 @@ do-build:
# Server part
.if !defined(CLIENT_ONLY)
(cd ${WRKSRC}/ftpd && make) || exit
+ @${SED} ${SED_ARG} ${FILESDIR}/pkg-message.server > \
+ ${WRKDIR}/pkg-message
.endif
do-install:
@@ -66,6 +69,7 @@ do-install:
.if !defined(CLIENT_ONLY)
${INSTALL_PROGRAM} ${WRKSRC}/ftpd/ftpd ${PREFIX}/libexec/ftpd
${INSTALL_MAN} ${WRKSRC}/ftpd/ftpchroot.5.gz ${MANDIR}5/ftpchroot.5.gz
+ ${INSTALL_MAN} ${WRKSRC}/ftpd/xferlog.5.gz ${MANDIR}5/xferlog.5.gz
${INSTALL_MAN} ${WRKSRC}/ftpd/ftpd.8.gz ${MANDIR}8/ftpd.8.gz
.endif
@@ -94,6 +98,7 @@ post-install:
${INSTALL_SCRIPT} -p ${WRKSRC}/cert/xCA.sh ${DOCDIR}/cert/xCA.sh
.endif
.if !defined(CLIENT_ONLY)
+ @${INSTALL_SCRIPT} ${FILESDIR}/bsdftpd-ssl.sh ${PREFIX}/etc/rc.d/bsdftpd-ssl.sh.sample
@${ECHO_CMD} "*******************************************************************************"
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD} "*******************************************************************************"
diff --git a/ftp/bsdftpd-ssl/distinfo b/ftp/bsdftpd-ssl/distinfo
index 2c61dbc6a1b7..ca70612e5ab9 100644
--- a/ftp/bsdftpd-ssl/distinfo
+++ b/ftp/bsdftpd-ssl/distinfo
@@ -1 +1 @@
-MD5 (bsdftpd-ssl-1.0.0.tar.gz) = 745befccb117d08aa0e37ea592dfb48c
+MD5 (bsdftpd-ssl-1.0.1.tar.gz) = fe77f5a8631c01aa85f969355fba3b69
diff --git a/ftp/bsdftpd-ssl/files/bsdftpd-ssl.sh b/ftp/bsdftpd-ssl/files/bsdftpd-ssl.sh
new file mode 100644
index 000000000000..7ac97ef97405
--- /dev/null
+++ b/ftp/bsdftpd-ssl/files/bsdftpd-ssl.sh
@@ -0,0 +1,30 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ if [ -x ${PREFIX}/libexec/ftpd ]; then
+ ${PREFIX}/libexec/ftpd -D -l -p /var/run/ftpd.pid > /dev/null
+ echo -n ' BSDftpd-ssl'
+ fi
+ ;;
+stop)
+ if [ -r /var/run/ftpd.pid ]; then
+ kill -TERM `cat /var/run/ftpd.pid`
+ rm -f /var/run/ftpd.pid
+ echo -n ' BSDftpd-ssl'
+ fi
+ ;;
+*)
+ echo ""
+ echo "Usage: `basename $0` { start | stop }"
+ echo ""
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/ftp/bsdftpd-ssl/files/patch-aa b/ftp/bsdftpd-ssl/files/patch-aa
deleted file mode 100644
index 533d6dab3b3c..000000000000
--- a/ftp/bsdftpd-ssl/files/patch-aa
+++ /dev/null
@@ -1,40 +0,0 @@
---- ftpd/Makefile.FreeBSD.ORI Wed Oct 8 00:59:49 2003
-+++ ftpd/Makefile.FreeBSD Mon Jan 12 00:33:53 2004
-@@ -44,7 +44,7 @@
- CFLAGS+=-Wall
- ## Feature flags
- CFLAGS+=-DSETPROCTITLE -DLOGIN_CAP -DVIRTUAL_HOSTING
--CFLAGS+=-DUSE_SENDFILE
-+#CFLAGS+=-DUSE_SENDFILE
- #CFLAGS+=-DINET6
-
- YFLAGS=
---- ftpd/ftpd.c.ORI Mon Nov 10 11:42:45 2003
-+++ ftpd/ftpd.c Mon Jan 12 00:36:04 2004
-@@ -2810,6 +2810,17 @@
- goto oldway;
- } else
- #endif /* USE_SSL */
-+/* workaround for the problem described in
-+ * http://bsdftpd-ssl.sc.ru/news/bfa_20040112.txt */
-+#if __FreeBSD__ >= 5
-+# if __FreeBSD_version >= 502000
-+# define USE_SENDFILE = 1
-+# endif
-+#else
-+# if __FreeBSD_version > 490000
-+# define USE_SENDFILE = 1
-+# endif
-+#endif /* __FreeBSD__ */
- #ifdef USE_SENDFILE
- while (err != -1 && filesize > 0) {
- #ifdef LINUX /* Linux port */
-@@ -2834,7 +2845,7 @@
-
- if (err == -1) {
- #ifndef LINUX /* BSD source */
-- if (errno == EAGAIN) {
-+ if (errno == EAGAIN || errno == EINTR) {
- err = 0;
- continue;
- }
diff --git a/ftp/bsdftpd-ssl/files/pkg-message.server b/ftp/bsdftpd-ssl/files/pkg-message.server
index 06081d4ac727..8f1643a2f72d 100644
--- a/ftp/bsdftpd-ssl/files/pkg-message.server
+++ b/ftp/bsdftpd-ssl/files/pkg-message.server
@@ -1,2 +1,14 @@
+=============================================================================
You will also need to read "Configuration" and "Supplement information" parts
-of INSTALL file from package documentation for subsequent configuration issues.
+of %%DOCSDIR%%/INSTALL file from the package documentation
+for the subsequent configuration steps:
+ 1. Create the server certificate
+ 2. Edit PAM configuration
+ 3. Start the FTP server
+
+If you want to run the FTP server in the daemon mode, you can copy the sample
+start-up script %%PREFIX%%/etc/rc.d/bsdftpd-ssl.sh.sample to
+%%PREFIX%%/etc/rc.d/bsdftpd-ssl.sh.
+
+Please note: the manual page for the FTP server is available as ftpd-ssl(8).
+=============================================================================
diff --git a/ftp/bsdftpd-ssl/pkg-plist b/ftp/bsdftpd-ssl/pkg-plist
index cb904d959428..ef0447bc5741 100644
--- a/ftp/bsdftpd-ssl/pkg-plist
+++ b/ftp/bsdftpd-ssl/pkg-plist
@@ -1,4 +1,5 @@
bin/ftps
+etc/rc.d/bsdftpd-ssl.sh.sample
libexec/ftpd
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
%%PORTDOCS%%%%DOCSDIR%%/README