aboutsummaryrefslogtreecommitdiff
path: root/ftp/curl
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-08-15 07:37:23 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-08-15 07:37:23 +0000
commit044820ca450d91f00892ed8fd791764f5f8bc311 (patch)
treebd07f15b1bb428fe83e7d6b693cf6709e92527b2 /ftp/curl
parent36543d067d6cb1b3a02ebeec89424a753ec817ed (diff)
downloadports-044820ca450d91f00892ed8fd791764f5f8bc311.tar.gz
ports-044820ca450d91f00892ed8fd791764f5f8bc311.zip
Notes
Diffstat (limited to 'ftp/curl')
-rw-r--r--ftp/curl/Makefile3
-rw-r--r--ftp/curl/distinfo4
-rw-r--r--ftp/curl/files/patch-lib-multi.c16
-rw-r--r--ftp/curl/files/patch-lib-transfer.c16
-rw-r--r--ftp/curl/pkg-plist5
5 files changed, 7 insertions, 37 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index ae93953c7a71..abafc53645d4 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= curl
-PORTVERSION= 7.43.0
-PORTREVISION= 3
+PORTVERSION= 7.44.0
CATEGORIES= ftp www
MASTER_SITES= http://curl.haxx.se/download/ \
LOCAL/sunpoet
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index ef8692482514..40434c924f7b 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (curl-7.43.0.tar.lzma) = e2b8d84d9c7d85f81cc8477ea3ec757e4c9908eca116be8764b7d158aa7677fa
-SIZE (curl-7.43.0.tar.lzma) = 2765536
+SHA256 (curl-7.44.0.tar.lzma) = e7aab6b92fb30f88f9150090f6fa04f1e4358809ca8642d4e79cd79db652563e
+SIZE (curl-7.44.0.tar.lzma) = 2792083
diff --git a/ftp/curl/files/patch-lib-multi.c b/ftp/curl/files/patch-lib-multi.c
deleted file mode 100644
index 49a9a6466c63..000000000000
--- a/ftp/curl/files/patch-lib-multi.c
+++ /dev/null
@@ -1,16 +0,0 @@
-Obtained from: https://github.com/bagder/curl/commit/903b6e05565bf826b4194447864288642214b094
-
---- lib/multi.c.orig 2015-06-15 21:14:25 UTC
-+++ lib/multi.c
-@@ -402,11 +402,6 @@ CURLMcode curl_multi_add_handle(CURLM *m
- /* Point to the multi's connection cache */
- data->state.conn_cache = &multi->conn_cache;
-
-- if(data->set.httpreq == HTTPREQ_PUT)
-- data->state.infilesize = data->set.filesize;
-- else
-- data->state.infilesize = data->set.postfieldsize;
--
- /* This adds the new entry at the 'end' of the doubly-linked circular
- list of SessionHandle structs to try and maintain a FIFO queue so
- the pipelined requests are in order. */
diff --git a/ftp/curl/files/patch-lib-transfer.c b/ftp/curl/files/patch-lib-transfer.c
deleted file mode 100644
index c0507a87548a..000000000000
--- a/ftp/curl/files/patch-lib-transfer.c
+++ /dev/null
@@ -1,16 +0,0 @@
-Obtained from: https://github.com/bagder/curl/commit/903b6e05565bf826b4194447864288642214b094
-
---- lib/transfer.c.orig 2015-06-14 21:31:01 UTC
-+++ lib/transfer.c
-@@ -1315,6 +1315,11 @@ CURLcode Curl_pretransfer(struct Session
- Curl_safefree(data->info.wouldredirect);
- data->info.wouldredirect = NULL;
-
-+ if(data->set.httpreq == HTTPREQ_PUT)
-+ data->state.infilesize = data->set.filesize;
-+ else
-+ data->state.infilesize = data->set.postfieldsize;
-+
- /* If there is a list of cookie files to read, do it now! */
- if(data->change.cookielist)
- Curl_cookie_loadfiles(data);
diff --git a/ftp/curl/pkg-plist b/ftp/curl/pkg-plist
index d658f851a084..414feb3d4341 100644
--- a/ftp/curl/pkg-plist
+++ b/ftp/curl/pkg-plist
@@ -12,7 +12,7 @@ include/curl/typecheck-gcc.h
lib/libcurl.a
lib/libcurl.so
lib/libcurl.so.4
-lib/libcurl.so.4.3.0
+lib/libcurl.so.4.4.0
lib/libcurl.so.7
libdata/pkgconfig/libcurl.pc
man/man1/curl-config.1.gz
@@ -26,6 +26,8 @@ man/man3/CURLMOPT_MAX_TOTAL_CONNECTIONS.3.gz
man/man3/CURLMOPT_PIPELINING.3.gz
man/man3/CURLMOPT_PIPELINING_SERVER_BL.3.gz
man/man3/CURLMOPT_PIPELINING_SITE_BL.3.gz
+man/man3/CURLMOPT_PUSHDATA.3.gz
+man/man3/CURLMOPT_PUSHFUNCTION.3.gz
man/man3/CURLMOPT_SOCKETDATA.3.gz
man/man3/CURLMOPT_SOCKETFUNCTION.3.gz
man/man3/CURLMOPT_TIMERDATA.3.gz
@@ -301,6 +303,7 @@ man/man3/libcurl-errors.3.gz
man/man3/libcurl-multi.3.gz
man/man3/libcurl-share.3.gz
man/man3/libcurl-symbols.3.gz
+man/man3/libcurl-thread.3.gz
man/man3/libcurl-tutorial.3.gz
man/man3/libcurl.3.gz
share/aclocal/libcurl.m4