aboutsummaryrefslogtreecommitdiff
path: root/ftp/curl
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-12-18 15:20:50 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-12-18 15:20:50 +0000
commit19c76abeae5f817d7f80bd0fad20998d135e20b6 (patch)
tree4fa86d57931f2d94f9971d379de500a552e20249 /ftp/curl
parent9c2a182d4ce684231486dbda7168aa0efb1150fa (diff)
downloadports-19c76abeae5f817d7f80bd0fad20998d135e20b6.tar.gz
ports-19c76abeae5f817d7f80bd0fad20998d135e20b6.zip
Notes
Diffstat (limited to 'ftp/curl')
-rw-r--r--ftp/curl/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 78969d00f045..92ddd5c22f2e 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= curl
PORTVERSION= 7.51.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= ftp net www
MASTER_SITES= http://curl.haxx.se/download/ \
LOCAL/sunpoet
@@ -20,7 +20,7 @@ OPTIONS_SINGLE= GSSAPI
OPTIONS_RADIO_RESOLV= CARES THREADED_RESOLVER
OPTIONS_RADIO_SSL= GNUTLS NSS OPENSSL POLARSSL WOLFSSL
OPTIONS_SINGLE_GSSAPI= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT GSSAPI_NONE
-OPTIONS_DEFAULT= CA_BUNDLE COOKIES OPENSSL PROXY RESOLV THREADED_RESOLVER TLS_SRP
+OPTIONS_DEFAULT= CA_BUNDLE COOKIES HTTP2 OPENSSL PROXY RESOLV THREADED_RESOLVER TLS_SRP
CA_BUNDLE_DESC= Install CA bundle for OpenSSL
CA_BUNDLE_IMPLIES= OPENSSL
COOKIES_DESC= Cookies support
@@ -95,10 +95,10 @@ GSSAPI_MIT_LDFLAGS= ${GSSAPILDFLAGS}
GSSAPI_MIT_LIBS= ${GSSAPILIBS}
GSSAPI_MIT_USES= gssapi:mit
GSSAPI_NONE_CONFIGURE_ON= --without-gssapi
-HTTP2_BUILD_DEPENDS= nghttp2>=1.0.0:www/nghttp2
-HTTP2_CONFIGURE_WITH= nghttp2
-HTTP2_LIB_DEPENDS= libnghttp2.so:www/nghttp2
-HTTP2_RUN_DEPENDS= nghttp2>=1.0.0:www/nghttp2
+HTTP2_BUILD_DEPENDS= libnghttp2>=1.0.0:www/libnghttp2
+HTTP2_CONFIGURE_WITH= libnghttp2
+HTTP2_LIB_DEPENDS= libnghttp2.so:www/libnghttp2
+HTTP2_RUN_DEPENDS= libnghttp2>=1.0.0:www/libnghttp2
HTTP2_USES= pkgconfig
IDN_CONFIGURE_WITH= libidn2
IDN_LIB_DEPENDS= libidn2.so:dns/libidn2