aboutsummaryrefslogtreecommitdiff
path: root/ftp/curlpp
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2007-01-14 19:50:31 +0000
committerPeter Pentchev <roam@FreeBSD.org>2007-01-14 19:50:31 +0000
commit9588baf82d48b660f982f6d1f24e9452290d4a11 (patch)
treeb07132fccc7b0e28e77c25f113ae694420ca7038 /ftp/curlpp
parentacbb86204796966f3626148a8f4b3f3364f0c573 (diff)
downloadports-9588baf82d48b660f982f6d1f24e9452290d4a11.tar.gz
ports-9588baf82d48b660f982f6d1f24e9452290d4a11.zip
Fix the build with gcc 4.1: explicitly state the curlpp namespace.
This is a no-op for gcc 3.x. While I'm here, specify the build target in the way the GNU configure script wants it. No PORTREVISION bump, since neither of these changes affects the build output in any way - well, except for the build actually succeeding with gcc 4.1 :)
Notes
Notes: svn path=/head/; revision=182367
Diffstat (limited to 'ftp/curlpp')
-rw-r--r--ftp/curlpp/Makefile1
-rw-r--r--ftp/curlpp/files/patch-curlpp::Info.cpp28
2 files changed, 29 insertions, 0 deletions
diff --git a/ftp/curlpp/Makefile b/ftp/curlpp/Makefile
index 452f2dad462d..a571bea1cacd 100644
--- a/ftp/curlpp/Makefile
+++ b/ftp/curlpp/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl
USE_GCC= 3.4
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-ewarning
diff --git a/ftp/curlpp/files/patch-curlpp::Info.cpp b/ftp/curlpp/files/patch-curlpp::Info.cpp
new file mode 100644
index 000000000000..4273dbb4c148
--- /dev/null
+++ b/ftp/curlpp/files/patch-curlpp::Info.cpp
@@ -0,0 +1,28 @@
+--- curlpp/Info.cpp.orig Sun Jan 14 19:53:08 2007
++++ curlpp/Info.cpp Sun Jan 14 19:53:13 2007
+@@ -5,9 +5,11 @@
+ #include "Info.hpp"
+
+
++namespace cURLpp {
++
+ template< >
+ void
+-cURLpp::InfoTypeConverter< std::string >::get(cURLpp::Easy &handle,
++InfoTypeConverter< std::string >::get(cURLpp::Easy &handle,
+ CURLINFO info,
+ std::string &value)
+ {
+@@ -18,9 +20,11 @@
+
+ template< >
+ void
+-cURLpp::InfoTypeConverter< std::list< std::string > >::get(cURLpp::Easy &,
++InfoTypeConverter< std::list< std::string > >::get(cURLpp::Easy &,
+ CURLINFO ,
+ std::list< std::string > &)
+ {
+
++}
++
+ }