aboutsummaryrefslogtreecommitdiff
path: root/ftp/dmachine
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-15 07:47:03 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-15 07:47:03 +0000
commit5deb0f972a24433f0ccb505608405cc0bd3cf025 (patch)
treebc344d3a905f834cd9b0da943cc277f482b33900 /ftp/dmachine
parentc563a2cc0098ab04cb2bfeac41600bbf88ff3b6c (diff)
downloadports-5deb0f972a24433f0ccb505608405cc0bd3cf025.tar.gz
ports-5deb0f972a24433f0ccb505608405cc0bd3cf025.zip
add dmachine 0.19
A non interactive, non graphical, batch download manager
Notes
Notes: svn path=/head/; revision=95854
Diffstat (limited to 'ftp/dmachine')
-rw-r--r--ftp/dmachine/Makefile34
-rw-r--r--ftp/dmachine/distinfo1
-rw-r--r--ftp/dmachine/files/dmachine1
-rw-r--r--ftp/dmachine/pkg-descr6
-rw-r--r--ftp/dmachine/pkg-plist20
5 files changed, 62 insertions, 0 deletions
diff --git a/ftp/dmachine/Makefile b/ftp/dmachine/Makefile
new file mode 100644
index 000000000000..95634afd920f
--- /dev/null
+++ b/ftp/dmachine/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: dmachine
+# Date Created: Dec 15, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= dmachine
+PORTVERSION= 0.19
+CATEGORIES= ftp
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A non interactive, non graphical, batch download manager
+
+USE_JAVA= 1.1+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+ALL_TARGET= dmachine
+
+do-install:
+ @${SED} 's|%%DATADIR%%|${DATADIR}|' ${FILESDIR}/dmachine > ${WRKSRC}/dmachine
+ ${INSTALL_SCRIPT} ${WRKSRC}/dmachine ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.class ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../dmachine.cnf ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/ftp/dmachine/distinfo b/ftp/dmachine/distinfo
new file mode 100644
index 000000000000..4903dcf88df8
--- /dev/null
+++ b/ftp/dmachine/distinfo
@@ -0,0 +1 @@
+MD5 (dmachine-019.tar.gz) = 9213d3b3e082cfa209028ff26a2da756
diff --git a/ftp/dmachine/files/dmachine b/ftp/dmachine/files/dmachine
new file mode 100644
index 000000000000..e0caf2eab2e4
--- /dev/null
+++ b/ftp/dmachine/files/dmachine
@@ -0,0 +1 @@
+java -cp %%DATADIR%% dmachine
diff --git a/ftp/dmachine/pkg-descr b/ftp/dmachine/pkg-descr
new file mode 100644
index 000000000000..b60cff9989e0
--- /dev/null
+++ b/ftp/dmachine/pkg-descr
@@ -0,0 +1,6 @@
+Download machine is non interactive, non graphical, batch download manager.
+Tired of GUI Download managers and mouse clicking? Then Download Machine is
+just for YOU! Download Machine is written in portable Java 1.1 code and
+supports HTTP, FTP and FSP protocols.
+
+WWW: http://dmachine.sourceforge.net/
diff --git a/ftp/dmachine/pkg-plist b/ftp/dmachine/pkg-plist
new file mode 100644
index 000000000000..e9734cf8be50
--- /dev/null
+++ b/ftp/dmachine/pkg-plist
@@ -0,0 +1,20 @@
+%%DATADIR%%/FSPInputStream.class
+%%DATADIR%%/FSPStreamHandler.class
+%%DATADIR%%/FSPURLConnection.class
+%%DATADIR%%/FSPpacket.class
+%%DATADIR%%/FSPsession.class
+%%DATADIR%%/FSPstat.class
+%%DATADIR%%/FSPutil.class
+%%DATADIR%%/HTUU.class
+%%DATADIR%%/dmachine.class
+%%DATADIR%%/downloadfactory.class
+%%DATADIR%%/fspfactory.class
+%%DATADIR%%/ftpfactory.class
+%%DATADIR%%/qfile.class
+%%DATADIR%%/queuefile.class
+%%DATADIR%%/regexp.class
+%%DATADIR%%/util.class
+@dirrm %%DATADIR%%
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/dmachine.cnf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%