aboutsummaryrefslogtreecommitdiff
path: root/ftp/filezilla/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-07-14 22:35:05 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-07-14 22:35:05 +0000
commit3c2b3733a50c5c528049de16bcb6b0b4c598ff4f (patch)
treec63f9d6580c47c3a0a60d18fd85ed2449221ae61 /ftp/filezilla/Makefile
parent1bf967b107b318ef4771f12d8fade3076684874d (diff)
downloadports-3c2b3733a50c5c528049de16bcb6b0b4c598ff4f.tar.gz
ports-3c2b3733a50c5c528049de16bcb6b0b4c598ff4f.zip
Notes
Diffstat (limited to 'ftp/filezilla/Makefile')
-rw-r--r--ftp/filezilla/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/ftp/filezilla/Makefile b/ftp/filezilla/Makefile
index 3dbb56c6b3ed..e85f94fdde4e 100644
--- a/ftp/filezilla/Makefile
+++ b/ftp/filezilla/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= filezilla
-PORTVERSION= 3.11.0.1
+PORTVERSION= 3.12.0.2
CATEGORIES= ftp
MASTER_SITES= SF/${PORTNAME}/FileZilla_Client/${PORTVERSION}
DISTNAME= FileZilla_${PORTVERSION}_src
@@ -20,8 +20,6 @@ LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
libidn.so:${PORTSDIR}/dns/libidn \
libtinyxml.so:${PORTSDIR}/textproc/tinyxml
-BROKEN_FreeBSD_9= does not build on FreeBSD 9.x (gcc segfault)
-
INSTALLS_ICONS= yes
USES= compiler:c++11-lib gmake pkgconfig tar:bzip2
USE_SQLITE= 3
@@ -49,8 +47,8 @@ CONFIGURE_ARGS+= --disable-manualupdatecheck
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-# can't count on Clang having lic++ before 10, so compiler uses selects gcc
+.if ${CHOSEN_COMPILER_TYPE} == "gcc"
+BROKEN= GCC dies with Internal Compiler Error
.if ${ARCH} == i386 && ! ${CFLAGS:M-march=*}
# needed for __atomic_exchange_8, __atmoic_fetch_add_8, __atomic_store_8
CFLAGS+= -march=i586