aboutsummaryrefslogtreecommitdiff
path: root/ftp/ftpcopy/Makefile
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-07 12:14:54 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-07 12:14:54 +0000
commit8b6e99c02d6da8b25db80197b38bef1b8ae20f71 (patch)
tree46ac7997fdadec943863669091ac1931441ca450 /ftp/ftpcopy/Makefile
parent35ae9b658f401874e0b088fc42a3171ab544fd76 (diff)
ftp/ftpcopy: fix build on non-x86
Use GCC since clang doesn't like regparm, but GCC ignores it.
Diffstat (limited to 'ftp/ftpcopy/Makefile')
-rw-r--r--ftp/ftpcopy/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/ftp/ftpcopy/Makefile b/ftp/ftpcopy/Makefile
index 5fc463123875..9d9554bd3450 100644
--- a/ftp/ftpcopy/Makefile
+++ b/ftp/ftpcopy/Makefile
@@ -10,11 +10,6 @@ COMMENT= Command line FTP tools for listing and mirroring
LICENSE= GPLv2
-BROKEN_aarch64= fails to build: regparm is not valid on this platform
-BROKEN_armv6= fails to build: regparm is not valid on this platform
-BROKEN_armv7= fails to build: regparm is not valid on this platform
-BROKEN_riscv64= fails to build: regparm is not valid on this platform
-
USES= perl5
USE_PERL5= build
@@ -22,6 +17,12 @@ WRKSRC= ${WRKDIR}/web/${DISTNAME}
OPTIONS_DEFINE= DOCS
+.include <bsd.port.options.mk>
+
+.if ${ARCH} != amd64 && ${ARCH} != i386
+USES+= compiler:gcc-c++11-lib
+.endif
+
pre-build:
${ECHO} "${CC}" >${WRKSRC}/src/conf-cc
${ECHO} "${CPPFLAGS} ${CFLAGS}" >${WRKSRC}/src/conf-cflags