aboutsummaryrefslogtreecommitdiff
path: root/ftp/ftpproxy
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-09-27 07:55:17 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-09-27 07:55:17 +0000
commitb76a034eadb200112e482b2a676b4e2b064ac590 (patch)
tree4c9e33666ce014025872217f3529b134fffb3e39 /ftp/ftpproxy
parent48ce7183d0ca4d8cccaadb05d1594754bbf0df2d (diff)
downloadports-b76a034eadb200112e482b2a676b4e2b064ac590.tar.gz
ports-b76a034eadb200112e482b2a676b4e2b064ac590.zip
- Fix a wrong usage of CFLAGS in last update
(the port does not build if CFLAGS defined in /etc/make.conf) PR: ports/86616 Reported by: TANABE Hiroyasu <h@cosat.com> Submitted by: Andrej Zverev <az@inec.ru> Approved by: broken build
Notes
Notes: svn path=/head/; revision=143612
Diffstat (limited to 'ftp/ftpproxy')
-rw-r--r--ftp/ftpproxy/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/ftp/ftpproxy/Makefile b/ftp/ftpproxy/Makefile
index e50576357e94..e724dc989603 100644
--- a/ftp/ftpproxy/Makefile
+++ b/ftp/ftpproxy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ftpproxy
PORTVERSION= 1.2.3
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= http://www.ftpproxy.org/download/ \
http://www.ftpproxy.org/download/older_releases/
@@ -17,14 +18,14 @@ COMMENT= A ftp proxy
USE_REINPLACE= yes
USE_GMAKE= yes
-CFLAGS +=-DVERSION=\\\"${PORTVERSION}\\\"
MAN1= ftp.proxy.1
MANCOMPRESSED= no
PLIST_FILES= sbin/ftp.proxy
pre-build:
- @${REINPLACE_CMD} -e 's|^CFLAGS|#CFLAGS|' ${WRKSRC}/src/Makefile
+ @${REINPLACE_CMD} -e 's|^CFLAGS.*|CFLAGS=${CFLAGS} \
+ -DVERSION=\\"${PORTVERSION}\\"|' ${WRKSRC}/src/Makefile
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/src/ftp.proxy ${PREFIX}/sbin