aboutsummaryrefslogtreecommitdiff
path: root/ftp/ftpproxy
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-01-26 00:07:18 +0000
committerPatrick Li <pat@FreeBSD.org>2002-01-26 00:07:18 +0000
commitd5992e92c57098977d89344f2e6101b69a394842 (patch)
tree6c2ca4aca3870510b64d983d9fa684ffdf1f2fd8 /ftp/ftpproxy
parentb9d623eba1913b92cf04f5aa8414d50674120a06 (diff)
downloadports-d5992e92c57098977d89344f2e6101b69a394842.tar.gz
ports-d5992e92c57098977d89344f2e6101b69a394842.zip
Update to 1.1.4
PR: 34186 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=53739
Diffstat (limited to 'ftp/ftpproxy')
-rw-r--r--ftp/ftpproxy/Makefile22
-rw-r--r--ftp/ftpproxy/distinfo2
-rw-r--r--ftp/ftpproxy/files/patch-Makefile25
-rw-r--r--ftp/ftpproxy/files/patch-ftp.c21
-rw-r--r--ftp/ftpproxy/files/patch-main.c20
-rw-r--r--ftp/ftpproxy/pkg-descr2
-rw-r--r--ftp/ftpproxy/pkg-list1
7 files changed, 41 insertions, 52 deletions
diff --git a/ftp/ftpproxy/Makefile b/ftp/ftpproxy/Makefile
index e0e88e3cf8a3..0a552147148a 100644
--- a/ftp/ftpproxy/Makefile
+++ b/ftp/ftpproxy/Makefile
@@ -6,21 +6,27 @@
#
PORTNAME= ftpproxy
-PORTVERSION= 1.0.7
+PORTVERSION= 1.1.4
CATEGORIES= ftp
-MASTER_SITES= http://ftp.daemons.de/download/
-DISTNAME= ftpproxy-${PORTVERSION}
+MASTER_SITES= http://www.ftpproxy.org/download/ \
+ ftp://ftp.daemons.de/ \
+ http://www.ftpproxy.org/download/older_releases/ \
+ ftp://ftp.daemons.de/older_releases/
+EXTRACT_SUFX= .tgz
MAINTAINER= philippe@le-berre.com
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+
MAN1= ftp.proxy.1
MANCOMPRESSED= no
-pre-build:
- ${PERL} -pi -e "s@gcc@${CC}@g; s@-O2 -Wall -ggdb@-Wall ${CFLAGS}@g; \
- s@/usr/local@${PREFIX}@g" ${WRKSRC}/Makefile
+pre-patch:
+ @${RM} -Rf ${WRKSRC}/*.o ${WRKSRC}/src/ftp.proxy
+ @${PERL} -pi.orig -e 's|SOL_TCP|SOL_SOCKET|' ${WRKSRC}/ftp.c
-post-patch:
- ${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/ftp.proxy ${PREFIX}/sbin
+ @${INSTALL_MAN} ${WRKSRC}/../doc/ftp.proxy.1 ${PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/ftp/ftpproxy/distinfo b/ftp/ftpproxy/distinfo
index b45c2a06ff66..9da78c867147 100644
--- a/ftp/ftpproxy/distinfo
+++ b/ftp/ftpproxy/distinfo
@@ -1 +1 @@
-MD5 (ftpproxy-1.0.7.tar.gz) = 4cf5774e22fbcd0a0e02dab0c7ba4853
+MD5 (ftpproxy-1.1.4.tgz) = 3f2732c23d7cda68320b7258544cb753
diff --git a/ftp/ftpproxy/files/patch-Makefile b/ftp/ftpproxy/files/patch-Makefile
new file mode 100644
index 000000000000..8ef244d80a0e
--- /dev/null
+++ b/ftp/ftpproxy/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- Makefile.orig Wed Jan 23 23:42:24 2002
++++ Makefile Wed Jan 23 23:49:22 2002
+@@ -1,20 +1,4 @@
+-
+-CC = gcc
+-CFLAGS = -O2 -Wall -ggdb
+-
+ FTPPROXY = main.o ftp.o ip-lib.o lib.o
+
+-TARGETS = ftp.proxy
+-
+-
+-all: $(TARGETS)
+- -ctags *.[ch]
+-
+-
+-ftp.proxy: $(FTPPROXY)
+- $(CC) -o $@ $(FTPPROXY)
+-
+-
+-clean:
+- rm -f *.o cut out $(TARGETS) $(TAR).tar.gz
+-
++all: $(FTPPROXY)
++ $(CC) $(CFLAGS) -o ftp.proxy $(FTPPROXY)
diff --git a/ftp/ftpproxy/files/patch-ftp.c b/ftp/ftpproxy/files/patch-ftp.c
deleted file mode 100644
index fb8f266dea37..000000000000
--- a/ftp/ftpproxy/files/patch-ftp.c
+++ /dev/null
@@ -1,21 +0,0 @@
-*** ftp.orig Wed May 16 09:53:13 2001
---- ftp.c Wed May 16 09:54:08 2001
-***************
-*** 31,38 ****
-
- #include <time.h>
- #include <signal.h>
-! #include <wait.h>
- #include <ctype.h>
-
- #include <sys/types.h>
- #include <sys/stat.h>
---- 31,38 ----
-
- #include <time.h>
- #include <signal.h>
-! #include <sys/wait.h>
- #include <ctype.h>
-
- #include <sys/types.h>
- #include <sys/stat.h>
diff --git a/ftp/ftpproxy/files/patch-main.c b/ftp/ftpproxy/files/patch-main.c
deleted file mode 100644
index 68c4b369573d..000000000000
--- a/ftp/ftpproxy/files/patch-main.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- main.c.orig Fri May 11 16:30:04 2001
-+++ main.c Mon Oct 15 21:24:20 2001
-@@ -30,7 +30,7 @@
- #include <stdarg.h>
-
- #include <signal.h>
--#include <wait.h>
-+#include <sys/wait.h>
-
- #include <sys/types.h>
- #include <sys/stat.h>
-@@ -81,7 +81,7 @@
- config->timeout = 15 * 60;
- strcpy(config->varname, "PROXY_");
-
-- openlog(program, LOG_PID, LOG_MAIL);
-+ openlog(program, LOG_PID, LOG_FTP);
-
- k = 1;
- while (k < argc && argv[k][0] == '-' && argv[k][1] != 0) {
diff --git a/ftp/ftpproxy/pkg-descr b/ftp/ftpproxy/pkg-descr
index 0501ec709285..39d1318cc8ff 100644
--- a/ftp/ftpproxy/pkg-descr
+++ b/ftp/ftpproxy/pkg-descr
@@ -6,7 +6,7 @@ Beside this basic function which makes the program useful on firewall
or masqueraders it offers fixing the FTP server (e.g. for connections
into a protected LAN) and proxy authentication.
-WWW: http://ftp.daemons.de/
+WWW: http://www.ftpproxy.org/
-Philippe
philippe@le-berre.com
diff --git a/ftp/ftpproxy/pkg-list b/ftp/ftpproxy/pkg-list
deleted file mode 100644
index 980ec472946d..000000000000
--- a/ftp/ftpproxy/pkg-list
+++ /dev/null
@@ -1 +0,0 @@
-sbin/ftp.proxy