aboutsummaryrefslogtreecommitdiff
path: root/ftp/ftpproxy
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-25 20:47:31 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-25 20:47:31 +0000
commitee522bf9271eacd6486d7cc0fae4e2e698965a27 (patch)
treee147f2219e15ecde91ec9e69eec30dc1dc17e0c5 /ftp/ftpproxy
parentfd414793d2dbf9402b63a920675c8c577b09b6af (diff)
downloadports-ee522bf9271eacd6486d7cc0fae4e2e698965a27.tar.gz
ports-ee522bf9271eacd6486d7cc0fae4e2e698965a27.zip
Support stage
Respect CC USE_GMAKE -> USES=gmake
Notes
Notes: svn path=/head/; revision=341097
Diffstat (limited to 'ftp/ftpproxy')
-rw-r--r--ftp/ftpproxy/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/ftp/ftpproxy/Makefile b/ftp/ftpproxy/Makefile
index 9a153aa0e8da..e5c1982aeebf 100644
--- a/ftp/ftpproxy/Makefile
+++ b/ftp/ftpproxy/Makefile
@@ -10,22 +10,21 @@ MASTER_SITES= http://www.ftpproxy.org/download/ \
EXTRACT_SUFX= .tgz
MAINTAINER= philippe@le-berre.com
-COMMENT= A ftp proxy
+COMMENT= ftp proxy
-USE_GMAKE= yes
+USES= gmake
MAKE_JOBS_UNSAFE= yes
+MAKE_ARGS= CC=${CC}
-MAN1= ftp.proxy.1
-MANCOMPRESSED= no
-PLIST_FILES= sbin/ftp.proxy
+PLIST_FILES= sbin/ftp.proxy \
+ man/man1/ftp.proxy.1.gz
-NO_STAGE= yes
pre-build:
@${REINPLACE_CMD} -e 's|^CFLAGS.*|CFLAGS=${CFLAGS} \
-DVERSION=\\"${PORTVERSION}\\"|' ${WRKSRC}/src/Makefile
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/src/ftp.proxy ${PREFIX}/sbin
- @${INSTALL_MAN} ${WRKSRC}/doc/ftp.proxy.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/ftp.proxy ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/doc/ftp.proxy.1 ${STAGEDIR}${PREFIX}/man/man1
.include <bsd.port.mk>