aboutsummaryrefslogtreecommitdiff
path: root/ftp/gftp
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-26 09:58:33 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-26 09:58:33 +0000
commit1933bfac5966c4c873f2170214fc9390476dcc39 (patch)
tree0703b05c980a1a962f207fe4415499f2f3f22ae8 /ftp/gftp
parent5c7bf71301cf74b9fc42fef0bef4145a737511d3 (diff)
downloadports-1933bfac5966c4c873f2170214fc9390476dcc39.tar.gz
ports-1933bfac5966c4c873f2170214fc9390476dcc39.zip
Convert left unconverted ports in ftp to new options framework
Notes
Notes: svn path=/head/; revision=315271
Diffstat (limited to 'ftp/gftp')
-rw-r--r--ftp/gftp/Makefile38
1 files changed, 18 insertions, 20 deletions
diff --git a/ftp/gftp/Makefile b/ftp/gftp/Makefile
index 80f2c69ca09f..6b531fc1804c 100644
--- a/ftp/gftp/Makefile
+++ b/ftp/gftp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gftp
-# Date Created: 21 Feb 1999
-# Whom: Damjan Marion <dmarion@open.hr>
-#
+# Created by: Damjan Marion <dmarion@open.hr>
# $FreeBSD$
-#
PORTNAME= gftp
PORTVERSION= 2.0.19
@@ -24,32 +20,32 @@ CPPFLAGS+= -I${LOCALBASE}/include
WANT_GNOME= yes
-OPTIONS= X11 "Build with X11 frontend" on \
- NLS "Native Language Support via gettext utilities" on
+OPTIONS_DEFINE= X11 NLS
+OPTIONS_DEFAULT= X11
-.if !defined(WITHOUT_X11)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MX11}
USE_XORG= x11
.endif
-.include <bsd.port.pre.mk>
-
-USE_GNOME+= gnomehack
+USES= pathfix
-.if defined(WITHOUT_X11)
-CONFIGURE_ARGS+=--disable-gtkport
-PKGNAMESUFFIX= -nox11
-USE_GNOME+= glib20
-PLIST_SUB+= NOX11:="@comment "
-.else
+.if ${PORT_OPTIONS:MX11}
PLIST_SUB+= NOX11:=""
WANT_GNOME= yes
USE_GNOME+= gtk20
CONFIGURE_ENV+= _GTHREAD_LIBS="-lgthread-2.0"
+.else
+CONFIGURE_ARGS+=--disable-gtkport
+PKGNAMESUFFIX= -nox11
+USE_GNOME+= glib20
+PLIST_SUB+= NOX11:="@comment "
.endif
MAN1= gftp.1
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
@@ -57,7 +53,9 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if ${HAVE_GNOME:Mgnomelibs}!="" && !defined(WITH_GTK2)
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mgnomelibs}!="" && ! ${PORT_OPTIONS:MGTK2}
USE_GNOME+= gnomeprefix gnomelibs
PKGNAMESUFFIX+= -gnome
PLIST_SUB+= MYGNOME=""
@@ -73,7 +71,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|size_t dest_len|size_t *dest_len|g ; \
s|\(gftp_filename_from_utf8 (gftp_request \* request,\) int force_local,|\1|' \
${WRKSRC}/lib/charset-conv.c
-.if defined(WITHOUT_X11)
+.if ! ${PORT_OPTIONS:MX11}
@${REINPLACE_CMD} -e 's|: install-pkgdataDATA|: |' \
${WRKSRC}/docs/sample.gftp/Makefile.in
.endif