aboutsummaryrefslogtreecommitdiff
path: root/ftp/gftp
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2008-12-05 15:12:47 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2008-12-05 15:12:47 +0000
commitb9f76f8f267582656e7ebd3dbd703c8820dd3532 (patch)
treec5d9d5d833cf458013a5594f4ef29cd8146058b9 /ftp/gftp
parent52fb91d89dc9f02a0362c3a6de2d3c2a224e7043 (diff)
downloadports-b9f76f8f267582656e7ebd3dbd703c8820dd3532.tar.gz
ports-b9f76f8f267582656e7ebd3dbd703c8820dd3532.zip
update to 2.0.19
drop GTK12 support (not working with 2.0.19)
Notes
Notes: svn path=/head/; revision=223814
Diffstat (limited to 'ftp/gftp')
-rw-r--r--ftp/gftp/Makefile21
-rw-r--r--ftp/gftp/distinfo6
-rw-r--r--ftp/gftp/files/patch-ab16
-rw-r--r--ftp/gftp/files/patch-lib-fsplib_fsplib.c47
-rw-r--r--ftp/gftp/files/patch-lib-fsplib_fsplib.h24
-rw-r--r--ftp/gftp/files/patch-lib-protocols.c18
-rw-r--r--ftp/gftp/files/patch-lib::pty.c11
-rw-r--r--ftp/gftp/files/patch-src::gtk::options_dialog.c11
-rw-r--r--ftp/gftp/files/patch-src::text::gftp-text.c18
-rw-r--r--ftp/gftp/pkg-plist25
10 files changed, 59 insertions, 138 deletions
diff --git a/ftp/gftp/Makefile b/ftp/gftp/Makefile
index b2ffe693fc16..76e1323c5bb6 100644
--- a/ftp/gftp/Makefile
+++ b/ftp/gftp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gftp
-PORTVERSION= 2.0.18
-PORTREVISION= 7
+PORTVERSION= 2.0.19
CATEGORIES= ftp
MASTER_SITES= http://gftp.seul.org/ \
ftp://gftp.seul.org/pub/gftp/
@@ -24,9 +23,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
WANT_GNOME= yes
-OPTIONS= X11 "Build with X11 frontend" on \
- GTK1 "gtk12 instead of gtk2" off \
- NLS "Native Language Support via gettext utilities" on
+OPTIONS= X11 "Build with X11 frontend" on \
+ NLS "Native Language Support via gettext utilities" on
.if !defined(WITHOUT_X11)
USE_XORG= x11
@@ -37,22 +35,16 @@ USE_XORG= x11
USE_GNOME+= gnomehack
.if defined(WITHOUT_X11)
-CONFIGURE_ARGS+=--disable-gtkport --disable-gtk20
+CONFIGURE_ARGS+=--disable-gtkport
PKGNAMESUFFIX= -nox11
-USE_GNOME+= glib12
+USE_GNOME+= glib20
PLIST_SUB+= NOX11:="@comment "
.else
PLIST_SUB+= NOX11:=""
WANT_GNOME= yes
-.if defined(WITH_GTK1)
-USE_GNOME+= gtk12
-CONFIGURE_ENV+= _GTHREAD_LIBS="-lgthread-12"
-CONFIGURE_ARGS+=--disable-gtk20
-.else
USE_GNOME+= gtk20
CONFIGURE_ENV+= _GTHREAD_LIBS="-lgthread-2.0"
.endif
-.endif
MAN1= gftp.1
@@ -77,6 +69,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|"-lssl |& -lcrypto|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|size_t dest_len|size_t *dest_len|g ; \
+ s|\(gftp_filename_from_utf8 (gftp_request \* request,\) int force_local,|\1|' \
+ ${WRKSRC}/lib/charset-conv.c
.if defined(WITHOUT_X11)
@${REINPLACE_CMD} -e 's|: install-pkgdataDATA|: |' \
${WRKSRC}/docs/sample.gftp/Makefile.in
diff --git a/ftp/gftp/distinfo b/ftp/gftp/distinfo
index 7bf1b08bd13b..870ea174b2bb 100644
--- a/ftp/gftp/distinfo
+++ b/ftp/gftp/distinfo
@@ -1,3 +1,3 @@
-MD5 (gftp-2.0.18.tar.gz) = 4d449f79b225b0831692e9caa39a2028
-SHA256 (gftp-2.0.18.tar.gz) = 1b501769f2e494e9a494ff3f9f1b7d82edeaf7d1fb77fdfd2f5bad76d0265a00
-SIZE (gftp-2.0.18.tar.gz) = 2170271
+MD5 (gftp-2.0.19.tar.gz) = 4c0cab4b35e8666f5892b02125270a21
+SHA256 (gftp-2.0.19.tar.gz) = eefc47ae51b011a2412874f0df068397ad85d9600c1acc02e22d5df3d9a60074
+SIZE (gftp-2.0.19.tar.gz) = 2691419
diff --git a/ftp/gftp/files/patch-ab b/ftp/gftp/files/patch-ab
index df7f5c923f37..cd71fd8709dd 100644
--- a/ftp/gftp/files/patch-ab
+++ b/ftp/gftp/files/patch-ab
@@ -1,8 +1,8 @@
---- docs/Makefile.in.orig Wed Nov 10 20:13:26 2004
-+++ docs/Makefile.in Wed Nov 10 20:15:59 2004
-@@ -167,16 +167,20 @@
+--- docs/Makefile.in.orig 2008-12-04 19:27:08.000000000 +0100
++++ docs/Makefile.in 2008-12-04 19:30:20.000000000 +0100
+@@ -247,14 +247,18 @@
+ sysconfdir = @sysconfdir@
target_alias = @target_alias@
-
man_MANS = gftp.1
+.ifndef WITHOUT_X11
SUBDIRS = sample.gftp
@@ -10,14 +10,12 @@
EXTRA_DIST = USERS-GUIDE gftp.1 gftp.desktop gftp.lsm gftp.png parse-netrc.pl \
gftp-faq.sgml
-
+.ifdef HAVE_GNOME
Utilitiesdir = $(datadir)/applications
Utilities_DATA = gftp.desktop
-
Iconsdir = $(datadir)/pixmaps
Icons_DATA = gftp.png
+.endif
- subdir = docs
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ all: all-recursive
+
+ .SUFFIXES:
diff --git a/ftp/gftp/files/patch-lib-fsplib_fsplib.c b/ftp/gftp/files/patch-lib-fsplib_fsplib.c
deleted file mode 100644
index 151b3bfb8c2d..000000000000
--- a/ftp/gftp/files/patch-lib-fsplib_fsplib.c
+++ /dev/null
@@ -1,47 +0,0 @@
---- lib/fsplib/fsplib.c.orig 2005-01-19 03:03:45.000000000 +0100
-+++ lib/fsplib/fsplib.c 2007-11-05 16:37:32.000000000 +0100
-@@ -612,7 +612,7 @@
- entry->d_reclen = fentry.reclen;
- strncpy(entry->d_name,fentry.name,MAXNAMLEN);
-
-- if (fentry.namlen > MAXNAMLEN)
-+ if (fentry.namlen >= MAXNAMLEN)
- {
- entry->d_name[MAXNAMLEN + 1 ] = '\0';
- #ifdef HAVE_NAMLEN
-@@ -680,9 +680,19 @@
- /* skip file date and file size */
- dir->dirpos += 9;
- /* read file name */
-- entry->name[255 + 1] = '\0';
-+ entry->name[255] = '\0';
- strncpy(entry->name,(char *)( dir->data + dir->dirpos ),MAXNAMLEN);
-+ /* check for ASCIIZ encoded filename */
-+ if (memchr(dir->data + dir->dirpos,0,dir->datasize - dir->dirpos) != NULL)
-+ {
- namelen = strlen( (char *) dir->data+dir->dirpos);
-+ }
-+ else
-+ {
-+ /* \0 terminator not found at end of filename */
-+ *result = NULL;
-+ return 0;
-+ }
- /* skip over file name */
- dir->dirpos += namelen +1;
-
-@@ -709,12 +719,12 @@
-
- struct dirent * fsp_readdir(FSP_DIR *dirp)
- {
-- static struct dirent entry;
-+ static dirent_workaround entry;
- struct dirent *result;
-
-
- if (dirp == NULL) return NULL;
-- if ( fsp_readdir_r(dirp,&entry,&result) )
-+ if ( fsp_readdir_r(dirp,&entry.dirent,&result) )
- return NULL;
- else
- return result;
diff --git a/ftp/gftp/files/patch-lib-fsplib_fsplib.h b/ftp/gftp/files/patch-lib-fsplib_fsplib.h
deleted file mode 100644
index 5d2d7449b053..000000000000
--- a/ftp/gftp/files/patch-lib-fsplib_fsplib.h
+++ /dev/null
@@ -1,24 +0,0 @@
---- lib/fsplib/fsplib.h.orig 2005-01-19 03:04:02.000000000 +0100
-+++ lib/fsplib/fsplib.h 2007-11-05 16:37:32.000000000 +0100
-@@ -1,6 +1,8 @@
- #ifndef _FSPLIB_H
- #define _FSPLIB_H 1
- #include <time.h>
-+#include <stddef.h>
-+
- /* The FSP v2 protocol support library - public interface */
-
- /*
-@@ -138,6 +140,12 @@
- unsigned int pos; /* position of next packet */
- } FSP_FILE;
-
-+
-+typedef union dirent_workaround {
-+ struct dirent dirent;
-+ char fill[offsetof (struct dirent, d_name) + MAXNAMLEN + 1];
-+} dirent_workaround;
-+
- /* function prototypes */
-
- /* session management */
diff --git a/ftp/gftp/files/patch-lib-protocols.c b/ftp/gftp/files/patch-lib-protocols.c
new file mode 100644
index 000000000000..e24aab9708d8
--- /dev/null
+++ b/ftp/gftp/files/patch-lib-protocols.c
@@ -0,0 +1,18 @@
+--- lib/protocols.c.orig 2008-12-04 21:35:37.000000000 +0100
++++ lib/protocols.c 2008-12-04 21:36:25.000000000 +0100
+@@ -457,6 +457,7 @@
+ fle->file = tmpfile;
+ }
+
++#if GLIB_MAJOR_VERSION > 1
+ if (ret >= 0 && fle->file != NULL)
+ {
+ if (g_utf8_validate (fle->file, -1, NULL))
+@@ -472,6 +473,7 @@
+ }
+ }
+ }
++#endif
+
+ if (ret >= 0 && !request->cached && request->cachefd > 0 &&
+ request->last_dir_entry != NULL)
diff --git a/ftp/gftp/files/patch-lib::pty.c b/ftp/gftp/files/patch-lib::pty.c
index f7c16d130878..21423eea8079 100644
--- a/ftp/gftp/files/patch-lib::pty.c
+++ b/ftp/gftp/files/patch-lib::pty.c
@@ -50,17 +50,6 @@
#elif HAVE_GRANTPT
#include <stropts.h>
-@@ -78,8 +121,8 @@
-
- if ((fdm = open ("/dev/ptmx", O_RDWR)) < 0)
- return (GFTP_ERETRYABLE);
--
-- if (grantpt (fdm) < 0)
-+
-+ if (grantpt (fdm) < 0)
- {
- close (fdm);
- return (GFTP_ERETRYABLE);
@@ -123,49 +166,6 @@
#endif
diff --git a/ftp/gftp/files/patch-src::gtk::options_dialog.c b/ftp/gftp/files/patch-src::gtk::options_dialog.c
deleted file mode 100644
index 2fb1b0bd6a24..000000000000
--- a/ftp/gftp/files/patch-src::gtk::options_dialog.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gtk/options_dialog.c.orig Sat Feb 5 16:42:53 2005
-+++ src/gtk/options_dialog.c Sat Feb 5 16:45:15 2005
-@@ -1002,7 +1002,7 @@
- gtk_widget_show (box);
-
- #if GTK_MAJOR_VERSION == 1
-- tempwid = gtk_label_new (_("Type:"))
-+ tempwid = gtk_label_new (_("Type:"));
- #else
- tempwid = gtk_label_new_with_mnemonic (_("_Type:"));
- #endif
diff --git a/ftp/gftp/files/patch-src::text::gftp-text.c b/ftp/gftp/files/patch-src::text::gftp-text.c
deleted file mode 100644
index 0e1bf3bd9fa7..000000000000
--- a/ftp/gftp/files/patch-src::text::gftp-text.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/text/gftp-text.c.orig Sat Feb 5 16:38:03 2005
-+++ src/text/gftp-text.c Sat Feb 5 16:39:26 2005
-@@ -185,6 +185,7 @@
- else
- infd = stdin;
-
-+#if GLIB_MAJOR_VERSION > 1
- locale_question = g_locale_from_utf8 (question, -1, NULL, NULL, NULL);
- if (locale_question != NULL)
- {
-@@ -193,6 +194,7 @@
- g_free (locale_question);
- }
- else
-+#endif
- printf ("%s%s%s ", GFTPUI_COMMON_COLOR_BLUE, question,
- GFTPUI_COMMON_COLOR_DEFAULT);
-
diff --git a/ftp/gftp/pkg-plist b/ftp/gftp/pkg-plist
index 855fb7959c0a..578f0e591a51 100644
--- a/ftp/gftp/pkg-plist
+++ b/ftp/gftp/pkg-plist
@@ -12,8 +12,13 @@ bin/gftp-text
%%NOX11:%%%%DATADIR%%/dotdot.xpm
%%NOX11:%%%%DATADIR%%/down.xpm
%%NOX11:%%%%DATADIR%%/exe.xpm
+%%NOX11:%%%%DATADIR%%/gftp-16x16.png
+%%NOX11:%%%%DATADIR%%/gftp-22x22.png
+%%NOX11:%%%%DATADIR%%/gftp-24x24.png
+%%NOX11:%%%%DATADIR%%/gftp-32x32.png
+%%NOX11:%%%%DATADIR%%/gftp-48x48.png
%%NOX11:%%%%DATADIR%%/gftp-logo.xpm
-%%NOX11:%%%%DATADIR%%/gftp-mini-logo.xpm
+%%NOX11:%%%%DATADIR%%/gftp-scalable.svg
%%NOX11:%%%%DATADIR%%/gftp.xpm
%%NOX11:%%%%DATADIR%%/gftprc
%%NOX11:%%%%DATADIR%%/img.xpm
@@ -40,6 +45,7 @@ bin/gftp-text
%%NLS%%share/locale/cs/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/da/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/de/LC_MESSAGES/gftp.mo
+%%NLS%%share/locale/dz/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/el/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/en_CA/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/gftp.mo
@@ -47,22 +53,30 @@ bin/gftp-text
%%NLS%%share/locale/fi/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/fr/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/ga/LC_MESSAGES/gftp.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/gftp.mo
+%%NLS%%share/locale/gu/LC_MESSAGES/gftp.mo
+%%NLS%%share/locale/he/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/hr/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/hu/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/it/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/ja/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/ko/LC_MESSAGES/gftp.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/gftp.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/mk/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/ml/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/ms/LC_MESSAGES/gftp.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/gftp.mo
+%%NLS%%share/locale/ne/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/nl/LC_MESSAGES/gftp.mo
-%%NLS%%share/locale/no/LC_MESSAGES/gftp.mo
+%%NLS%%share/locale/oc/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/pa/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/pl/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/pt/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/ro/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/ru/LC_MESSAGES/gftp.mo
+%%NLS%%share/locale/rw/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/sk/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/sq/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/sr/LC_MESSAGES/gftp.mo
@@ -73,7 +87,14 @@ bin/gftp-text
%%NLS%%share/locale/tr/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/uk/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/gftp.mo
+%%NLS%%share/locale/zh_HK/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/gftp.mo
%%NOX11:%%%%MYGNOME%%share/pixmaps/gftp.png
%%NOX11:%%@dirrm %%DATADIR%%
@dirrmtry share/applications
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw