aboutsummaryrefslogtreecommitdiff
path: root/ftp/horde-gollem
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2012-12-18 07:29:02 +0000
committerMartin Matuska <mm@FreeBSD.org>2012-12-18 07:29:02 +0000
commitd233d23153a79abe3de1d8486176c4d98ab09947 (patch)
tree8d904b07fa526dd8e87cb6dee568a4229000277e /ftp/horde-gollem
parent0e4ff235c8f914e857ea9edc6e404904fffd15f0 (diff)
downloadports-d233d23153a79abe3de1d8486176c4d98ab09947.tar.gz
ports-d233d23153a79abe3de1d8486176c4d98ab09947.zip
Rename horde4-* apps to horde-*
Notes
Notes: svn path=/head/; revision=309149
Diffstat (limited to 'ftp/horde-gollem')
-rw-r--r--ftp/horde-gollem/Makefile47
-rw-r--r--ftp/horde-gollem/distinfo2
-rw-r--r--ftp/horde-gollem/pkg-descr5
3 files changed, 54 insertions, 0 deletions
diff --git a/ftp/horde-gollem/Makefile b/ftp/horde-gollem/Makefile
new file mode 100644
index 000000000000..059071ba5aad
--- /dev/null
+++ b/ftp/horde-gollem/Makefile
@@ -0,0 +1,47 @@
+# Ports collection makefile for: horde4-gollem
+# Date created: Oct 11, 2011
+# Whom: Martin Matuska (mm@FreeBSD.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= gollem
+DISTVERSION= 3.0.0RC1
+CATEGORIES= ftp www pear
+PKGNAMEPREFIX= horde-
+
+MAINTAINER= horde@FreeBSD.org
+COMMENT= Horde Web-based File Manager
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LATEST_LINK= horde5-${PORTNAME}
+
+USE_PHP= gettext json
+USE_HORDE_BUILD= Horde_Role
+USE_HORDE_RUN= Horde_Role \
+ horde \
+ Horde_Auth \
+ Horde_Cache \
+ Horde_Core \
+ Horde_Editor \
+ Horde_Exception \
+ Horde_Mime \
+ Horde_Mime_Viewer \
+ Horde_Perms \
+ Horde_Secret \
+ Horde_Serialize \
+ Horde_Support \
+ Horde_Url \
+ Horde_Util \
+ Horde_Vfs \
+ Horde_View
+
+# Optional but we want it
+USE_HORDE_RUN+= Horde_Db \
+ Horde_Share
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
+.include <bsd.port.post.mk>
diff --git a/ftp/horde-gollem/distinfo b/ftp/horde-gollem/distinfo
new file mode 100644
index 000000000000..7c7a9289ca72
--- /dev/null
+++ b/ftp/horde-gollem/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Horde/gollem-3.0.0RC1.tgz) = 7d9aec8a48b34e6d848788cf393b64b721bd1a5aa863122c2b627ee537441bdf
+SIZE (Horde/gollem-3.0.0RC1.tgz) = 1071511
diff --git a/ftp/horde-gollem/pkg-descr b/ftp/horde-gollem/pkg-descr
new file mode 100644
index 000000000000..da1a582762a8
--- /dev/null
+++ b/ftp/horde-gollem/pkg-descr
@@ -0,0 +1,5 @@
+Gollem is a web-based File Manager, providing the ability to fully manage
+a hierarchical file system stored in a variety of backends such as a SQL
+database, as part of a real filesystem, or on FTP, Samba or SSH servers.
+
+WWW: http://www.horde.org/apps/gollem/