aboutsummaryrefslogtreecommitdiff
path: root/ftp/hsftp
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2012-12-14 02:31:55 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2012-12-14 02:31:55 +0000
commit68e328e59f4c7c586f5f732a92942f4181c4e201 (patch)
tree042ae6c340da5433a2260b06ed5a1139dd2acade /ftp/hsftp
parent0dcdb66111e71c1a728fc0b272827f77c7dbb7dd (diff)
downloadports-68e328e59f4c7c586f5f732a92942f4181c4e201.tar.gz
ports-68e328e59f4c7c586f5f732a92942f4181c4e201.zip
- Support USE_READLINE.
- Add LICENSE. - Add MAKE_JOBS_SAFE. - Trim header. - Convert to new option framework. PR: ports/171998 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=308875
Diffstat (limited to 'ftp/hsftp')
-rw-r--r--ftp/hsftp/Makefile26
1 files changed, 16 insertions, 10 deletions
diff --git a/ftp/hsftp/Makefile b/ftp/hsftp/Makefile
index c3a0fb6bb3cb..84272e97fde9 100644
--- a/ftp/hsftp/Makefile
+++ b/ftp/hsftp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: hsftp
-# Date created: Mon 03 Jul 2000
-# Whom: will
-#
+# Created by: will
# $FreeBSD$
-#
PORTNAME= hsftp
PORTVERSION= 1.15
@@ -15,22 +11,32 @@ MASTER_SITES= http://la-samhna.de/hsftp/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= FTP emulator that uses ssh to transport commands/data
+LICENSE= GPLv2
+
+OPTIONS_DEFINE= OPENSSH READLINE
+OPTIONS_DEFAULT=READLINE
+OPENSSH_DESC= Build with OpenSSH support
+READLINE_DESC= Enable readline support
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-readline
MAKEFILE= makefile
+MAKE_JOBS_SAFE= yes
+
MAN1= hsftp.1
PLIST_FILES= bin/hsftp
-OPTIONS_DEFINE= OPENSSH
-OPENSSH_DESC= Build with OpenSSH support
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENSSH}
-RUN_DEPENDS+= ssh:${PORTSDIR}/security/openssh
+RUN_DEPENDS+= ssh:${PORTSDIR}/security/openssh-portable
CONFIGURE_ARGS+= --with-openssh
.endif
+.if ${PORT_OPTIONS:MREADLINE}
+USE_READLINE= yes
+CONFIGURE_ARGS+= --with-readline
+.endif
+
pre-patch:
${REINPLACE_CMD} -e '2343d' ${WRKSRC}/configure