aboutsummaryrefslogtreecommitdiff
path: root/ftp/hsftp
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-08 14:31:11 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-08 14:31:11 +0000
commitdf4fdef577549b590c1727976b1ecc992f468f67 (patch)
tree49d128320a4cd9c8d0d530f43c4df49d6c055ccb /ftp/hsftp
parent5d14c6f625cb0f8e66fc22e6fed8d78936d24bc4 (diff)
downloadports-df4fdef577549b590c1727976b1ecc992f468f67.tar.gz
ports-df4fdef577549b590c1727976b1ecc992f468f67.zip
- Use options helpers
- Add stage support
Notes
Notes: svn path=/head/; revision=343338
Diffstat (limited to 'ftp/hsftp')
-rw-r--r--ftp/hsftp/Makefile22
1 files changed, 7 insertions, 15 deletions
diff --git a/ftp/hsftp/Makefile b/ftp/hsftp/Makefile
index 41d7cd591708..2835b26ee72a 100644
--- a/ftp/hsftp/Makefile
+++ b/ftp/hsftp/Makefile
@@ -21,27 +21,19 @@ READLINE_DESC= Enable readline support
GNU_CONFIGURE= yes
MAKEFILE= makefile
-MAN1= hsftp.1
-PLIST_FILES= bin/hsftp
+PLIST_FILES= bin/hsftp man/man1/hsftp.1.gz
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPENSSH_RUN_DEPENDS= ssh:${PORTSDIR}/security/openssh-portable
+OPENSSH_CONFIGURE_WITH= openssh
-.if ${PORT_OPTIONS:MOPENSSH}
-RUN_DEPENDS+= ssh:${PORTSDIR}/security/openssh-portable
-CONFIGURE_ARGS+= --with-openssh
-.endif
-
-.if ${PORT_OPTIONS:MREADLINE}
-USES+= readline
-CONFIGURE_ARGS+= --with-readline
-.endif
+READLINE_USES= readline
+READLINE_CONFIGURE_WITH= readline
pre-patch:
${REINPLACE_CMD} -e '2343d' ${WRKSRC}/configure
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/hsftp ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/hsftp.1 ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/hsftp ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/hsftp.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>