aboutsummaryrefslogtreecommitdiff
path: root/ftp/ncftpd/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2001-06-27 13:34:06 +0000
committerPeter Pentchev <roam@FreeBSD.org>2001-06-27 13:34:06 +0000
commit8c410f8959c541f12ee77adbf6f2c4e8f5232b42 (patch)
tree4a1360aedab4cc3f104597ca34271f41aa2aa98e /ftp/ncftpd/Makefile
parent6fe5bfb1cb26c096d2c25aa4901b938f720308eb (diff)
downloadports-8c410f8959c541f12ee77adbf6f2c4e8f5232b42.tar.gz
ports-8c410f8959c541f12ee77adbf6f2c4e8f5232b42.zip
Notes
Diffstat (limited to 'ftp/ncftpd/Makefile')
-rw-r--r--ftp/ncftpd/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/ftp/ncftpd/Makefile b/ftp/ncftpd/Makefile
new file mode 100644
index 000000000000..7db0b3a7a9e6
--- /dev/null
+++ b/ftp/ncftpd/Makefile
@@ -0,0 +1,44 @@
+# New ports collection Makefile for: ncftpd
+# Date created: 19 June 2001
+# Whom: Justin Stanford <jus@security.za.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ncftpd
+PORTVERSION= 2.7.0
+CATEGORIES= ftp
+MASTER_SITES= ftp://ftp.ncftp.com/ncftpd/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsd4.2-${ARCH}-export
+
+MAINTAINER= jus@security.za.net
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+ONLY_FOR_ARCHS= i386
+NO_BUILD= YES
+LICENSE= shareware
+RESTRICTED= "30 day evaluation license"
+
+do-install:
+ ${MKDIR} ${PREFIX}/etc/ncftpd
+ ${INSTALL_PROGRAM} ${WRKSRC}/ncftpd ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/ncftpd_edquota ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/ncftpd_passwd ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/ncftpd_repquota ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/ncftpd_spy ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/conf/general.cf-dist ${PREFIX}/etc/ncftpd
+ ${INSTALL_DATA} ${WRKSRC}/conf/domain.cf-dist ${PREFIX}/etc/ncftpd
+ ${INSTALL_SCRIPT} ${SCRIPTDIR}/ncftpd.sh ${PREFIX}/etc/rc.d
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ncftpd
+ ${INSTALL_DATA} ${WRKSRC}/install.html ${PREFIX}/share/doc/ncftpd
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/ncftpd
+ ${INSTALL_DATA} ${WRKSRC}/README.freebsd ${PREFIX}/share/doc/ncftpd
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${PREFIX}/share/doc/ncftpd
+.endif
+ ${SED} -e 's,%%PREFIX%%,${PREFIX},' ${PKGMESSAGE}
+
+.include <bsd.port.mk>