aboutsummaryrefslogtreecommitdiff
path: root/ftp/pear-Net_FTP
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-01-09 05:02:28 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-01-09 05:02:28 +0000
commit0aba1dbbc8d3f419af763e5bb4a2cf716ed994c2 (patch)
tree169c4287841bf0d1d6d07c62845fd67e56c1dc6d /ftp/pear-Net_FTP
parent4bbb35b98282b36a604e8c64bdbe7f45b45e21f9 (diff)
downloadports-0aba1dbbc8d3f419af763e5bb4a2cf716ed994c2.tar.gz
ports-0aba1dbbc8d3f419af763e5bb4a2cf716ed994c2.zip
New port: net/pear-Net_FTP PEAR OO interface to the PHP FTP functions
plus some additions Net_FTP allows you to communicate with FTP servers in a more comfortable way than the native FTP functions of PHP do. The class implements everything nativly supported by PHP and additionally features like recursive up- and downloading, dircreation and chmodding. It although implements an observer pattern to allow for example the view of a progress bar. Cold Fusion tags. PR: ports/75915 Submitted by: Antônio Carlos Venâncio Júnior <antonio@php.net>
Notes
Notes: svn path=/head/; revision=125927
Diffstat (limited to 'ftp/pear-Net_FTP')
-rw-r--r--ftp/pear-Net_FTP/Makefile27
-rw-r--r--ftp/pear-Net_FTP/distinfo2
-rw-r--r--ftp/pear-Net_FTP/pkg-descr7
3 files changed, 36 insertions, 0 deletions
diff --git a/ftp/pear-Net_FTP/Makefile b/ftp/pear-Net_FTP/Makefile
new file mode 100644
index 000000000000..13c9d33e8f16
--- /dev/null
+++ b/ftp/pear-Net_FTP/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: pear-Net_FTP
+# Date created: 06 January 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_FTP
+PORTVERSION= 1.3.0
+CATEGORIES= ftp pear
+DISTNAME= ${PORTNAME}-${PORTVERSION}RC2
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR OO interface to the PHP FTP functions plus some additions
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= ftp
+
+FILES= Net/FTP.php Net/FTP/Observer.php
+EXAMPLES= extensions.ini index.php observer.php
+_EXAMPLESDIR= example
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/ftp/pear-Net_FTP/distinfo b/ftp/pear-Net_FTP/distinfo
new file mode 100644
index 000000000000..f4608f98e723
--- /dev/null
+++ b/ftp/pear-Net_FTP/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Net_FTP-1.3.0RC2.tgz) = 05fc7fea7bc80462f4e8990c021feec3
+SIZE (PEAR/Net_FTP-1.3.0RC2.tgz) = 19442
diff --git a/ftp/pear-Net_FTP/pkg-descr b/ftp/pear-Net_FTP/pkg-descr
new file mode 100644
index 000000000000..54fe165d7255
--- /dev/null
+++ b/ftp/pear-Net_FTP/pkg-descr
@@ -0,0 +1,7 @@
+Net_FTP allows you to communicate with FTP servers in a more comfortable way
+than the native FTP functions of PHP do. The class implements everything nativly
+supported by PHP and additionally features like recursive up- and downloading,
+dircreation and chmodding. It although implements an observer pattern to allow
+for example the view of a progress bar.
+
+WWW: http://pear.php.net/package/Net_FTP/