aboutsummaryrefslogtreecommitdiff
path: root/ftp/proftpd
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2014-03-27 23:26:04 +0000
committerMartin Matuska <mm@FreeBSD.org>2014-03-27 23:26:04 +0000
commit68eeec6389133d0d1210a2b87a4d5cc10981736b (patch)
tree47bc1921c5c2377f65fe1514501b27776605e3bc /ftp/proftpd
parentc92c569b7259fd3e6970a7770a7d8b65132eeaf3 (diff)
downloadports-68eeec6389133d0d1210a2b87a4d5cc10981736b.tar.gz
ports-68eeec6389133d0d1210a2b87a4d5cc10981736b.zip
- Add DOCS option.
- When the NLS option is enabled the configure script looks for iconv_open() and libiconv_open() functions in libiconv before trying libc. This means that on FreeBSD 10 proftpd depends on converters/libiconv when it is installed but it should use iconv from libc instead. To fix this add ac_cv_lib_iconv_iconv_open=no and ac_cv_lib_iconv_libiconv_open=no to CONFIGURE_ARGS to bypass those configure tests when ICONV_LIB is empty. - Remove references to -lintl. The configure script detects it correctly. PR: ports/187860 Submitted by: tijl@FreeBSD.org
Notes
Notes: svn path=/head/; revision=349373
Diffstat (limited to 'ftp/proftpd')
-rw-r--r--ftp/proftpd/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index c4c2406e9b00..1945e5d5eff1 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -5,7 +5,7 @@ PORTNAME?= proftpd
.if !defined(DISTVERSION)
PORTVERSION?= ${PROFTPD_VERSION}
.endif
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES?= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
https://github.com/downloads/proftpd/proftpd.github.com/ \
@@ -85,7 +85,7 @@ PLIST_FILES+= libexec/proftpd/${m}.a \
.endfor
PLIST_DIRSTRY+= libexec/proftpd
.else
-OPTIONS_DEFINE= HTMLDOCS IPV6 NLS MEMCACHE PCRE
+OPTIONS_DEFINE= DOCS HTMLDOCS IPV6 NLS MEMCACHE PCRE
OPTIONS_DEFAULT= IPV6 NLS PCRE
HTMLDOCS_DESC= Include HTML documentation
@@ -158,8 +158,7 @@ CONFIGURE_ARGS+= --disable-ipv6
.if ${PORT_OPTIONS:MNLS}
CONFIGURE_ARGS+= --enable-nls
-USES+= gettext
-PROFTPD_LIBS+= -lintl -L${LOCALBASE}/lib
+USES+= gettext iconv
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
@@ -198,12 +197,16 @@ CONFIGURE_ARGS+= --with-shared=${_MODULES:C/^://g}
CONFIGURE_ARGS+= --with-includes=${INCLUDEDIRS}
CONFIGURE_ARGS+= --with-libraries=${LIBDIRS}
+.include <bsd.port.pre.mk>
+
.if !defined(_BUILDING_PROFTPD_MODULE)
-post-patch:
-.if ${PORT_OPTIONS:MNLS}
- @${REINPLACE_CMD} -e 's|-lsupp|-lsupp -lintl|g' ${WRKSRC}/Makefile.in
+.if empty(ICONV_LIB)
+CONFIGURE_ARGS+= ac_cv_lib_iconv_iconv_open=no \
+ ac_cv_lib_iconv_libiconv_open=no
.endif
+
+post-patch:
@${REINPLACE_CMD} -e 's|proftpd\.conf|proftpd.conf.sample|g' ${WRKSRC}/Makefile.in
pre-configure:
@@ -247,4 +250,4 @@ post-install:
@${INSTALL_MAN} ${WRKSRC}/src/ftpdctl.8 ${STAGEDIR}${MAN8PREFIX}/man/man8/
.endif #!defined(_BUILDING_PROFTPD_MODULE)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>