aboutsummaryrefslogtreecommitdiff
path: root/ftp/py-aioftp
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-20 11:07:20 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-20 12:32:13 +0000
commit1958373e537fc27e5bc2fa63c3a9c76e74f0ea4c (patch)
treed254a65f456443513900070fa7fc488036e95c31 /ftp/py-aioftp
parent29ad38cfe5d910c3f855eae9abaac2b346c7e8b7 (diff)
downloadports-1958373e537fc27e5bc2fa63c3a9c76e74f0ea4c.tar.gz
ports-1958373e537fc27e5bc2fa63c3a9c76e74f0ea4c.zip
ftp/py-aioftp: switch to USES=pytest
Switch to USES=pytest and ignore test which fails [1] on FreeBSD Reported by: reprise [1]
Diffstat (limited to 'ftp/py-aioftp')
-rw-r--r--ftp/py-aioftp/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/ftp/py-aioftp/Makefile b/ftp/py-aioftp/Makefile
index eab99f5d0968..3c0c29ed9430 100644
--- a/ftp/py-aioftp/Makefile
+++ b/ftp/py-aioftp/Makefile
@@ -10,19 +10,17 @@ COMMENT= FTP client/server for asyncio
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/license.txt
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-asyncio>=0:devel/py-pytest-asyncio@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest4-asyncio>=0:devel/py-pytest4-asyncio@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest4-cov>=0:devel/py-pytest4-cov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}trustme>=0:security/py-trustme@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}async_timeout>0:devel/py-async_timeout@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}siosocks>0:net/py-siosocks@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}idna>0:dns/py-idna@${PY_FLAVOR}
-USES= python:3.7+
+USES= python:3.7+ pytest:4
USE_PYTHON= autoplist distutils
NO_ARCH= yes
-
-do-test:
- @cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest -v -rs
+# https://github.com/aio-libs/aioftp/issues/152
+PYTEST_IGNORED_TESTS= test_pasv_connection_pasv_forced_response_address
.include <bsd.port.mk>