aboutsummaryrefslogtreecommitdiff
path: root/ftp/py-pycurl
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-12-12 23:43:50 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-12-12 23:43:50 +0000
commit4676ca5994f9c72a8d9c64607885dc363fe3d52e (patch)
tree7058f2db9cae7f106b566a30662dff6325715135 /ftp/py-pycurl
parent0c37ba26506dec18368a21f78d37add7f4c3c64a (diff)
downloadports-4676ca5994f9c72a8d9c64607885dc363fe3d52e.tar.gz
ports-4676ca5994f9c72a8d9c64607885dc363fe3d52e.zip
- Move ftp/py-curl to ftp/py-pycurl
- Bump PORTREVISION for dependent ports
Notes
Notes: svn path=/head/; revision=403641
Diffstat (limited to 'ftp/py-pycurl')
-rw-r--r--ftp/py-pycurl/Makefile27
-rw-r--r--ftp/py-pycurl/distinfo2
-rw-r--r--ftp/py-pycurl/pkg-descr5
3 files changed, 34 insertions, 0 deletions
diff --git a/ftp/py-pycurl/Makefile b/ftp/py-pycurl/Makefile
new file mode 100644
index 000000000000..f2f9eeb1e001
--- /dev/null
+++ b/ftp/py-pycurl/Makefile
@@ -0,0 +1,27 @@
+# Created by: Hye-Shik Chang
+# $FreeBSD$
+
+PORTNAME= pycurl
+PORTVERSION= 7.19.5.3
+PORTREVISION= 1
+CATEGORIES= ftp python
+MASTER_SITES= CHEESESHOP \
+ http://pycurl.sourceforge.net/download/ \
+ http://pycurl.sourceforge.net/download/00-OLD-VERSIONS/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python interface to libcurl
+
+LICENSE= LGPL21 MIT
+LICENSE_COMB= dual
+
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+
+USE_PYTHON= autoplist concurrent distutils
+USES= python
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}.so
+
+.include <bsd.port.mk>
diff --git a/ftp/py-pycurl/distinfo b/ftp/py-pycurl/distinfo
new file mode 100644
index 000000000000..3b849aea2005
--- /dev/null
+++ b/ftp/py-pycurl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pycurl-7.19.5.3.tar.gz) = 24f6c4016b1dd2a5e29d1b025ac2ad61f80c17adfdcf8a7f47aefab63ace78d7
+SIZE (pycurl-7.19.5.3.tar.gz) = 154800
diff --git a/ftp/py-pycurl/pkg-descr b/ftp/py-pycurl/pkg-descr
new file mode 100644
index 000000000000..f3afd1ea220a
--- /dev/null
+++ b/ftp/py-pycurl/pkg-descr
@@ -0,0 +1,5 @@
+Python module interface to the cURL library which is
+a tool for transferring files with URL syntax, supporting
+many protocols.
+
+WWW: http://pycurl.sourceforge.net/