aboutsummaryrefslogtreecommitdiff
path: root/ftp/py-tftpy
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-05-19 11:06:57 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-05-19 11:06:57 +0000
commit7b436120fee58458048b6cbb028c006c6fdaa2ec (patch)
tree1618d1d970f7160ea75f927bc8700339562d672f /ftp/py-tftpy
parenta87d872b65d3ae231b54b913e1318fa159f5b928 (diff)
downloadports-7b436120fee58458048b6cbb028c006c6fdaa2ec.tar.gz
ports-7b436120fee58458048b6cbb028c006c6fdaa2ec.zip
Update to 0.7.0
- Change MASTER_SITES to CHEESESHOP - Update COMMENT - Update pkg-descr - Update WWW - Add GitHub repository to WWW Changes: https://github.com/msoulier/tftpy/blob/master/README https://github.com/msoulier/tftpy/blob/master/ChangeLog
Notes
Notes: svn path=/head/; revision=470384
Diffstat (limited to 'ftp/py-tftpy')
-rw-r--r--ftp/py-tftpy/Makefile10
-rw-r--r--ftp/py-tftpy/distinfo6
-rw-r--r--ftp/py-tftpy/files/patch-tftpy-TftpServer.py13
-rw-r--r--ftp/py-tftpy/files/patch-tftpy-TftpStates.py11
-rw-r--r--ftp/py-tftpy/pkg-descr8
5 files changed, 12 insertions, 36 deletions
diff --git a/ftp/py-tftpy/Makefile b/ftp/py-tftpy/Makefile
index 4a26e2584a2c..5b7592959a89 100644
--- a/ftp/py-tftpy/Makefile
+++ b/ftp/py-tftpy/Makefile
@@ -2,13 +2,13 @@
# $FreeBSD$
PORTNAME= tftpy
-PORTVERSION= 0.6.2
-PORTREVISION= 2
+PORTVERSION= 0.7.0
CATEGORIES= ftp python
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
-COMMENT= Pure Python TFTP Implementation
+COMMENT= Pure Python TFTP library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -17,8 +17,4 @@ NO_ARCH= yes
USE_PYTHON= autoplist concurrent distutils
USES= python
-GH_ACCOUNT= msoulier
-GH_TAGNAME= c5a7b52
-USE_GITHUB= yes
-
.include <bsd.port.mk>
diff --git a/ftp/py-tftpy/distinfo b/ftp/py-tftpy/distinfo
index 9104601b2f8e..d24c2c7e2169 100644
--- a/ftp/py-tftpy/distinfo
+++ b/ftp/py-tftpy/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1489402358
-SHA256 (msoulier-tftpy-0.6.2-c5a7b52_GH0.tar.gz) = d294e263b181e35327d4f316d7fd13295056a0ea03b1187836d54496a0a9863c
-SIZE (msoulier-tftpy-0.6.2-c5a7b52_GH0.tar.gz) = 820065
+TIMESTAMP = 1526718503
+SHA256 (tftpy-0.7.0.tar.gz) = 5495d387b5b8338b1c88a8c1cb4f282ef130c4f0bef9caa56db32467854c76bd
+SIZE (tftpy-0.7.0.tar.gz) = 32252
diff --git a/ftp/py-tftpy/files/patch-tftpy-TftpServer.py b/ftp/py-tftpy/files/patch-tftpy-TftpServer.py
deleted file mode 100644
index ade11f443ff4..000000000000
--- a/ftp/py-tftpy/files/patch-tftpy-TftpServer.py
+++ /dev/null
@@ -1,13 +0,0 @@
---- tftpy/TftpServer.py.orig 2016-07-07 08:32:15 UTC
-+++ tftpy/TftpServer.py
-@@ -53,8 +53,8 @@ class TftpServer(TftpSession):
- for name in 'dyn_file_func', 'upload_open':
- attr = getattr(self, name)
- if attr and not callable(attr):
-- raise TftpException, "%s supplied, but it is not callable." % (
-- name,)
-+ raise TftpException("%s supplied, but it is not callable." % (
-+ name))
- if os.path.exists(self.root):
- log.debug("tftproot %s does exist", self.root)
- if not os.path.isdir(self.root):
diff --git a/ftp/py-tftpy/files/patch-tftpy-TftpStates.py b/ftp/py-tftpy/files/patch-tftpy-TftpStates.py
deleted file mode 100644
index 5967afc2c6df..000000000000
--- a/ftp/py-tftpy/files/patch-tftpy-TftpStates.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- tftpy/TftpStates.py.orig 2016-07-07 08:32:15 UTC
-+++ tftpy/TftpStates.py
-@@ -368,7 +368,7 @@ class TftpStateServerRecvWRQ(TftpServerS
- f = self.context.upload_open(path, self.context)
- if f is None:
- self.sendError(TftpErrors.AccessViolation)
-- raise TftpException, "Dynamic path %s not permitted" % path
-+ raise TftpException("Dynamic path %s not permitted" % path)
- else:
- self.context.fileobj = f
- else:
diff --git a/ftp/py-tftpy/pkg-descr b/ftp/py-tftpy/pkg-descr
index 68d721570e6f..9648af54e78c 100644
--- a/ftp/py-tftpy/pkg-descr
+++ b/ftp/py-tftpy/pkg-descr
@@ -1,3 +1,7 @@
-TFTPy is a Pure Python TFTP Implementation.
+Tftpy is a TFTP library for the Python programming language. It includes client
+and server classes, with sample implementations. Hooks are included for easy
+inclusion in a UI for populating progress indicators. It supports RFCs 1350,
+2347, 2348 and the tsize option from RFC 2349.
-WWW: http://tftpy.sourceforge.net/
+WWW: https://pypi.org/project/tftpy/
+WWW: https://github.com/msoulier/tftpy