aboutsummaryrefslogtreecommitdiff
path: root/ftp/smbftpd
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-04-18 19:35:44 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-04-18 19:35:44 +0000
commitf47c438e2f70db591abe7fc09c56e22ad40ecc60 (patch)
tree90144ff95c616a231afccb5434504325378381ca /ftp/smbftpd
parentf806355804cba4359bf87dc4042178d5f0026177 (diff)
downloadports-f47c438e2f70db591abe7fc09c56e22ad40ecc60.tar.gz
ports-f47c438e2f70db591abe7fc09c56e22ad40ecc60.zip
STAGE support.
Notes
Notes: svn path=/head/; revision=351562
Diffstat (limited to 'ftp/smbftpd')
-rw-r--r--ftp/smbftpd/Makefile49
-rw-r--r--ftp/smbftpd/pkg-descr2
2 files changed, 20 insertions, 31 deletions
diff --git a/ftp/smbftpd/Makefile b/ftp/smbftpd/Makefile
index 425d4825ae2b..6af7ab979182 100644
--- a/ftp/smbftpd/Makefile
+++ b/ftp/smbftpd/Makefile
@@ -11,45 +11,34 @@ MAINTAINER= jnlin@csie.nctu.edu.tw
COMMENT= FTP daemon using Samba-like share management mechanism
OPTIONS_DEFINE= MYSQL PGSQL SSL ICONV
-MYSQL_DESC= Users database is a MySQL database
-PGSQL_DESC= Users database is a PostgreSQL database
-SSL_DESC= Enable SSL/TLS support
ICONV_DESC= Enable codepage to unicode conversion for UTF-8 FTP
HAS_CONFIGURE= yes
-MAKE_ENV= OSTYPE=FreeBSD
-CONFIGURE_ARGS= "--prefix=${PREFIX}"
+MAKE_ENV+= OSTYPE=FreeBSD
+CONFIGURE_ARGS+= "--prefix=${PREFIX}"
USES= perl5
USE_RC_SUBR= ${PORTNAME}
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
-CONFIGURE_ARGS+= "--with-mysql"
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
-CONFIGURE_ARGS+= "--with-pgsql"
-.endif
-
-.if ${PORT_OPTIONS:MICONV}
-USES+= iconv
-CONFIGURE_ARGS+= "--with-iconv"
-.endif
-
-.if ${PORT_OPTIONS:MSSL}
-CONFIGURE_ARGS+= "--with-ssl"
-.endif
+MYSQL_USE= MYSQL=yes
+MYSQL_CONFIGURE_WITH= mysql
+PGSQL_USE= PGSQL=yes
+PGSQL_CONFIGURE_WITH= pgsql
+ICONV_USES= iconv
+ICONV_CONFIGURE_WITH= iconv
+SSL_CONFIGURE_WITH= ssl
post-extract:
- @${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
+ ${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
post-patch:
- @${REINPLACE_CMD} -e '/^CONFIGS = / s|\.conf|&.sample|g' ${WRKSRC}/Makefile
- @cd ${WRKSRC}/conf/ && (${LS} *.conf | ${XARGS} -I % ${MV} % %.sample)
+ ${REINPLACE_CMD} -e '/^CONFIGS = / s|\.conf|&.sample|g' ${WRKSRC}/Makefile
+ cd ${WRKSRC}/conf/ && (${LS} *.conf | ${XARGS} -I % ${MV} % %.sample)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}-user ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf/*.sample ${STAGEDIR}${ETCDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ftp/smbftpd/pkg-descr b/ftp/smbftpd/pkg-descr
index 8b14736ef39f..7c95d11410bd 100644
--- a/ftp/smbftpd/pkg-descr
+++ b/ftp/smbftpd/pkg-descr
@@ -3,4 +3,4 @@ original FreeBSD ftpd features, it enhances the user permission control,
integrate configuration files, and more useful features. SmbFTPD also support
SSL/TLS encryption.
-WWW: http://www.twbsd.org/enu/smbftpd/index.php
+WWW: http://www.twbsd.org/enu/smbftpd/index.php