aboutsummaryrefslogtreecommitdiff
path: root/ftp/spegla
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2008-10-05 12:30:44 +0000
committerHiroki Sato <hrs@FreeBSD.org>2008-10-05 12:30:44 +0000
commit37d5e627fdd6805c2dfad3edba485c4e1b639181 (patch)
treec227f161324dfcc0b0823f187efc8cf59bade4a2 /ftp/spegla
parent657501c6d38188d772000dbdabd2c5ce870c8712 (diff)
downloadports-37d5e627fdd6805c2dfad3edba485c4e1b639181.tar.gz
ports-37d5e627fdd6805c2dfad3edba485c4e1b639181.zip
- Fix NOPORTEXAMPLES=yes case.
- Add WITH_IPV6 option.
Notes
Notes: svn path=/head/; revision=221234
Diffstat (limited to 'ftp/spegla')
-rw-r--r--ftp/spegla/Makefile29
-rw-r--r--ftp/spegla/files/patch-Makefile32
-rw-r--r--ftp/spegla/files/patch-ac12
-rw-r--r--ftp/spegla/pkg-plist6
4 files changed, 49 insertions, 30 deletions
diff --git a/ftp/spegla/Makefile b/ftp/spegla/Makefile
index 07544307d1bc..764aa3cf359a 100644
--- a/ftp/spegla/Makefile
+++ b/ftp/spegla/Makefile
@@ -8,7 +8,7 @@
PORTNAME= spegla
PORTVERSION= 1.1p4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= ftp ipv6
MASTER_SITES= ftp://subzero.campus.luth.se/pub/spegla/ \
ftp://ftp.luth.se/pub/unix/mirror/
@@ -20,21 +20,26 @@ MAINTAINER= hrs@FreeBSD.org
COMMENT= A mirror program for FTP sites (written in C)
MAKE_ARGS= MANDIR=${MAN1PREFIX}/man/man
+PLIST_FILES= bin/spegla
+PORTEXAMPLES= freebsd.org spegla.conf spegla.sh
MANCOMPRESSED= yes
MAN1= spegla.1
-post-extract:
-.for file in engine.c regcomp.c regerror.c regexec.c regfree.c cclass.h cname.h regex.h regex2.h utils.h
- @${CP} ${WRKSRC}/regex/${file} ${WRKSRC}
-.endfor
-
-pre-install:
- @${MKDIR} ${EXAMPLESDIR}
+OPTIONS= IPV6 "IPv6 support" on
+.if !defined(NOPORTEXAMPLES)
post-install:
- ${INSTALL_DATA} ${WRKSRC}/freebsd.org ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/spegla.conf ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/spegla.sh ${EXAMPLESDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && \
+ ${INSTALL_DATA} freebsd.org spegla.conf ${EXAMPLESDIR} && \
+ ${INSTALL_SCRIPT} spegla.sh ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_IPV6)
+MAKE_ARGS+= -DINET6
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/ftp/spegla/files/patch-Makefile b/ftp/spegla/files/patch-Makefile
new file mode 100644
index 000000000000..ba9ee5b21f53
--- /dev/null
+++ b/ftp/spegla/files/patch-Makefile
@@ -0,0 +1,32 @@
+--- Makefile.orig 2008-10-05 21:20:36.000000000 +0900
++++ Makefile 2008-10-05 21:22:33.000000000 +0900
+@@ -8,7 +8,8 @@
+
+ PROG = spegla
+ SRCS = jftp.c parserow.c spegla.c tgetopt.c container.c spf_util.c \
+- que_syms.c e_err.c
++ que_syms.c e_err.c \
++ regcomp.c regerror.c regexec.c regfree.c
+ .if !(defined(HAVE_STRLCPY) && ${HAVE_STRLCPY} == "yes")
+ SRCS += strlcpy.c
+ CPPFLAGS += -DNO_STRLCPY
+@@ -16,14 +17,6 @@
+
+ MAN = spegla.1
+
+-FILES = spegla.sh spegla.conf
+-FILESDIR = ${PREFIX}/share/examples/spegla
+-
+-filesinstall:: ${PREFIX}/share/examples/spegla
+-
+-${PREFIX}/share/examples/spegla:
+- mkdir -p ${PREFIX}/share/examples/spegla
+-
+ #WARNS = 2
+ CFLAGS += -Wall
+ LDADD += -lcompat
+@@ -73,3 +66,4 @@
+ cp ${.CURDIR}/../tgetopt/tgetopt.c tgetopt.c
+ .endif
+
++.PATH: ${.CURDIR}/regex
diff --git a/ftp/spegla/files/patch-ac b/ftp/spegla/files/patch-ac
deleted file mode 100644
index 35675a1276bc..000000000000
--- a/ftp/spegla/files/patch-ac
+++ /dev/null
@@ -1,12 +0,0 @@
---- Makefile.dist Sat May 27 22:50:20 2000
-+++ Makefile Thu Jun 29 20:06:23 2000
-@@ -8,7 +8,8 @@
-
- PROG = spegla
- SRCS = jftp.c parserow.c spegla.c tgetopt.c container.c spf_util.c \
-- que_syms.c e_err.c
-+ que_syms.c e_err.c \
-+ regcomp.c regerror.c regexec.c regfree.c
- .if !(defined(HAVE_STRLCPY) && ${HAVE_STRLCPY} == "yes")
- SRCS += strlcpy.c
- CPPFLAGS += -DNO_STRLCPY
diff --git a/ftp/spegla/pkg-plist b/ftp/spegla/pkg-plist
deleted file mode 100644
index f07214e6f073..000000000000
--- a/ftp/spegla/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-@comment $FreeBSD$
-bin/spegla
-%%EXAMPLESDIR%%/freebsd.org
-%%EXAMPLESDIR%%/spegla.conf
-%%EXAMPLESDIR%%/spegla.sh
-@dirrm %%EXAMPLESDIR%%