aboutsummaryrefslogtreecommitdiff
path: root/ftp/spegla
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2001-01-19 23:16:42 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2001-01-19 23:16:42 +0000
commit8bb488d141d113bd2c3f3338931ead2635903a58 (patch)
tree383c636446854af25a0c1868cea91754f0d50f7f /ftp/spegla
parent15c945918e47d001732ff998fda84e44cdabe226 (diff)
downloadports-8bb488d141d113bd2c3f3338931ead2635903a58.tar.gz
ports-8bb488d141d113bd2c3f3338931ead2635903a58.zip
Fix at minfree checking when filesystem has free space over 4GB.
Approved by: maintainer
Notes
Notes: svn path=/head/; revision=37351
Diffstat (limited to 'ftp/spegla')
-rw-r--r--ftp/spegla/Makefile1
-rw-r--r--ftp/spegla/files/patch-spegla.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/ftp/spegla/Makefile b/ftp/spegla/Makefile
index 56fde261fa7d..059edc911cc2 100644
--- a/ftp/spegla/Makefile
+++ b/ftp/spegla/Makefile
@@ -8,6 +8,7 @@
PORTNAME= spegla
PORTVERSION= 1.1p4
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.luth.se/pub/unix/mirror/ \
ftp://subzero.campus.luth.se/pub/spegla/
diff --git a/ftp/spegla/files/patch-spegla.c b/ftp/spegla/files/patch-spegla.c
new file mode 100644
index 000000000000..2af5159fbf9c
--- /dev/null
+++ b/ftp/spegla/files/patch-spegla.c
@@ -0,0 +1,11 @@
+--- spegla.c.orig Sat May 27 22:38:14 2000
++++ spegla.c Fri Jan 19 19:36:43 2001
+@@ -728,7 +728,7 @@
+ #ifdef ULTRIX
+ if ((f.fd_req.bfreen * 1024) < minfree)
+ #else
+- if ((f.f_bsize * f.f_bavail) < minfree)
++ if (((long long)f.f_bsize * f.f_bavail) < minfree)
+ #endif
+ e_errx(1, "%s: Not enough space left", path);
+