aboutsummaryrefslogtreecommitdiff
path: root/ftp/spegla
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2016-11-04 19:21:06 +0000
committerHiroki Sato <hrs@FreeBSD.org>2016-11-04 19:21:06 +0000
commitfde0acf7afe2d50f9920dc9510ce682d109815b5 (patch)
tree71402d9f584db50442ccd4dc8f85bcef7eaf17f0 /ftp/spegla
parentf1197dbcac2e8e8995157d05f9d9361b593b906a (diff)
downloadports-fde0acf7afe2d50f9920dc9510ce682d109815b5.tar.gz
ports-fde0acf7afe2d50f9920dc9510ce682d109815b5.zip
Resurrect ftp/spegla. The original upstream has gone but the distfile is
maintained in the Github repo now.
Notes
Notes: svn path=/head/; revision=425351
Diffstat (limited to 'ftp/spegla')
-rw-r--r--ftp/spegla/Makefile37
-rw-r--r--ftp/spegla/distinfo3
-rw-r--r--ftp/spegla/pkg-descr3
3 files changed, 43 insertions, 0 deletions
diff --git a/ftp/spegla/Makefile b/ftp/spegla/Makefile
new file mode 100644
index 000000000000..250b8a3d1005
--- /dev/null
+++ b/ftp/spegla/Makefile
@@ -0,0 +1,37 @@
+# Created by: Jordan Hubbard <jkh@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= spegla
+PORTVERSION= 1.1p5
+DISTVERSIONPREFIX= v
+CATEGORIES= ftp ipv6
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Mirror program for FTP sites (written in C)
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= uidfix
+USE_GITHUB= yes
+GH_ACCOUNT= hrs-allbsd
+LICENSE_BSD2CLAUSE_REGEX="/ \* [Cc]opyright/,/ \*\//!d;s,^ \*,,;s,^/,,"
+MAKE_ARGS= MANDIR=${MAN1PREFIX}/man/man
+PLIST_FILES= bin/spegla man/man1/spegla.1.gz
+PORTEXAMPLES= freebsd.org spegla.conf spegla.sh
+
+OPTIONS_DEFINE= IPV6
+OPTIONS_DEFAULT=IPV6
+IPV6_MAKE_ARGS= -DINET6
+
+post-extract:
+ cd ${WRKSRC} && ${SED} -e ${LICENSE_BSD2CLAUSE_REGEX} \
+ ${WRKSRC}/spegla.c > ${LICENSE_FILE}
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/freebsd.org ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/spegla.conf ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/spegla.sh ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/ftp/spegla/distinfo b/ftp/spegla/distinfo
new file mode 100644
index 000000000000..990a3218e3ea
--- /dev/null
+++ b/ftp/spegla/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1469008226
+SHA256 (hrs-allbsd-spegla-v1.1p5_GH0.tar.gz) = 9cecdb5ddeb25012f5bd02f27f0feb340fa36526eff122e862d42be004d7722f
+SIZE (hrs-allbsd-spegla-v1.1p5_GH0.tar.gz) = 101505
diff --git a/ftp/spegla/pkg-descr b/ftp/spegla/pkg-descr
new file mode 100644
index 000000000000..c12ed1e7b4f1
--- /dev/null
+++ b/ftp/spegla/pkg-descr
@@ -0,0 +1,3 @@
+Spegla is a mirror program for FTP sites. It was written because the author
+couldn't find any fast mirroring program for big mirrors. It makes a
+complete mirror of a FTP area.