aboutsummaryrefslogtreecommitdiff
path: root/ftp/tnftpd/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-01-03 07:28:00 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-01-03 07:28:00 +0000
commitf6a904c04ff55bf6effce9a17b29cc40c9ff1f19 (patch)
tree8f08379a6bae3391bf6723c8de30552f57c498f0 /ftp/tnftpd/Makefile
parent53a207cbceb937b2a74223e0f200a7ca17a0c226 (diff)
downloadports-f6a904c04ff55bf6effce9a17b29cc40c9ff1f19.tar.gz
ports-f6a904c04ff55bf6effce9a17b29cc40c9ff1f19.zip
Notes
Diffstat (limited to 'ftp/tnftpd/Makefile')
-rw-r--r--ftp/tnftpd/Makefile74
1 files changed, 74 insertions, 0 deletions
diff --git a/ftp/tnftpd/Makefile b/ftp/tnftpd/Makefile
new file mode 100644
index 000000000000..d89e2e16e108
--- /dev/null
+++ b/ftp/tnftpd/Makefile
@@ -0,0 +1,74 @@
+# New ports collection makefile for: tnftpd
+# Date created: 3 August 2003
+# Whom: ports
+#
+# $FreeBSD$
+#
+
+PORTNAME= tnftpd
+PORTVERSION= 2.0b3
+CATEGORIES= ftp ipv6
+MASTER_SITES= ftp://ftp.netbsd.org/pub/NetBSD/misc/tnftp/
+DISTNAME= ${PORTNAME}-2.0-beta3
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Enhanced ftp server from NetBSD
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+
+.if defined(WITH_SOCKS5)
+BUILD_DEPENDS= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
+CONFIGURE_ARGS+= --with-socks5
+.endif
+
+DOCS= ChangeLog README THANKS COPYING
+
+MAN5= ftpd.conf.5 ftpusers.5
+MAN8= tnftpd.8
+
+FIXPREFIX= ftpd.8 ftpd.conf.5 ftpusers.5
+
+pre-patch:
+.for f in ${FIXPREFIX}
+ ${REINPLACE_CMD} -e \
+ "s@^\.Dq Pa /etc@.Dq Pa ${PREFIX}/etc@g; \
+ s@^\.Pa /etc@.Pa ${PREFIX}/etc@g; \
+ s@^\.It Pa /etc/@.It Pa ${PREFIX}/etc/@g; \
+ s@^\.Ss /etc/@.Ss ${PREFIX}/etc/@g; \
+ s@^\.Sx /etc/@.Sx ${PREFIX}/etc/@g; \
+ s@^\.Bl -tag -width /etc/@.Bl -tag -width ${PREFIX}/etc/@g; \
+ s@${PREFIX}/etc/shells@/etc/shells@g; \
+ s@${PREFIX}/etc/motd@/etc/motd@g; \
+ s@${PREFIX}/etc/nologin@/etc/nologin@g; \
+ s@${PREFIX}/etc/pwd.db@/etc/pwd.db@g" \
+ ${WRKSRC}/src/${f}
+.endfor
+ ${REINPLACE_CMD} -e \
+ "s@^#define _DEFAULT_CONFDIR \"/etc\"@#define _DEFAULT_CONFDIR \"${PREFIX}/etc\"@" \
+ ${WRKSRC}/src/pathnames.h
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/tnftpd ${PREFIX}/libexec
+ ${INSTALL_MAN} ${WRKSRC}/src/ftpd.8 ${PREFIX}/man/man8/tnftpd.8
+ ${INSTALL_MAN} ${WRKSRC}/src/ftpd.conf.5 ${PREFIX}/man/man5
+ ${INSTALL_MAN} ${WRKSRC}/src/ftpusers.5 ${PREFIX}/man/man5
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/${PORTNAME}/
+.endfor
+.endif
+
+post-install:
+ @${ECHO} "================================================================================"
+ @${ECHO} "This port relies on a number of configuration files in ${PREFIX}/etc."
+ @${ECHO} "At the very least, create a ftpusers file with the usernams of users you don't"
+ @${ECHO} "want to connect (root, toor, etc.). This will allow non-listed users to log in."
+ @${ECHO} "Copying /etc/ftpusers to ${PREFIX}/etc/ftpusers should be sufficient."
+ @${ECHO}
+ @${ECHO} "See the man files for more information. The man- and configuration files for"
+ @${ECHO} "FreeBSD's built-in ftpd can also be of use as examples/additional info."
+ @${ECHO} "================================================================================"
+
+.include <bsd.port.mk>