aboutsummaryrefslogtreecommitdiff
path: root/ftp/twoftpd
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2017-03-26 04:56:50 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2017-03-26 04:56:50 +0000
commitf2e559d15011ceb1f43b970e55c7210306a484da (patch)
tree7c0bcb2b12007ddaa408fbcfbe5a31edc6d88743 /ftp/twoftpd
parentc21170b0b520b6dc61475d6b986f1d39c24ee9a6 (diff)
downloadports-f2e559d15011ceb1f43b970e55c7210306a484da.tar.gz
ports-f2e559d15011ceb1f43b970e55c7210306a484da.zip
- Bump PORTREVISION to reflect devel/bglibs update.
- Take maintainership.
Notes
Notes: svn path=/head/; revision=436936
Diffstat (limited to 'ftp/twoftpd')
-rw-r--r--ftp/twoftpd/Makefile9
-rw-r--r--ftp/twoftpd/distinfo2
-rw-r--r--ftp/twoftpd/files/patch-Makefile33
3 files changed, 40 insertions, 4 deletions
diff --git a/ftp/twoftpd/Makefile b/ftp/twoftpd/Makefile
index bedb4e6fcf13..1b37e603195b 100644
--- a/ftp/twoftpd/Makefile
+++ b/ftp/twoftpd/Makefile
@@ -3,22 +3,25 @@
PORTNAME= twoftpd
PORTVERSION= 1.43
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= http://untroubled.org/${PORTNAME}/archive/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= araujo@FreeBSD.org
COMMENT= Simple, secure, efficient FTP server
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/bin/bg-installer:devel/bglibs
-LIB_DEPENDS= libcvm-v2client.so:security/cvm
+LIB_DEPENDS= libcvm-v2client.so:security/cvm \
+ libbg.so.2:devel/bglibs
USES= localbase:ldflags
-BGLIBS_LIB= ${LOCALBASE}/lib/bglibs
BGLIBS_INCLUDE= ${LOCALBASE}/include/bglibs
+BGLIBS_LIB= ${LOCALBASE}/lib/bglibs
+USE_LDCONFIG= ${BGLIBS_LIB}
PORTDOCS= NEWS README TODO
PLIST_FILES= bin/twoftpd-anon bin/twoftpd-anon-conf \
diff --git a/ftp/twoftpd/distinfo b/ftp/twoftpd/distinfo
index 10ae2874d9f4..873999b5a881 100644
--- a/ftp/twoftpd/distinfo
+++ b/ftp/twoftpd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1489218354
+TIMESTAMP = 1490332776
SHA256 (twoftpd-1.43.tar.gz) = ed77d2f3020bdbbe1a0a7d9a84780f3525431300e5000901e95a982873e24dc3
SIZE (twoftpd-1.43.tar.gz) = 88125
diff --git a/ftp/twoftpd/files/patch-Makefile b/ftp/twoftpd/files/patch-Makefile
new file mode 100644
index 000000000000..8598d4e65b64
--- /dev/null
+++ b/ftp/twoftpd/files/patch-Makefile
@@ -0,0 +1,33 @@
+--- Makefile.orig 2015-02-04 21:59:50 UTC
++++ Makefile
+@@ -23,11 +23,12 @@ clean: TARGETS
+ clean-spac: clean AUTOFILES
+ rm -f `cat AUTOFILES`
+
+-compile: conf-cc
+- ( echo '#!/bin/sh'; \
++compile: conf-cc conf-bgincs
++ ( bgincs=`head -n 1 conf-bgincs`; \
++ echo '#!/bin/sh'; \
+ echo 'source=$$1; shift'; \
+ echo 'base=`echo "$$source" | sed -e s:\\\\.c$$::`'; \
+- echo exec `head -n 1 conf-cc` -I. '-o $${base}.o -c $$source $${1+"$$@"}'; \
++ echo exec `head -n 1 conf-cc` -I. "-I'$${bgincs}'" '-o $${base}.o -c $$source $${1+"$$@"}'; \
+ ) >compile
+ chmod 755 compile
+
+@@ -54,10 +55,11 @@ libraries: backend.a main.a
+ list.o: compile list.c twoftpd.h backend.h
+ ./compile list.c
+
+-load: conf-ld
+- ( echo '#!/bin/sh';\
++load: conf-ld conf-bglibs
++ ( bglibs=`head -n 1 conf-bglibs`; \
++ echo '#!/bin/sh';\
+ echo 'main="$$1"; shift';\
+- echo exec `head -n 1 conf-ld` -L. '-o "$$main" "$$main.o" $${1+"$$@"}'; \
++ echo exec `head -n 1 conf-ld` -L. "-L'$${bglibs}'" "-Wl,-R'$${bglibs}'" '-o "$$main" "$$main.o" $${1+"$$@"}'; \
+ ) >load
+ chmod 755 load
+