aboutsummaryrefslogtreecommitdiff
path: root/ftp/wcurl
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2024-09-05 11:47:02 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2024-09-05 11:48:39 +0000
commitba7c09d98455357aae46334c18c85187b173dd0f (patch)
tree4353df5d9ff71eb69b0faaffa09c53dc6add76b7 /ftp/wcurl
parenta067c93271149375640f7ad487e5dace034462bd (diff)
Diffstat (limited to 'ftp/wcurl')
-rw-r--r--ftp/wcurl/Makefile31
-rw-r--r--ftp/wcurl/distinfo3
-rw-r--r--ftp/wcurl/pkg-descr10
3 files changed, 44 insertions, 0 deletions
diff --git a/ftp/wcurl/Makefile b/ftp/wcurl/Makefile
new file mode 100644
index 000000000000..963f7372ffb1
--- /dev/null
+++ b/ftp/wcurl/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= wcurl
+DISTVERSION= 2024.07.10
+CATEGORIES= ftp net www
+
+MAINTAINER= tagattie@FreeBSD.org
+COMMENT= Simple wrapper around curl to easily download files
+WWW= https://curl.se/wcurl/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= curl>=7.46.0:ftp/curl
+TEST_DEPENDS= shunit2:devel/shunit2
+
+USE_GITHUB= yes
+GH_ACCOUNT= curl
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/wcurl \
+ share/man/man1/wcurl.1.gz
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/wcurl ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/wcurl.1 ${STAGEDIR}${PREFIX}/share/man/man1
+
+do-test:
+ cd ${WRKSRC} && ./tests/tests.sh
+
+.include <bsd.port.mk>
diff --git a/ftp/wcurl/distinfo b/ftp/wcurl/distinfo
new file mode 100644
index 000000000000..5a056e441ab2
--- /dev/null
+++ b/ftp/wcurl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1725536015
+SHA256 (curl-wcurl-2024.07.10_GH0.tar.gz) = 962bb72e36e6f6cedbd21c8ca3af50e7dadd587a49d2482ab3226e76cf6dcc97
+SIZE (curl-wcurl-2024.07.10_GH0.tar.gz) = 5791
diff --git a/ftp/wcurl/pkg-descr b/ftp/wcurl/pkg-descr
new file mode 100644
index 000000000000..12e51760f31c
--- /dev/null
+++ b/ftp/wcurl/pkg-descr
@@ -0,0 +1,10 @@
+wcurl is a simple curl wrapper which lets you use curl to download
+files without having to remember any parameters.
+
+Simply call wcurl with a list of URLs you want to download and wcurl
+will pick sane defaults.
+
+If you need anything more complex, you can provide any of curl's
+supported parameters via the --curl-options option. Just beware that
+you likely should be using curl directly if your use case is not
+covered.