aboutsummaryrefslogtreecommitdiff
path: root/ftp/wput
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-07-10 11:43:30 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-07-10 11:43:30 +0000
commit95daff2cd23b9954d2cedaa19702e4639e592e6e (patch)
tree63c78879263add528929ea209412b48989fe6ac2 /ftp/wput
parent46ba2524983b12a7223d8564ce24e60f3400ed9b (diff)
downloadports-95daff2cd23b9954d2cedaa19702e4639e592e6e.tar.gz
ports-95daff2cd23b9954d2cedaa19702e4639e592e6e.zip
Distfile has been rerolled with fix initialy found in files/patch-src::ftp.c
Noticed by: kris / pointyhat
Notes
Notes: svn path=/head/; revision=113329
Diffstat (limited to 'ftp/wput')
-rw-r--r--ftp/wput/Makefile1
-rw-r--r--ftp/wput/distinfo2
-rw-r--r--ftp/wput/files/patch-src::ftp.c34
3 files changed, 1 insertions, 36 deletions
diff --git a/ftp/wput/Makefile b/ftp/wput/Makefile
index 52d695301216..97d72c0b77dc 100644
--- a/ftp/wput/Makefile
+++ b/ftp/wput/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wput
PORTVERSION= 0.4
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= http://itooktheredpill.dyndns.org/wput/
EXTRACT_SUFX= .tgz
diff --git a/ftp/wput/distinfo b/ftp/wput/distinfo
deleted file mode 100644
index b95a9210b52c..000000000000
--- a/ftp/wput/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (wput-0.4.tgz) = 11b73023fe49f4d9d6f6254433c152ae
-SIZE (wput-0.4.tgz) = 154911
diff --git a/ftp/wput/files/patch-src::ftp.c b/ftp/wput/files/patch-src::ftp.c
deleted file mode 100644
index 843483ab0872..000000000000
--- a/ftp/wput/files/patch-src::ftp.c
+++ /dev/null
@@ -1,34 +0,0 @@
---- src/ftp.c.orig Mon Jul 5 21:26:46 2004
-+++ src/ftp.c Mon Jul 5 21:39:05 2004
-@@ -798,15 +798,30 @@
-
- int get_msg(int csock, char * msg, int buflen){
- int res = 0;
-+ char *s;
-
- do {
- memset(msg, 0, buflen);
- res = recv(csock, msg, buflen-1, 0);
- printout(vDEBUG, "%s", msg);
-+ /*
-+ * Multiline responses should of course only check on the last line.
-+ * If there are two \n's from the end of the string in the string,
-+ * the check at the start of second last one.
-+ */
-+ if ((s=strrchr(msg,'\n'))!=NULL) {
-+ if ((s=strrchr(s-1,'\n'))!=NULL) {
-+ s++;
-+ if (*s=='\r') s++;
-+ } else
-+ s=msg;
-+ } else {
-+ s=msg;
-+ }
- /* multiline messages are required by rfc to have a hiphen
- * after the command-code (e.g. 250-).
- * this counts for all but the last one, so look out for it. */
-- } while(msg[3] == '-');
-+ } while(s[3] == '-');
-
- return res;
- }