aboutsummaryrefslogtreecommitdiff
path: root/ftp/wput
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-07-08 08:02:10 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-07-08 08:02:10 +0000
commitde65b31a3d6aef39d8e950ee055155efde3025fe (patch)
treea63fa0bf625105c19fb48ac7f55b3c242c4fa831 /ftp/wput
parent6d6ed936ecf43a93ba0d45bdd1ac7e3c9edd25d4 (diff)
downloadports-de65b31a3d6aef39d8e950ee055155efde3025fe.tar.gz
ports-de65b31a3d6aef39d8e950ee055155efde3025fe.zip
Update ftp/wput to version 0.4 (with smarter upload options)
PR: ports/68684 Submitted by: Edwin Groothuis <edwin@mavetju.org> Reviewed by: ChiP <chip-set@mail.ru>
Notes
Notes: svn path=/head/; revision=113196
Diffstat (limited to 'ftp/wput')
-rw-r--r--ftp/wput/Makefile6
-rw-r--r--ftp/wput/distinfo4
-rw-r--r--ftp/wput/files/patch-src::Makefile.in32
-rw-r--r--ftp/wput/files/patch-src::ftp.c34
-rw-r--r--ftp/wput/files/patch::configure.in28
5 files changed, 71 insertions, 33 deletions
diff --git a/ftp/wput/Makefile b/ftp/wput/Makefile
index aa578d7f5319..52d695301216 100644
--- a/ftp/wput/Makefile
+++ b/ftp/wput/Makefile
@@ -6,16 +6,15 @@
#
PORTNAME= wput
-PORTVERSION= 0.3.6d
+PORTVERSION= 0.4
CATEGORIES= ftp
MASTER_SITES= http://itooktheredpill.dyndns.org/wput/
-DISTNAME= wput-0.3.6
EXTRACT_SUFX= .tgz
MAINTAINER= chip-set@mail.ru
COMMENT= Uploads files or directories to a ftpserver with support of resuming
-PORTDOCS= TODO USAGE.examples
+PORTDOCS= TODO ChangeLog
USE_AUTOCONF_VER= 253
USE_GETOPT_LONG= yes
@@ -27,6 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
PLIST_FILES= bin/wput
+MAN1= wput.1
post-install:
.if !defined(NOPORTDOCS)
diff --git a/ftp/wput/distinfo b/ftp/wput/distinfo
index 4d79af6db8a9..b95a9210b52c 100644
--- a/ftp/wput/distinfo
+++ b/ftp/wput/distinfo
@@ -1,2 +1,2 @@
-MD5 (wput-0.3.6.tgz) = 6fc94aaf28e86f42c2b87ee977ceb039
-SIZE (wput-0.3.6.tgz) = 85523
+MD5 (wput-0.4.tgz) = 11b73023fe49f4d9d6f6254433c152ae
+SIZE (wput-0.4.tgz) = 154911
diff --git a/ftp/wput/files/patch-src::Makefile.in b/ftp/wput/files/patch-src::Makefile.in
index 1275f921b2a3..b361d6722415 100644
--- a/ftp/wput/files/patch-src::Makefile.in
+++ b/ftp/wput/files/patch-src::Makefile.in
@@ -1,24 +1,22 @@
---- src/Makefile.in.orig Tue Dec 2 03:57:48 2003
-+++ src/Makefile.in Tue Dec 2 03:58:04 2003
-@@ -4,10 +4,10 @@
+--- src/Makefile.in.orig Sat Apr 17 02:35:38 2004
++++ src/Makefile.in Mon Jul 5 18:11:30 2004
+@@ -4,8 +4,8 @@
prefix=@prefix@
bindir=@bindir@
CC=@CC@
-CFLAGS= @CFLAGS@
+-LIBS=@LIBS@
+CFLAGS= @CFLAGS@ @CPPFLAGS@
- LDFLAGS=@LDFLAGS@
++LIBS=@LIBS@ ${LDFLAGS}
EXE=../wput
--LIBS=
-+LIBS= @LIBS@
- #DEBUG= -DDEBUG
- DEBUG=
- OBJ=wput.o ftp.o utils.o progress.o socket.o
-@@ -17,7 +17,7 @@
-
- all: wput
- wput: $(OBJ)
-- $(CC) $(LIBS) $(DEBUG) -o $(EXE) $(OBJ)
-+ $(CC) $(LIBS) $(DEBUG) -o $(EXE) $(OBJ) $(LDFLAGS)
+ GETOPT=@GETOPT@
+ MEMDBG=@MEMDBG@
+@@ -22,7 +22,7 @@
+ ftp-ls.o: ftp.h
+
+ wput: $(OBJ)
+- $(CC) -o $(EXE) $(OBJ) $(LIBS)
++ $(CC) -o $(EXE) $(OBJ) $(LIBS) $(LDFLAGS)
clean:
- rm -f *.o wput *~ *.bak
- rm -r msvcpp/Debug msvcpp/Release
+ rm -f *.o *~ *.bak ../wput getopt/*.o
+ win-clean: clean
diff --git a/ftp/wput/files/patch-src::ftp.c b/ftp/wput/files/patch-src::ftp.c
new file mode 100644
index 000000000000..843483ab0872
--- /dev/null
+++ b/ftp/wput/files/patch-src::ftp.c
@@ -0,0 +1,34 @@
+--- src/ftp.c.orig Mon Jul 5 21:26:46 2004
++++ src/ftp.c Mon Jul 5 21:39:05 2004
+@@ -798,15 +798,30 @@
+
+ int get_msg(int csock, char * msg, int buflen){
+ int res = 0;
++ char *s;
+
+ do {
+ memset(msg, 0, buflen);
+ res = recv(csock, msg, buflen-1, 0);
+ printout(vDEBUG, "%s", msg);
++ /*
++ * Multiline responses should of course only check on the last line.
++ * If there are two \n's from the end of the string in the string,
++ * the check at the start of second last one.
++ */
++ if ((s=strrchr(msg,'\n'))!=NULL) {
++ if ((s=strrchr(s-1,'\n'))!=NULL) {
++ s++;
++ if (*s=='\r') s++;
++ } else
++ s=msg;
++ } else {
++ s=msg;
++ }
+ /* multiline messages are required by rfc to have a hiphen
+ * after the command-code (e.g. 250-).
+ * this counts for all but the last one, so look out for it. */
+- } while(msg[3] == '-');
++ } while(s[3] == '-');
+
+ return res;
+ }
diff --git a/ftp/wput/files/patch::configure.in b/ftp/wput/files/patch::configure.in
index f35c75daa982..70d23a0d02fc 100644
--- a/ftp/wput/files/patch::configure.in
+++ b/ftp/wput/files/patch::configure.in
@@ -1,11 +1,17 @@
---- configure.in.orig Tue Dec 2 03:49:48 2003
-+++ configure.in Tue Dec 2 03:50:00 2003
-@@ -9,7 +9,7 @@
- [AC_MSG_ERROR("You need to get libgnugetopt or a newer GNU libc.")]
- )]
- )
--AC_SEARCH_LIBS(getopt_long, gnugetopt, [],
-+AC_SEARCH_LIBS(getopt_long, gnugetopt, [LIBS="-lgnugetopt"],
- [AC_MSG_ERROR("You need to get libgnugetopt or a newer GNU libc.")]
- )
- AC_CONFIG_FILES([Makefile src/Makefile])
+--- configure.in.orig Mon Jul 5 18:06:13 2004
++++ configure.in Mon Jul 5 18:06:46 2004
+@@ -23,12 +23,12 @@
+ AC_PROG_CC
+ AC_CHECK_HEADERS([sys/termio.h, sys/winsize.h], AC_DEFINE(HAVE_TERMIO))
+ AC_CHECK_HEADERS(getopt.h, [
+- AC_SEARCH_LIBS(getopt_long, gnugetopt, [],
++ AC_SEARCH_LIBS(getopt_long, gnugetopt, [LIBS="-lgnugetopt"],
+ [AC_MSG_ERROR("You need to get libgnugetopt or a newer GNU libc.")]
+ )
+ ],
+ [AC_CHECK_HEADERS(gnugetopt/getopt.h, [
+- AC_SEARCH_LIBS(getopt_long, gnugetopt, [],
++ AC_SEARCH_LIBS(getopt_long, gnugetopt, [LIBS="-lgnugetopt"],
+ [AC_MSG_ERROR("You need to get libgnugetopt or a newer GNU libc.")]
+ )
+ ],