aboutsummaryrefslogtreecommitdiff
path: root/ftp/wput
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-03 17:37:52 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-03 17:37:52 +0000
commitdf8007c28e771d2b6c87985656515accdf1dec23 (patch)
tree324fa15a05efc62fc9421a28fc24fa62b3d8952d /ftp/wput
parentbfbf38cbe7307706de9a7fdbb297257f548e87f3 (diff)
downloadports-df8007c28e771d2b6c87985656515accdf1dec23.tar.gz
ports-df8007c28e771d2b6c87985656515accdf1dec23.zip
Finish the conversion to OPTIONS helpers.
APproved by: portmgr (blanket)
Notes
Notes: svn path=/head/; revision=360427
Diffstat (limited to 'ftp/wput')
-rw-r--r--ftp/wput/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/ftp/wput/Makefile b/ftp/wput/Makefile
index f8ee5a4da972..c0861676e688 100644
--- a/ftp/wput/Makefile
+++ b/ftp/wput/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 0.6.2
PORTREVISION= 4
CATEGORIES= ftp
MASTER_SITES= SF
-EXTRACT_SUFX= .tgz
MAINTAINER= chip-set@mail.ru
COMMENT= Uploads files or directories to a ftpserver with support of resuming
@@ -15,20 +14,20 @@ PORTDOCS= ABOUT-NLS COPYING ChangeLog INSTALL TODO
PORTEXAMPLES= USAGE.examples USAGE.resumehandling USAGE.urlhandling \
passwordfile wputrc
+USES= tar:tgz
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE=yes
OPTIONS_DEFINE= TLS NLS DOCS EXAMPLES
-OPTIONS_DEFAULT= TLS
+OPTIONS_DEFAULT=TLS
OPTIONS_SUB= yes
TLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
TLS_CONFIGURE_WITH= ssl
-NLS_USES+= gettext iconv
-NLS_CONFIGURE_ON= --enable-nls \
- --with-libintl-prefix=${LOCALBASE} \
- ${ICONV_CONFIGURE_ARG}
-NLS_CONFIGURE_OFF= --disable-nls --without-libiconv-prefix
+NLS_USES= gettext iconv
+NLS_CONFIGURE_ENABLE= nls
+NLS_CONFIGURE_WITH= libintl-prefix=${LOCALBASE}
+NLS_CONFIGURE_ON= ${ICONV_CONFIGURE_ARG}
pre-configure:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \