aboutsummaryrefslogtreecommitdiff
path: root/ftp/wxdfast
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-12-07 17:52:07 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-12-07 17:52:07 +0000
commit28fe8e4844ed5a9a6fefc6300af7ccb0d9488ad2 (patch)
tree0a70c087ea1f71c1a5eda4b2dfe76b86b7a30fc4 /ftp/wxdfast
parentbc3d9e05557f6b94861539229622eceb14b49632 (diff)
downloadports-28fe8e4844ed5a9a6fefc6300af7ccb0d9488ad2.tar.gz
ports-28fe8e4844ed5a9a6fefc6300af7ccb0d9488ad2.zip
wxDownload Fast (also known as wxDFast) is an open source download manager. It
is multi-platform and builds on Windows(2k,XP), Linux and Mac OS X. Besides that, it is a multi-threaded download manager. This means that it can split a file into several pieces and download the pieces simultaneously. Features: * Faster downloads (with Segmented/Multi-threaded/Accelerated transfers). * Download resuming (Pause and restart where you stopped). * Download scheduling. * Organizes files you have already downloaded. * View server messages (HTTP, FTP, file://). No HTTPS support. * Available in multiple languages and easily translated. Now available in Portuguese [Brazil], Spanish, English, German, Russian, Hungarian, Armenian and Indonesian. * Connection to FTP servers which require a password. * Calculates the MD5 checksum of downloaded files so they can be easily. verified. * Metalink support. WWW: http://dfast.sourceforge.net/
Notes
Notes: svn path=/head/; revision=179133
Diffstat (limited to 'ftp/wxdfast')
-rw-r--r--ftp/wxdfast/Makefile36
-rw-r--r--ftp/wxdfast/distinfo3
-rw-r--r--ftp/wxdfast/files/patch-src__FinishedList.cpp20
-rw-r--r--ftp/wxdfast/pkg-descr21
-rw-r--r--ftp/wxdfast/pkg-plist87
5 files changed, 167 insertions, 0 deletions
diff --git a/ftp/wxdfast/Makefile b/ftp/wxdfast/Makefile
new file mode 100644
index 000000000000..dec732cd1237
--- /dev/null
+++ b/ftp/wxdfast/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: wxdfast
+# Date created: 2006-11-07
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= wxdfast
+PORTVERSION= 0.5.3
+CATEGORIES= ftp www
+MASTER_SITES= SF/dfast
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= A great multithreaded and multi-platform download manager
+
+USE_GETTEXT= yes
+USE_WX= 2.6
+WX_CONF_ARGS= relative
+WX_UNICODE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --mandir="${MANPREFIX}/man"
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+# Debugging symbols.
+STRIP= #
+CONFIGURE_ARGS+=--enable-debug
+
+MAN1= wxdfast.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|wxrc|${WXRC_CMD:T}|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|pt_BR||' ${WRKSRC}/man/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/ftp/wxdfast/distinfo b/ftp/wxdfast/distinfo
new file mode 100644
index 000000000000..08b62fd55ab0
--- /dev/null
+++ b/ftp/wxdfast/distinfo
@@ -0,0 +1,3 @@
+MD5 (wxdfast_0.5.3.tar.gz) = 3514e5b8011f0b3314ef7ba776677541
+SHA256 (wxdfast_0.5.3.tar.gz) = dbdb1eeaba0590ba0f7d5cfb862ce202baa154eeae4f357d38051788b09645bb
+SIZE (wxdfast_0.5.3.tar.gz) = 877821
diff --git a/ftp/wxdfast/files/patch-src__FinishedList.cpp b/ftp/wxdfast/files/patch-src__FinishedList.cpp
new file mode 100644
index 000000000000..2084afb7e512
--- /dev/null
+++ b/ftp/wxdfast/files/patch-src__FinishedList.cpp
@@ -0,0 +1,20 @@
+--- ./src/FinishedList.cpp.orig Sun Oct 29 12:08:39 2006
++++ ./src/FinishedList.cpp Tue Nov 7 19:55:03 2006
+@@ -186,7 +186,7 @@
+ wxDateTime date;
+ value = 0;
+ config->Read(START_REG,&value);
+- date.Set(value);
++ date.Set((time_t)value);
+ infolist->SetItem(5,1,date.Format());
+ }
+
+@@ -194,7 +194,7 @@
+ wxDateTime date;
+ value = 0;
+ config->Read(END_REG,&value);
+- date.Set(value);
++ date.Set((time_t)value);
+ infolist->SetItem(6,1,date.Format());
+ }
+
diff --git a/ftp/wxdfast/pkg-descr b/ftp/wxdfast/pkg-descr
new file mode 100644
index 000000000000..909c9ecb329b
--- /dev/null
+++ b/ftp/wxdfast/pkg-descr
@@ -0,0 +1,21 @@
+wxDownload Fast (also known as wxDFast) is an open source download manager. It
+is multi-platform and builds on Windows(2k,XP), Linux and Mac OS X. Besides
+that, it is a multi-threaded download manager. This means that it can split a
+file into several pieces and download the pieces simultaneously.
+
+Features:
+
+* Faster downloads (with Segmented/Multi-threaded/Accelerated transfers).
+* Download resuming (Pause and restart where you stopped).
+* Download scheduling.
+* Organizes files you have already downloaded.
+* View server messages (HTTP, FTP, file://). No HTTPS support.
+* Available in multiple languages and easily translated. Now available in
+ Portuguese [Brazil], Spanish, English, German, Russian, Hungarian, Armenian
+ and Indonesian.
+* Connection to FTP servers which require a password.
+* Calculates the MD5 checksum of downloaded files so they can be easily.
+ verified.
+* Metalink support.
+
+WWW: http://dfast.sourceforge.net/
diff --git a/ftp/wxdfast/pkg-plist b/ftp/wxdfast/pkg-plist
new file mode 100644
index 000000000000..63998771dcfa
--- /dev/null
+++ b/ftp/wxdfast/pkg-plist
@@ -0,0 +1,87 @@
+bin/wxdfast
+share/applications/wxdfast.desktop
+share/locale/cs/LC_MESSAGES/wxDFast.mo
+share/locale/de/LC_MESSAGES/wxDFast.mo
+share/locale/es/LC_MESSAGES/wxDFast.mo
+share/locale/pt_BR/LC_MESSAGES/wxDFast.mo
+share/pixmaps/wxdfast.png
+%%DATADIR%%/RipStop/icon/png/download_add.png
+%%DATADIR%%/RipStop/icon/png/download_info.png
+%%DATADIR%%/RipStop/icon/png/download_move_down.png
+%%DATADIR%%/RipStop/icon/png/download_move_up.png
+%%DATADIR%%/RipStop/icon/png/download_new.png
+%%DATADIR%%/RipStop/icon/png/download_remove.png
+%%DATADIR%%/RipStop/icon/png/download_start.png
+%%DATADIR%%/RipStop/icon/png/download_start_all.png
+%%DATADIR%%/RipStop/icon/png/download_stop.png
+%%DATADIR%%/RipStop/icon/png/download_stop_all.png
+%%DATADIR%%/RipStop/icon/svg/download_add.svg
+%%DATADIR%%/RipStop/icon/svg/download_info.svg
+%%DATADIR%%/RipStop/icon/svg/download_move_down.svg
+%%DATADIR%%/RipStop/icon/svg/download_move_up.svg
+%%DATADIR%%/RipStop/icon/svg/download_new.svg
+%%DATADIR%%/RipStop/icon/svg/download_remove.svg
+%%DATADIR%%/RipStop/icon/svg/download_start.svg
+%%DATADIR%%/RipStop/icon/svg/download_start_all.svg
+%%DATADIR%%/RipStop/icon/svg/download_stop.svg
+%%DATADIR%%/RipStop/icon/svg/download_stop_all.svg
+%%DATADIR%%/RipStop/licence.txt
+%%DATADIR%%/RipStop/logo/logo.png
+%%DATADIR%%/RipStop/logo/logo.svg
+%%DATADIR%%/RipStop/logo/logo_3d.png
+%%DATADIR%%/RipStop/logo/logo_3d.svg
+%%DATADIR%%/RipStop/logo/wxdfast.ico
+%%DATADIR%%/RipStop/logo/wxdfast.png
+%%DATADIR%%/RipStop/logo/wxdfast.svg
+%%DATADIR%%/RipStop/readme.txt
+%%DATADIR%%/RipStop/ripstop.png
+%%DATADIR%%/RipStop/ripstop.svg
+%%DATADIR%%/boxabout.xrc
+%%DATADIR%%/boxnew.xrc
+%%DATADIR%%/boxoptions.xrc
+%%DATADIR%%/mainwindow.xrc
+%%DATADIR%%/menubar.xrc
+%%DATADIR%%/toolbar.xrc
+%%DATADIR%%/xpm/big/close.xpm
+%%DATADIR%%/xpm/big/down.xpm
+%%DATADIR%%/xpm/big/new.xpm
+%%DATADIR%%/xpm/big/properties.xpm
+%%DATADIR%%/xpm/big/remove.xpm
+%%DATADIR%%/xpm/big/schedule.xpm
+%%DATADIR%%/xpm/big/start.xpm
+%%DATADIR%%/xpm/big/startall.xpm
+%%DATADIR%%/xpm/big/stop.xpm
+%%DATADIR%%/xpm/big/stopall.xpm
+%%DATADIR%%/xpm/big/up.xpm
+%%DATADIR%%/xpm/small/error.xpm
+%%DATADIR%%/xpm/small/exit.xpm
+%%DATADIR%%/xpm/small/graph.xpm
+%%DATADIR%%/xpm/small/new.xpm
+%%DATADIR%%/xpm/small/noresume.xpm
+%%DATADIR%%/xpm/small/ok.xpm
+%%DATADIR%%/xpm/small/options.xpm
+%%DATADIR%%/xpm/small/paste.xpm
+%%DATADIR%%/xpm/small/progress.xpm
+%%DATADIR%%/xpm/small/properties.xpm
+%%DATADIR%%/xpm/small/queue.xpm
+%%DATADIR%%/xpm/small/remove.xpm
+%%DATADIR%%/xpm/small/resume.xpm
+%%DATADIR%%/xpm/small/schedule.xpm
+%%DATADIR%%/xpm/small/start.xpm
+%%DATADIR%%/xpm/small/startall.xpm
+%%DATADIR%%/xpm/small/stop.xpm
+%%DATADIR%%/xpm/small/stopall.xpm
+%%DATADIR%%/xpm/small/wxdfast.xpm
+%%DATADIR%%/xpm/wxdfast.ico
+%%DATADIR%%/xpm/wxdfast.xpm
+@dirrm %%DATADIR%%/xpm/small
+@dirrm %%DATADIR%%/xpm/big
+@dirrm %%DATADIR%%/xpm
+@dirrm %%DATADIR%%/RipStop/logo
+@dirrm %%DATADIR%%/RipStop/icon/svg
+@dirrm %%DATADIR%%/RipStop/icon/png
+@dirrm %%DATADIR%%/RipStop/icon
+@dirrm %%DATADIR%%/RipStop
+@dirrm %%DATADIR%%
+@dirrmtry share/pixmaps
+@dirrmtry share/applications