aboutsummaryrefslogtreecommitdiff
path: root/ftp/yafc
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-05-07 19:32:45 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-05-07 19:32:45 +0000
commitd2d23ef5fe4ca2d92bd9c2849fb23f431c5071b1 (patch)
tree5c8e99dcb21e7139b831fb3b137bb165451d169a /ftp/yafc
parentfcb5ca7aaf587637b7f7d23a9d5f8c4f9ac83550 (diff)
downloadports-d2d23ef5fe4ca2d92bd9c2849fb23f431c5071b1.tar.gz
ports-d2d23ef5fe4ca2d92bd9c2849fb23f431c5071b1.zip
- Update to version 1.1.3 [1]
- Project homepage has changed [1] - Respect NOPORTEXAMPLES - Include bsd.port.mk instead of not needed pre and post PR: ports/167547 [1] Submitted by: Norihiko Murase <mur1080224@inter7.jp> [1]
Notes
Notes: svn path=/head/; revision=296172
Diffstat (limited to 'ftp/yafc')
-rw-r--r--ftp/yafc/Makefile22
-rw-r--r--ftp/yafc/distinfo4
-rw-r--r--ftp/yafc/files/patch-src__input.c66
-rw-r--r--ftp/yafc/pkg-descr2
4 files changed, 16 insertions, 78 deletions
diff --git a/ftp/yafc/Makefile b/ftp/yafc/Makefile
index 902e81133793..eff52e92ea4a 100644
--- a/ftp/yafc/Makefile
+++ b/ftp/yafc/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= yafc
-PORTVERSION= 1.1.1
-PORTREVISION= 1
+PORTVERSION= 1.1.3
CATEGORIES= ftp
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+MASTER_SITES= https://github.com/downloads/sebastinas/yafc/
MAINTAINER= ports@FreeBSD.org
COMMENT= Yet another ftp client. Similar to ftp(1)
@@ -19,21 +18,26 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-socks4=no --with-socks5=no --with-krb4=no \
--with-krb5=no --with-gssapi=no
+FETCH_ARGS= -Fpr
+
MAN1= yafc.1
INFO= yafc
PLIST_FILES= bin/yafc \
- %%EXAMPLESDIR%%/inputrc.sample \
- %%EXAMPLESDIR%%/yafcrc.sample
-PLIST_DIRS= %%EXAMPLESDIR%%
-
-.include <bsd.port.pre.mk>
+ etc/bash_completion.d/yafc
+PLIST_DIRSTRY= etc/bash_completion.d
.if exists(${LOCALBASE}/lib/libreadline.so.6)
LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
post-install:
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/*.sample ${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+PLIST_FILES+= %%EXAMPLESDIR%%/inputrc.sample \
+ %%EXAMPLESDIR%%/yafcrc.sample
+PLIST_DIRS+= %%EXAMPLESDIR%%
+.endif
+
+.include <bsd.port.mk>
diff --git a/ftp/yafc/distinfo b/ftp/yafc/distinfo
index f7cf5bd3e32d..bfc35199244a 100644
--- a/ftp/yafc/distinfo
+++ b/ftp/yafc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (yafc-1.1.1.tar.bz2) = ab72b2ed89fb75dbe8ebd119458cf513392225f367cccfad881e9780aefcd7e6
-SIZE (yafc-1.1.1.tar.bz2) = 858991
+SHA256 (yafc-1.1.3.tar.bz2) = bcd9027081798b1e76fa2af6f900c333c7ab0e9fcd804b1f36f54879b3d377a7
+SIZE (yafc-1.1.3.tar.bz2) = 542126
diff --git a/ftp/yafc/files/patch-src__input.c b/ftp/yafc/files/patch-src__input.c
deleted file mode 100644
index d9b8ac7cb88e..000000000000
--- a/ftp/yafc/files/patch-src__input.c
+++ /dev/null
@@ -1,66 +0,0 @@
---- src/input.c.bak Thu Oct 6 04:31:25 2005
-+++ src/input.c Sun Jul 9 12:42:12 2006
-@@ -76,7 +76,11 @@
-
- # include <fcntl.h>
- # include <sys/ioctl.h>
-+#if 0
- # include <termio.h>
-+#else
-+# include <termios.h>
-+#endif
-
- char *getpass_hook(const char *prompt)
- {
-@@ -89,23 +93,39 @@
- #else
- int c, n = 0;
- char tmp[1024];
-+#if 0
- struct termio tbuf, tbufsave;
-+#else
-+ struct termios tbuf, tbufsave;
-+#endif
- FILE *fd;
-
- if((fd = fopen("/dev/tty", "rb")) == NULL) {
- perror("fopen /dev/tty");
- return NULL;
- }
-+#if 0
- if (ioctl(fileno(fd), TCGETA, &tbuf) < 0) {
-+#else
-+ if (ioctl(fileno(fd), TIOCGETA, &tbuf) < 0) {
-+#endif
- perror("ioctl get");
- fclose(fd);
- return NULL;
- }
- tbufsave = tbuf;
-+#if 0
- tbuf.c_iflag &= ~(IUCLC | ISTRIP | IXON | IXOFF);
-+#else
-+ tbuf.c_iflag &= ~(ISTRIP | IXON | IXOFF);
-+#endif
- tbuf.c_lflag &= ~(ICANON | ISIG | ECHO);
- tbuf.c_cc[4] = 1; /* MIN */
-+#if 0
- if (ioctl(fileno(fd), TCSETA, &tbuf) < 0) {
-+#else
-+ if (ioctl(fileno(fd), TIOCSETA, &tbuf) < 0) {
-+#endif
- perror("ioctl set");
- fclose(fd);
- return NULL;
-@@ -132,7 +152,11 @@
- fflush(stderr);
- }
- tmp[n] = '\0';
-+#if 0
- if (ioctl(fileno(fd), TCSETA, &tbufsave) < 0) {
-+#else
-+ if (ioctl(fileno(fd), TIOCSETA, &tbufsave) < 0) {
-+#endif
- perror("ioctl restore");
- fclose(fd);
- return NULL;
diff --git a/ftp/yafc/pkg-descr b/ftp/yafc/pkg-descr
index 7f7d68f15610..4c9379bb0a88 100644
--- a/ftp/yafc/pkg-descr
+++ b/ftp/yafc/pkg-descr
@@ -2,4 +2,4 @@ Yafc is yet another ftp client, similar to ftp(1). Features include
Directory cache, remote filename completion, aliases, colored ls,
recursive get/put/ls/rm, nohup mode transfers, and more!
-WWW: http://yafc.sourceforge.net/
+WWW: http://www.yafc-ftp.com/