aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-06 17:16:54 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-06 17:16:54 +0000
commit03c137d6f815a41f2b7361eebaf857f7fa2f2604 (patch)
tree8acff035e2804326858e174c6a2fcde48273b5d5 /ftp
parentcf977e9902e0b2934a27c3f4f41dd1fb1f3af730 (diff)
downloadports-03c137d6f815a41f2b7361eebaf857f7fa2f2604.tar.gz
ports-03c137d6f815a41f2b7361eebaf857f7fa2f2604.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/cmdftp/Makefile36
-rw-r--r--ftp/cmdftp/distinfo1
-rw-r--r--ftp/cmdftp/pkg-descr8
-rw-r--r--ftp/cmdftp/pkg-plist5
5 files changed, 51 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index bc8fe0972d04..58524ad89910 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -8,6 +8,7 @@
SUBDIR += bftpd
SUBDIR += bsdftpd-ssl
SUBDIR += cftp
+ SUBDIR += cmdftp
SUBDIR += curl
SUBDIR += curlpp
SUBDIR += dmachine
diff --git a/ftp/cmdftp/Makefile b/ftp/cmdftp/Makefile
new file mode 100644
index 000000000000..1ea35d7e6b37
--- /dev/null
+++ b/ftp/cmdftp/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: cmdftp
+# Date created: 2003-12-28
+# Whom: Andreas Fehlner <fehlner@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cmdftp
+PORTVERSION= 0.7.2
+CATEGORIES= ftp
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= cmdftp
+
+MAINTAINER= fehlner@gmx.de
+COMMENT= Command line shell-like ftp client
+
+USE_REINPLACE= yes
+
+DOCS= CHANGELOG README RELEASE
+
+post-patch:
+ @${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|^CC|#CC|g ; \
+ s|^CFLAGS|#CFLAGS|g ; \
+ s|^PREFIX|#PREFIX|g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cmdftp ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/ftp/cmdftp/distinfo b/ftp/cmdftp/distinfo
new file mode 100644
index 000000000000..2fbe301538a8
--- /dev/null
+++ b/ftp/cmdftp/distinfo
@@ -0,0 +1 @@
+MD5 (cmdftp-0.7.2.tar.gz) = ddc9b7c7171b4f308fe0f6015b253a3c
diff --git a/ftp/cmdftp/pkg-descr b/ftp/cmdftp/pkg-descr
new file mode 100644
index 000000000000..065262b38e09
--- /dev/null
+++ b/ftp/cmdftp/pkg-descr
@@ -0,0 +1,8 @@
+cmdftp is a command line FTP client for Unix systems that features shell-like
+functions, passive mode, local and remote transparent modes, broken connection
+resumption, multiple and recursive file transfers, auto-login, and more.
+
+WWW: http://cmdftp.sourceforge.net
+
+-Andreas Fehlner
+fehlner@gmx.de
diff --git a/ftp/cmdftp/pkg-plist b/ftp/cmdftp/pkg-plist
new file mode 100644
index 000000000000..26a5a01e8597
--- /dev/null
+++ b/ftp/cmdftp/pkg-plist
@@ -0,0 +1,5 @@
+bin/cmdftp
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/RELEASE
+%%PORTDOCS%%@dirrm %%DOCSDIR%%