aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2020-11-16 20:36:22 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2020-11-16 20:36:22 +0000
commit05ac365a0a335ec9e2c7aa20d961f131cdc069e1 (patch)
treedd7ff59b4609185250963096e849b7b49e9e2a5e /ftp
parent121e399cae9d4336c6f72b77d41fe9c2ea006357 (diff)
downloadports-05ac365a0a335ec9e2c7aa20d961f131cdc069e1.tar.gz
ports-05ac365a0a335ec9e2c7aa20d961f131cdc069e1.zip
- Handle two missing dependencies, pcre2 and nettle
- Improve PCRE handling in options, add NTLM option - Use pkg-config unconditionally, it's used for detecting all depends and is required for proper pcre2 detection - Use USES=localbase instead of duplicate CPPFLAGS/LDFLAGS for most options PR: 251189 Approved by: vd (maintainer)
Notes
Notes: svn path=/head/; revision=555515
Diffstat (limited to 'ftp')
-rw-r--r--ftp/wget/Makefile35
1 files changed, 20 insertions, 15 deletions
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index 82562563735a..e09b902f9846 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wget
DISTVERSION= 1.20.3
+PORTREVISION= 1
CATEGORIES= ftp www
MASTER_SITES= GNU
@@ -15,15 +16,16 @@ LICENSE_FILE= ${WRKSRC}/COPYING
TEST_DEPENDS= p5-HTTP-Daemon>=0:www/p5-HTTP-Daemon \
p5-IO-Socket-SSL>=0:security/p5-IO-Socket-SSL
-USES= charsetfix cpe iconv tar:lz
+USES= charsetfix cpe iconv localbase pkgconfig tar:lz
CPE_VENDOR= gnu
GNU_CONFIGURE= yes
OPTIONS_SUB= yes
-OPTIONS_RADIO= SSL
+OPTIONS_RADIO= SSL PCRE
OPTIONS_RADIO_SSL=GNUTLS OPENSSL
-OPTIONS_DEFINE= DOCS IDN IPV6 MANPAGES METALINK NLS PCRE PSL
-OPTIONS_DEFAULT=IDN MANPAGES OPENSSL
+OPTIONS_RADIO_PCRE=PCRE1 PCRE2
+OPTIONS_DEFINE= DOCS IDN IPV6 MANPAGES METALINK NLS PSL NTLM
+OPTIONS_DEFAULT=IDN MANPAGES OPENSSL NLS
DOCS_DESC= Install info page
DOCS_CONFIGURE_ENV= MAKEINFO="${MAKEINFO}"
@@ -32,8 +34,6 @@ DOCS_USES= makeinfo
IDN_LIB_DEPENDS= libidn2.so:dns/libidn2 \
libunistring.so:devel/libunistring
-IDN_CPPFLAGS= -I${LOCALBASE}/include
-IDN_LDFLAGS= -L${LOCALBASE}/lib
IDN_CONFIGURE_ENABLE= iri
IDN_CONFIGURE_ON= --with-libidn=${LOCALBASE} \
--with-libunistring-prefix=${LOCALBASE}
@@ -50,18 +50,23 @@ METALINK_LIB_DEPENDS= libmetalink.so:misc/libmetalink
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-NLS_CPPFLAGS= -I${LOCALBASE}/include
-NLS_LDFLAGS= -L${LOCALBASE}/lib
PCRE_DESC= Support Perl regular expressions in addition to POSIX
-PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
-PCRE_CPPFLAGS= -I${LOCALBASE}/include
-PCRE_LDFLAGS= -L${LOCALBASE}/lib
-PCRE_CONFIGURE_ENABLE= pcre
+
+PCRE1_DESC= Support PCRE style regular expressions
+PCRE1_LIB_DEPENDS= libpcre.so:devel/pcre
+PCRE1_CONFIGURE_ENABLE= pcre
+
+PCRE2_DESC= Support PCRE2 style regular expressions
+PCRE2_LIB_DEPENDS= libpcre2-8.so:devel/pcre2
+PCRE2_CONFIGURE_ENABLE= pcre2
PSL_CONFIGURE_WITH= libpsl
PSL_LIB_DEPENDS= libpsl.so:dns/libpsl
+NTLM_DESC= Support NTLM authorization
+NTLM_CONFIGURE_ENABLE= ntlm
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENSSL}
@@ -70,11 +75,11 @@ CONFIGURE_ARGS+=--with-ssl=openssl --with-libssl-prefix=${OPENSSLBASE}
CPPFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
.elif ${PORT_OPTIONS:MGNUTLS}
-USES+= pkgconfig
LIB_DEPENDS+= libgnutls.so:security/gnutls
CONFIGURE_ARGS+=--with-ssl=gnutls
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+. if ${PORT_OPTIONS:MNTLM}
+LIB_DEPENDS+= libnettle.so:security/nettle
+. endif
.else
CONFIGURE_ARGS+=--without-ssl
.endif