aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2021-06-18 22:56:04 +0000
committerCy Schubert <cy@FreeBSD.org>2021-06-18 22:59:01 +0000
commit24cd2ad24f2581e9f4853065cd9322837a5f58f6 (patch)
tree57872e6d4833818db7e9be8a4fe91f4c59bc592b /ftp
parent15908d8556c2f5b11f0d949e190444abdd64aa01 (diff)
downloadports-24cd2ad24f2581e9f4853065cd9322837a5f58f6.tar.gz
ports-24cd2ad24f2581e9f4853065cd9322837a5f58f6.zip
ftp/freebsd-ftpd: Add ftp/freebsd-ftpd
This new port contains the legacy FreeBSD ftpd which will be removed from FreeBSD-14.
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/freebsd-ftpd/Makefile40
-rw-r--r--ftp/freebsd-ftpd/distinfo3
-rw-r--r--ftp/freebsd-ftpd/pkg-descr9
-rw-r--r--ftp/freebsd-ftpd/pkg-plist3
5 files changed, 56 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index cbf45be174d1..984e2b57e3bc 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -16,6 +16,7 @@
SUBDIR += filezilla
SUBDIR += fmirror
SUBDIR += fpc-libcurl
+ SUBDIR += freebsd-ftpd
SUBDIR += ftpcopy
SUBDIR += ftpfind
SUBDIR += ftplib
diff --git a/ftp/freebsd-ftpd/Makefile b/ftp/freebsd-ftpd/Makefile
new file mode 100644
index 000000000000..c129ea875761
--- /dev/null
+++ b/ftp/freebsd-ftpd/Makefile
@@ -0,0 +1,40 @@
+# Created by: cy@FreeBSD.org
+
+PORTNAME= freebsd-ftpd
+DISTVERSIONPREFIX= v
+DISTVERSION= 20200704
+CATEGORIES= ftp
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= FreeBSD ftpd
+
+LICENSE= BSD3CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= cschuber
+
+USES= uidfix
+
+MAKE_ARGS+= BINOWN=${BINOWN} BINMODE=${BINMODE}
+MAKE_ENV+= MAKESYSPATH=/usr/src/share/mk \
+ BINDIR=${PREFIX}/libexec \
+ MANDIR=${PREFIX}/man/man
+
+OPTIONS_DEFINE= IPV6 LIBBLACKLIST
+OPTIONS_DEFAULT= IPV6 LIBBLACKLIST
+.if !exists(/usr/include/blacklist.h)
+OPTIONS_EXCLUDE= LIBBLACKLIST
+.endif
+
+LIBBLACKLIST_DESC= libblacklist(3) support for rlogind(8) and rshd(8)
+LIBBLACKLIST_MAKE_ARGS= USE_LIBBLACKLIST=yes
+
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1300134
+MAKE_ENV+= MK_WERROR=no
+.else
+MAKE_ENV+= NO_WERROR=1
+.endif
+
+.include <bsd.port.mk>
diff --git a/ftp/freebsd-ftpd/distinfo b/ftp/freebsd-ftpd/distinfo
new file mode 100644
index 000000000000..206aaa765090
--- /dev/null
+++ b/ftp/freebsd-ftpd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1624028878
+SHA256 (cschuber-freebsd-ftpd-v20200704_GH0.tar.gz) = b07938fcdea2191e967db16ad4d204711a33e06b2083a08622022fc55e42fbed
+SIZE (cschuber-freebsd-ftpd-v20200704_GH0.tar.gz) = 49136
diff --git a/ftp/freebsd-ftpd/pkg-descr b/ftp/freebsd-ftpd/pkg-descr
new file mode 100644
index 000000000000..c6e34039baea
--- /dev/null
+++ b/ftp/freebsd-ftpd/pkg-descr
@@ -0,0 +1,9 @@
+git filter-repo is a versatile tool for rewriting history, which
+includes capabilities I have not found anywhere else. It roughly falls
+into the same space of tool as git filter-branch but without the
+capitulation-inducing poor performance, with far more capabilities,
+and with a design that scales usability-wise beyond trivial rewriting
+cases. git filter-repo is now recommended by the git project instead of
+git filter-branch.
+
+WWW: https://github.com/newren/git-filter-repo
diff --git a/ftp/freebsd-ftpd/pkg-plist b/ftp/freebsd-ftpd/pkg-plist
new file mode 100644
index 000000000000..d20051b4d69b
--- /dev/null
+++ b/ftp/freebsd-ftpd/pkg-plist
@@ -0,0 +1,3 @@
+libexec/ftpd
+man/man5/ftpchroot.5.gz
+man/man8/ftpd.8.gz