aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-03-03 08:05:19 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-03-03 08:05:19 +0000
commit49641faa1b4bdecd56c80cb88280143e0aac03af (patch)
treecff4d798c74c905e8887918e016391bc1e5ae12e /ftp
parent2d225ae6e1e46888267e649b901fad8d16ef7815 (diff)
downloadports-49641faa1b4bdecd56c80cb88280143e0aac03af.tar.gz
ports-49641faa1b4bdecd56c80cb88280143e0aac03af.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile117
-rw-r--r--ftp/curl/distinfo4
-rw-r--r--ftp/curl/files/patch-Makefile.in33
-rw-r--r--ftp/curl/files/patch-configure20
-rw-r--r--ftp/curl/files/patch-lib::url.c6
-rw-r--r--ftp/curl/files/patch-src-tool_operate.c (renamed from ftp/curl/files/patch-src::main.c)50
-rw-r--r--ftp/curl/files/patch-tests::runtests.pl16
-rw-r--r--ftp/curl/pkg-plist11
8 files changed, 99 insertions, 158 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 1676e8481030..d2097db5f63b 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -6,58 +6,17 @@
#
PORTNAME= curl
-PORTVERSION= 7.21.3
-PORTREVISION= 2
+PORTVERSION= 7.24.0
CATEGORIES= ftp ipv6 www
MASTER_SITES= http://curl.haxx.se/download/ \
- ftp://ftp.sunet.se/pub/www/utilities/curl/ \
- ftp://ftp.fu-berlin.de/pub/unix/network/curl/ \
- ftp://crydee.sai.msu.ru/zeus/unix/WWW/tools/mirror/
-MASTER_SITE_SUBDIR= curl
+ LOCAL/sunpoet
+EXTRACT_SUFX= .tar.lzma
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Non-interactive tool to get files from FTP, GOPHER, HTTP(S) servers
LICENSE= MIT
-PATCH_STRIP= -p1
-
-MAN1= curl.1 curl-config.1
-MAN3= curl_easy_cleanup.3 curl_easy_duphandle.3 \
- curl_easy_escape.3 curl_easy_getinfo.3 \
- curl_easy_init.3 curl_easy_pause.3 \
- curl_easy_perform.3 curl_easy_reset.3 curl_easy_recv.3 \
- curl_easy_send.3 \
- curl_easy_setopt.3 curl_easy_strerror.3 curl_easy_unescape.3 \
- curl_escape.3 \
- curl_unescape.3 curl_formadd.3 curl_formget.3 curl_formfree.3 curl_free.3 \
- curl_getdate.3 curl_getenv.3 curl_global_init.3 \
- curl_global_init_mem.3 curl_global_cleanup.3 curl_mprintf.3 \
- curl_multi_add_handle.3 curl_multi_assign.3 curl_multi_cleanup.3 \
- curl_multi_fdset.3 curl_multi_info_read.3 curl_multi_init.3 \
- curl_multi_perform.3 curl_multi_remove_handle.3 \
- curl_multi_setopt.3 curl_multi_socket.3 \
- curl_multi_socket_action.3 \
- curl_multi_strerror.3 curl_multi_timeout.3 \
- curl_share_cleanup.3 curl_share_init.3 \
- curl_share_setopt.3 curl_share_strerror.3 curl_slist_append.3 \
- curl_slist_free_all.3 curl_strequal.3 curl_version.3 \
- curl_version_info.3 libcurl.3 libcurl-easy.3 libcurl-errors.3 \
- libcurl-multi.3 libcurl-share.3 libcurl-tutorial.3
-
-USE_LDCONFIG= yes
-SHLIB_VER= 6
-
-MAKE_ENV= SHLIB_VER="${SHLIB_VER}"
-PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
-
-USE_PERL5_BUILD= yes
-USE_BZIP2= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--enable-pop3 --enable-smtp --enable-imap --enable-rtsp \
- --disable-threaded-resolver --disable-werror
-MAKE_JOBS_SAFE= yes
-
OPTIONS= CARES "Asynchronous DNS resolution via c-ares" off \
CURL_DEBUG "Enable curl diagnostic output" off \
GNUTLS "Use GNU TLS if OPENSSL is OFF" off \
@@ -74,7 +33,47 @@ OPTIONS= CARES "Asynchronous DNS resolution via c-ares" off \
RTMP "RTMP streams support" off \
TRACKMEMORY "Enable curl memory diagnostic output" off
-.include <bsd.port.pre.mk>
+CONFIGURE_ARGS= --disable-threaded-resolver --disable-werror \
+ --enable-imap --enable-pop3 --enable-rtsp --enable-smtp
+CONFIGURE_ENV= LOCALBASE="${LOCALBASE}"
+GNU_CONFIGURE= yes
+MAKE_ENV= SHLIB_VER="${SHLIB_VER}"
+MAKE_JOBS_SAFE= yes
+USE_GNOME= gnomehack
+USE_LDCONFIG= yes
+USE_PERL5_BUILD= yes
+USE_XZ= yes
+
+DOCS= BINDINGS BUGS CONTRIBUTE DISTRO-DILEMMA FAQ FEATURES HISTORY \
+ INSTALL INSTALL.devcpp INTERNALS KNOWN_BUGS LICENSE-MIXING \
+ MANUAL README.netware README.win32 RESOURCES SSLCERTS THANKS \
+ TODO TheArtOfHttpScripting VERSIONS curl-config.html \
+ curl-config.pdf curl.html curl.pdf index.html
+MAN1= curl.1 curl-config.1
+MAN3= curl_easy_cleanup.3 curl_easy_duphandle.3 curl_easy_escape.3 \
+ curl_easy_getinfo.3 curl_easy_init.3 curl_easy_pause.3 \
+ curl_easy_perform.3 curl_easy_recv.3 curl_easy_reset.3 \
+ curl_easy_send.3 curl_easy_setopt.3 curl_easy_strerror.3 \
+ curl_easy_unescape.3 curl_escape.3 curl_formadd.3 \
+ curl_formfree.3 curl_formget.3 curl_free.3 curl_getdate.3 \
+ curl_getenv.3 curl_global_cleanup.3 curl_global_init.3 \
+ curl_global_init_mem.3 curl_mprintf.3 curl_multi_add_handle.3 \
+ curl_multi_assign.3 curl_multi_cleanup.3 curl_multi_fdset.3 \
+ curl_multi_info_read.3 curl_multi_init.3 curl_multi_perform.3 \
+ curl_multi_remove_handle.3 curl_multi_setopt.3 \
+ curl_multi_socket.3 curl_multi_socket_action.3 \
+ curl_multi_strerror.3 curl_multi_timeout.3 \
+ curl_share_cleanup.3 curl_share_init.3 curl_share_setopt.3 \
+ curl_share_strerror.3 curl_slist_append.3 \
+ curl_slist_free_all.3 curl_strequal.3 curl_unescape.3 \
+ curl_version.3 curl_version_info.3 libcurl.3 libcurl-easy.3 \
+ libcurl-errors.3 libcurl-multi.3 libcurl-share.3 \
+ libcurl-tutorial.3
+PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
+
+SHLIB_VER= 6
+
+.include <bsd.port.options.mk>
.if defined(WITH_GNUTLS) && defined(WITH_OPENSSL)
IGNORE= may only use GNU TLS if OpenSSL support is disabled
@@ -90,10 +89,10 @@ IGNORE= only supports NTLM with OpenSSL
.if defined(WITH_LDAPS)
.if !defined(WITH_LDAP)
-IGNORE= only supports LDAPS with LDAP
+IGNORE= only supports LDAPS with LDAP
.else
.if !defined(WITH_OPENSSL) && !defined(WITH_GNUTLS)
-IGNORE= only supports LDAPS with SSL (OpenSSL or GNUTLS)
+IGNORE= only supports LDAPS with SSL (OpenSSL or GNUTLS)
.endif
.endif
.endif
@@ -203,25 +202,19 @@ CONFIGURE_ARGS+= --enable-proxy
CONFIGURE_ARGS+= --disable-proxy
.endif
-CONFIGURE_ENV+= LOCALBASE="${LOCALBASE}"
-
-DOCS= BINDINGS BUGS CONTRIBUTE DISTRO-DILEMMA FAQ FEATURES \
- HISTORY INSTALL INSTALL.devcpp INTERNALS KNOWN_BUGS \
- LICENSE-MIXING MANUAL README.netware README.win32 RESOURCES \
- SSLCERTS THANKS TODO TheArtOfHttpScripting VERSIONS \
- curl-config.html curl-config.pdf curl.html curl.pdf \
- index.html
+post-patch:
+ @${REINPLACE_CMD} -e '/^SUBDIRS = / s|$$| docs|; /^DIST_SUBDIRS = / s| docs||; /cd docs &&/d' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/require "valgrind.pm";/d' ${WRKSRC}/tests/runtests.pl
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${DOCS:S@^@${WRKSRC}/docs/@} ${DOCSDIR}
- @${MKDIR} ${DOCSDIR}/libcurl
- (cd ${WRKSRC}/docs/libcurl && exec ${INSTALL_DATA} ABI *.html *.pdf *.m4 ${DOCSDIR}/libcurl/)
+ ${MKDIR} ${DOCSDIR}/ ${DOCSDIR}/libcurl/
+ cd ${WRKSRC}/docs/ && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}/
+ cd ${WRKSRC}/docs/libcurl/ && ${INSTALL_DATA} ABI *.html *.pdf *.m4 ${DOCSDIR}/libcurl/
.endif
.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/examples/README ${WRKSRC}/docs/examples/Makefile.example ${WRKSRC}/docs/examples/makefile* ${WRKSRC}/docs/examples/*.c ${WRKSRC}/docs/examples/*.cc ${EXAMPLESDIR}/
+ ${MKDIR} ${EXAMPLESDIR}/
+ cd ${WRKSRC}/docs/examples/ && ${INSTALL_DATA} README Makefile.example makefile* *.c *.cc ${EXAMPLESDIR}/
.endif
# Setting LC_ALL=C is a kludge; maybe curl/libcurl shouldn't actually use
@@ -236,4 +229,4 @@ test: build
.endif
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} LC_ALL=C ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index 66b8dd5d5e0c..24996a072e3d 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (curl-7.21.3.tar.bz2) = 4fa554c56fdb09c299185a2c4c94416560e42a7e40655335f327e4d67c48bc39
-SIZE (curl-7.21.3.tar.bz2) = 2194975
+SHA256 (curl-7.24.0.tar.lzma) = cd683ee8be137ed8a8e97d42fd3cc94f88f63d478b83d4abe38e31b6281e2268
+SIZE (curl-7.24.0.tar.lzma) = 1973811
diff --git a/ftp/curl/files/patch-Makefile.in b/ftp/curl/files/patch-Makefile.in
deleted file mode 100644
index 33176dcc9180..000000000000
--- a/ftp/curl/files/patch-Makefile.in
+++ /dev/null
@@ -1,33 +0,0 @@
-Description: Build and install the documentation as usual, no special handling.
-Forwarded: https://sourceforge.net/tracker/?func=detail&aid=2897155&group_id=976&atid=100976
-Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2010-12-18
-
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -311,9 +311,9 @@
- libcurl.pc.in vc6curl.dsw MacOSX-Framework Android.mk $(CMAKE_DIST)
-
- bin_SCRIPTS = curl-config
--SUBDIRS = lib src
--DIST_SUBDIRS = $(SUBDIRS) tests include packages docs
--pkgconfigdir = $(libdir)/pkgconfig
-+SUBDIRS = lib src docs
-+DIST_SUBDIRS = $(SUBDIRS) tests include packages
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = libcurl.pc
- all: all-recursive
-
-@@ -874,12 +874,10 @@
- # We extend the standard install with a custom hook:
- install-data-hook:
- cd include && $(MAKE) install
-- cd docs && $(MAKE) install
-
- # We extend the standard uninstall with a custom hook:
- uninstall-hook:
- cd include && $(MAKE) uninstall
-- cd docs && $(MAKE) uninstall
-
- ca-bundle: lib/mk-ca-bundle.pl
- @echo "generate a fresh ca-bundle.crt"
diff --git a/ftp/curl/files/patch-configure b/ftp/curl/files/patch-configure
index 27d26e2e1c8c..3510088a3f55 100644
--- a/ftp/curl/files/patch-configure
+++ b/ftp/curl/files/patch-configure
@@ -6,9 +6,9 @@ Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2010-12-19
---- a/configure
-+++ b/configure
-@@ -14201,10 +14201,10 @@
+--- configure.orig 2012-02-26 17:52:21.904908587 +0800
++++ configure 2012-02-26 17:52:21.929909948 +0800
+@@ -15049,10 +15049,10 @@
flags_dbg_all="$flags_dbg_all -gdwarf-2"
flags_dbg_all="$flags_dbg_all -gvms"
flags_dbg_yes="-g"
@@ -21,7 +21,7 @@ Last-Update: 2010-12-19
else
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
$as_echo "no" >&6; }
-@@ -15041,6 +15041,9 @@
+@@ -15892,6 +15892,9 @@
tmp_CFLAGS="$CFLAGS"
tmp_CPPFLAGS="$CPPFLAGS"
@@ -31,7 +31,7 @@ Last-Update: 2010-12-19
ac_var_stripped=""
for word1 in $tmp_CFLAGS; do
ac_var_strip_word="no"
-@@ -15071,6 +15074,7 @@
+@@ -15922,6 +15925,7 @@
done
tmp_CPPFLAGS="$ac_var_stripped"
squeeze tmp_CPPFLAGS
@@ -39,7 +39,7 @@ Last-Update: 2010-12-19
#
if test "$want_debug" = "yes"; then
-@@ -15283,6 +15287,9 @@
+@@ -16139,6 +16143,9 @@
#
if test "$honor_optimize_option" = "yes"; then
@@ -49,7 +49,7 @@ Last-Update: 2010-12-19
ac_var_stripped=""
for word1 in $tmp_CFLAGS; do
ac_var_strip_word="no"
-@@ -15313,6 +15320,7 @@
+@@ -16169,6 +16176,7 @@
done
tmp_CPPFLAGS="$ac_var_stripped"
squeeze tmp_CPPFLAGS
@@ -57,7 +57,7 @@ Last-Update: 2010-12-19
if test "$want_optimize" = "yes"; then
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if compiler accepts optimizer enabling options" >&5
-@@ -19224,7 +19232,8 @@
+@@ -20137,7 +20145,8 @@
PKGTEST="no"
PREFIX_OPENSSL=$OPT_SSL
@@ -66,8 +66,8 @@ Last-Update: 2010-12-19
+ OPENSSL_PCDIR="$LOCALBASE/libdata/pkgconfig"
{ $as_echo "$as_me:${as_lineno-$LINENO}: PKG_CONFIG_LIBDIR will be set to \"$OPENSSL_PCDIR\"" >&5
$as_echo "$as_me: PKG_CONFIG_LIBDIR will be set to \"$OPENSSL_PCDIR\"" >&6;}
- if test -e "$OPENSSL_PCDIR/openssl.pc"; then
-@@ -21264,29 +21273,30 @@
+ if test -f "$OPENSSL_PCDIR/openssl.pc"; then
+@@ -23231,29 +23240,30 @@
;;
off)
LIB_RTMP="-lrtmp"
diff --git a/ftp/curl/files/patch-lib::url.c b/ftp/curl/files/patch-lib::url.c
index 7239f50ccdc8..02d05e16997b 100644
--- a/ftp/curl/files/patch-lib::url.c
+++ b/ftp/curl/files/patch-lib::url.c
@@ -3,9 +3,9 @@ Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2010-12-18
---- a/lib/url.c
-+++ b/lib/url.c
-@@ -857,6 +857,10 @@
+--- lib/url.c.orig 2012-01-23 23:31:30.000000000 +0800
++++ lib/url.c 2012-02-26 17:52:21.937920303 +0800
+@@ -797,6 +797,10 @@
data->progress.flags |= PGRS_HIDE;
data->state.current_speed = -1; /* init to negative == impossible */
diff --git a/ftp/curl/files/patch-src::main.c b/ftp/curl/files/patch-src-tool_operate.c
index 02f52d2be1ea..a168b8bcec40 100644
--- a/ftp/curl/files/patch-src::main.c
+++ b/ftp/curl/files/patch-src-tool_operate.c
@@ -1,20 +1,13 @@
-Description: Use fstat() instead of stat() to avoid a race condition.
-Forwarded: not-needed
-Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2010-12-18
-
---- a/src/main.c
-+++ b/src/main.c
-@@ -4887,33 +4887,34 @@
- break;
+--- src/tool_operate.c.orig 2012-01-23 23:31:30.000000000 +0800
++++ src/tool_operate.c 2012-02-26 17:40:00.117907281 +0800
+@@ -580,22 +580,10 @@
+ DEBUGASSERT(!outs.filename);
}
- if(config->resume_from_current) {
-- /* We're told to continue from where we are now. Get the
-- size of the file as it is now and open it for append instead */
--
+- /* We're told to continue from where we are now. Get the size
+- of the file as it is now and open it for append instead */
- struct_stat fileinfo;
--
- /* VMS -- Danger, the filesize is only valid for stream files */
- if(0 == stat(outfile, &fileinfo))
- /* set offset to current file size: */
@@ -24,37 +17,32 @@ Last-Update: 2010-12-18
- config->resume_from = 0;
- }
-
- outs.filename = outfile;
-
- if(config->resume_from) {
-- outs.init = config->resume_from;
+ if(config->resume_from || config->resume_from_current) {
/* open file for output: */
-- outs.stream=(FILE *) fopen(outfile, config->resume_from?"ab":"wb");
-+ /* (always open for appending, it has no effect on new files) */
-+ outs.stream=(FILE *) fopen(outfile, "ab");
- if(!outs.stream) {
+- FILE *file = fopen(outfile, config->resume_from?"ab":"wb");
++ /* (always open for appending, it has no effect on new files) */
++ FILE *file = fopen(outfile, "ab");
+ if(!file) {
helpf(config->errors, "Can't open '%s'!\n", outfile);
- free(url);
res = CURLE_WRITE_ERROR;
- break;
+@@ -603,6 +591,19 @@
}
+ outs.fopened = TRUE;
+ outs.stream = file;
+
-+ if(config->resume_from_current) {
-+ /* We're told to continue from where we are now. Get the
-+ size of the file as it is now */
-+
-+ struct_stat fileinfo;
-+
++ if(config->resume_from_current) {
++ /* We're told to continue from where we are now. Get the size
++ of the file as it is now */
++ struct_stat fileinfo;
+ if(0 == fstat(fileno(outs.stream), &fileinfo))
+ /* set offset to current file size: */
+ config->resume_from = fileinfo.st_size;
+ else
+ /* let offset be 0 */
+ config->resume_from = 0;
-+ }
++ }
+
-+ outs.init = config->resume_from;
+ outs.init = config->resume_from;
}
else {
- outs.stream = NULL; /* open when needed */
diff --git a/ftp/curl/files/patch-tests::runtests.pl b/ftp/curl/files/patch-tests::runtests.pl
deleted file mode 100644
index bedee759ea0f..000000000000
--- a/ftp/curl/files/patch-tests::runtests.pl
+++ /dev/null
@@ -1,16 +0,0 @@
-Description: Do not use valgrind.
-Forwarded: not-needed
-Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2010-06-11
-
---- a/tests/runtests.pl
-+++ b/tests/runtests.pl
-@@ -104,7 +104,7 @@
- );
-
- require "getpart.pm"; # array functions
--require "valgrind.pm"; # valgrind report parser
-+#require "valgrind.pm"; # valgrind report parser
- require "ftp.pm";
-
- my $HOSTIP="127.0.0.1"; # address on which the test server listens
diff --git a/ftp/curl/pkg-plist b/ftp/curl/pkg-plist
index dd30f9e019d1..cddfb71934dd 100644
--- a/ftp/curl/pkg-plist
+++ b/ftp/curl/pkg-plist
@@ -9,7 +9,6 @@ include/curl/mprintf.h
include/curl/multi.h
include/curl/stdcheaders.h
include/curl/typecheck-gcc.h
-include/curl/types.h
@dirrm include/curl
lib/libcurl.a
lib/libcurl.la
@@ -165,6 +164,7 @@ libdata/pkgconfig/libcurl.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/curlx.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/debug.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/evhiperfifo.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/externalsocket.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fileupload.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fopen.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ftp-wildcard.c
@@ -183,6 +183,7 @@ libdata/pkgconfig/libcurl.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/httpcustomheader.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/httpput.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/https.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/imap.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/makefile.dj
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multi-app.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multi-debugcallback.c
@@ -192,16 +193,24 @@ libdata/pkgconfig/libcurl.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multithread.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/opensslthreadlock.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/persistant.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pop3s.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pop3slist.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/post-callback.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/postit2.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/progressfunc.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/resolve.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rtsp.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleconv.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sepheaders.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sendrecv.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplepost.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplesmtp.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplessl.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/smooth-gtk-thread.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/smtp-multi.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/smtp-tls.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synctime.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/threaded-ssl.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/url2file.c
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%