aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-06-28 17:53:55 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-06-28 17:53:55 +0000
commit7fd883616c4f7b80237db27b80deda59d861631b (patch)
treeb196e91db5372b4e20561ec237704631b0d498d1 /ftp
parentda534e1b465ab4fe92dfd4307bd59bae4d9887f3 (diff)
downloadports-7fd883616c4f7b80237db27b80deda59d861631b.tar.gz
ports-7fd883616c4f7b80237db27b80deda59d861631b.zip
- Fix multi handles
- Bump PORTREVISION for package change PR: 201147 Submitted by: grembo Obtained from: https://github.com/bagder/curl/commit/903b6e05565bf826b4194447864288642214b094
Notes
Notes: svn path=/head/; revision=390806
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile2
-rw-r--r--ftp/curl/files/patch-lib-multi.c16
-rw-r--r--ftp/curl/files/patch-lib-transfer.c16
3 files changed, 33 insertions, 1 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 712c27d2fdba..cd915386b6c0 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= curl
PORTVERSION= 7.43.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp www
MASTER_SITES= http://curl.haxx.se/download/ \
LOCAL/sunpoet
diff --git a/ftp/curl/files/patch-lib-multi.c b/ftp/curl/files/patch-lib-multi.c
new file mode 100644
index 000000000000..49a9a6466c63
--- /dev/null
+++ b/ftp/curl/files/patch-lib-multi.c
@@ -0,0 +1,16 @@
+Obtained from: https://github.com/bagder/curl/commit/903b6e05565bf826b4194447864288642214b094
+
+--- lib/multi.c.orig 2015-06-15 21:14:25 UTC
++++ lib/multi.c
+@@ -402,11 +402,6 @@ CURLMcode curl_multi_add_handle(CURLM *m
+ /* Point to the multi's connection cache */
+ data->state.conn_cache = &multi->conn_cache;
+
+- if(data->set.httpreq == HTTPREQ_PUT)
+- data->state.infilesize = data->set.filesize;
+- else
+- data->state.infilesize = data->set.postfieldsize;
+-
+ /* This adds the new entry at the 'end' of the doubly-linked circular
+ list of SessionHandle structs to try and maintain a FIFO queue so
+ the pipelined requests are in order. */
diff --git a/ftp/curl/files/patch-lib-transfer.c b/ftp/curl/files/patch-lib-transfer.c
new file mode 100644
index 000000000000..c0507a87548a
--- /dev/null
+++ b/ftp/curl/files/patch-lib-transfer.c
@@ -0,0 +1,16 @@
+Obtained from: https://github.com/bagder/curl/commit/903b6e05565bf826b4194447864288642214b094
+
+--- lib/transfer.c.orig 2015-06-14 21:31:01 UTC
++++ lib/transfer.c
+@@ -1315,6 +1315,11 @@ CURLcode Curl_pretransfer(struct Session
+ Curl_safefree(data->info.wouldredirect);
+ data->info.wouldredirect = NULL;
+
++ if(data->set.httpreq == HTTPREQ_PUT)
++ data->state.infilesize = data->set.filesize;
++ else
++ data->state.infilesize = data->set.postfieldsize;
++
+ /* If there is a list of cookie files to read, do it now! */
+ if(data->change.cookielist)
+ Curl_cookie_loadfiles(data);