aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2020-12-24 13:46:01 +0000
committerKai Knoblich <kai@FreeBSD.org>2020-12-24 13:46:01 +0000
commit9cb5898561b302d952fec8e2fac66a945a2c4915 (patch)
tree9274631a296b893d582fb8062e2f256a3a8c8d77 /ftp
parent7d195372928d0063fee4bc1fcf003eae95a2451e (diff)
downloadports-9cb5898561b302d952fec8e2fac66a945a2c4915.tar.gz
ports-9cb5898561b302d952fec8e2fac66a945a2c4915.zip
Relax hardcoded paths to fix build with Python 3.8.7
Since r558913 Python 3.8 incorporates BPO-42604 [1] which changed the shared libs naming scheme. This means "EXT_SUFFIX" is now derived from SOABI and yields with Python 3.8 to ".cpython-38.so" instead of ".so". The affected ports strip the libaries in the "post-install" target via hardcoded path(s) and the build fails at the end because the new extension is not expected at this place. Remedy the issue by adding wildcards to these paths. This should also prepare the ports for future Python releases, which will use the new shared libs naming scheme. [1] https://bugs.python.org/issue42604 PR: 252057 Reported by: John Kennedy Reviewed by: fluffy, koobs Approved by: koobs (python)
Notes
Notes: svn path=/head/; revision=559094
Diffstat (limited to 'ftp')
-rw-r--r--ftp/py-pycurl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/ftp/py-pycurl/Makefile b/ftp/py-pycurl/Makefile
index 81e7063e7cd6..50c01670f8a7 100644
--- a/ftp/py-pycurl/Makefile
+++ b/ftp/py-pycurl/Makefile
@@ -25,7 +25,7 @@ PORTDOCS= AUTHORS INSTALL.rst README.rst RELEASE-NOTES.rst
OPTIONS_DEFINE= DOCS
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}*.so
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}/