aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2015-02-12 15:57:24 +0000
committerPawel Pekala <pawel@FreeBSD.org>2015-02-12 15:57:24 +0000
commitc52d6b0f4151b664bdaf77ab996e9073b242f2eb (patch)
tree3f16d1f07cf4ea5860c7703cbaa0e0598f127658 /ftp
parent20da3a365bef41d54402260676fb62b1d069e57a (diff)
downloadports-c52d6b0f4151b664bdaf77ab996e9073b242f2eb.tar.gz
ports-c52d6b0f4151b664bdaf77ab996e9073b242f2eb.zip
Notes
Diffstat (limited to 'ftp')
-rw-r--r--ftp/bareftp/Makefile27
-rw-r--r--ftp/bareftp/distinfo4
-rw-r--r--ftp/bareftp/files/patch-src-bareFTP.Protocol.Ftp-ftp-ListParser.cs13
3 files changed, 22 insertions, 22 deletions
diff --git a/ftp/bareftp/Makefile b/ftp/bareftp/Makefile
index 1996465ed811..82e617ddfd96 100644
--- a/ftp/bareftp/Makefile
+++ b/ftp/bareftp/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= bareftp
-PORTVERSION= 0.3.10
-PORTREVISION= 1
+PORTVERSION= 0.3.11
CATEGORIES= ftp
MASTER_SITES= http://www.bareftp.org/release/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= chris@bsdjunk.com
COMMENT= FTP client made in C sharp
GNU_CONFIGURE= yes
@@ -24,24 +23,12 @@ USE_LDCONFIG= yes
OPTIONS_DEFINE= GNOMEKEYRING NLS
OPTIONS_DEFAULT=GNOMEKEYRING
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGNOMEKEYRING}
-KEYRING_DETECT= ${LOCALBASE}/libdata/pkgconfig/gnome-keyring-sharp-1.0.pc
-BUILD_DEPENDS+= ${KEYRING_DETECT}:${PORTSDIR}/security/gnome-keyring-sharp
-RUN_DEPENDS+= ${KEYRING_DETECT}:${PORTSDIR}/security/gnome-keyring-sharp
-.else
-CONFIGURE_ARGS+= --without-gnomekeyring
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-CONFIGURE_ARGS+= --enable-nls
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+GNOMEKEYRING_CONFIGURE_WITH= gnomekeyring
+GNOMEKEYRING_BUILD_DEPENDS= gnome-keyring-sharp>0:${PORTSDIR}/security/gnome-keyring-sharp
+GNOMEKEYRING_RUN_DEPENDS= gnome-keyring-sharp>0:${PORTSDIR}/security/gnome-keyring-sharp
+NLS_CONFIGURE_ENABLE= nls
# TODO
# Ugly way but configure ignore "--localedir=" fu* ;/
diff --git a/ftp/bareftp/distinfo b/ftp/bareftp/distinfo
index 8deeab78ba02..bbabb3a09df0 100644
--- a/ftp/bareftp/distinfo
+++ b/ftp/bareftp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bareftp-0.3.10.tar.gz) = d36f10485762d93e38e81618981b540f2130945d7f41c7c0b60b6a0c059cd849
-SIZE (bareftp-0.3.10.tar.gz) = 618615
+SHA256 (bareftp-0.3.11.tar.gz) = cafc6cd6f71ee6e6151cadc517349646977d90b372850e194ad505d89aa6682f
+SIZE (bareftp-0.3.11.tar.gz) = 630784
diff --git a/ftp/bareftp/files/patch-src-bareFTP.Protocol.Ftp-ftp-ListParser.cs b/ftp/bareftp/files/patch-src-bareFTP.Protocol.Ftp-ftp-ListParser.cs
new file mode 100644
index 000000000000..6788da4e4482
--- /dev/null
+++ b/ftp/bareftp/files/patch-src-bareFTP.Protocol.Ftp-ftp-ListParser.cs
@@ -0,0 +1,13 @@
+--- src/bareFTP.Protocol.Ftp/ftp/ListParser.cs.bak 2015-01-29 07:46:28.278935333 -0800
++++ src/bareFTP.Protocol.Ftp/ftp/ListParser.cs 2015-01-29 07:47:03.217939461 -0800
+@@ -22,7 +22,9 @@
+
+ using System;
+ using System.Collections.Generic;
+-using System.Text;z
++using System.Text;
++using System.Globalization;
++
+ namespace bareFTP.Protocol.Ftp
+ {
+ public class ListParser