aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-16 22:54:01 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-16 22:54:01 +0000
commitda1cdf136662c638856b1c3f9c1e9ebdba254438 (patch)
tree1d6cc74c9c789d02deb7cc650056bbc79e4ba20b /ftp
parentda0a99f53a3b29cbec6c5382f34b922c5673b8ae (diff)
downloadports-da1cdf136662c638856b1c3f9c1e9ebdba254438.tar.gz
ports-da1cdf136662c638856b1c3f9c1e9ebdba254438.zip
Convert PORTDOCS and PORTEXAMPLES to PLIST entries
Notes
Notes: svn path=/head/; revision=493110
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curlpp/Makefile4
-rw-r--r--ftp/curlpp/pkg-plist27
2 files changed, 28 insertions, 3 deletions
diff --git a/ftp/curlpp/Makefile b/ftp/curlpp/Makefile
index ab2f4c607066..2fe640ffa317 100644
--- a/ftp/curlpp/Makefile
+++ b/ftp/curlpp/Makefile
@@ -18,10 +18,8 @@ LIB_DEPENDS= libcurl.so:ftp/curl
OPTIONS_DEFINE= DOCS EXAMPLES
USES= cmake compiler:c++11-lang localbase pathfix
-USE_LDCONFIG= yes
-PORTDOCS= *
-PORTEXAMPLES= *
+USE_LDCONFIG= yes
GH_ACCOUNT= jpbarrette
USE_GITHUB= yes
diff --git a/ftp/curlpp/pkg-plist b/ftp/curlpp/pkg-plist
index 830a0fddb635..64b780e249d8 100644
--- a/ftp/curlpp/pkg-plist
+++ b/ftp/curlpp/pkg-plist
@@ -38,3 +38,30 @@ lib/libcurlpp.so
lib/libcurlpp.so.1
lib/libcurlpp.so.1.0.0
libdata/pkgconfig/curlpp.pc
+%%PORTDOCS%%%%DOCSDIR%%/guide.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example00.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example01.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example02.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example03.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example04.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example05.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example06.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example07.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example08.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example09.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example10.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example11.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example12.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example13.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example14.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example15.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example16.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example17.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example18.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example19.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example20.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example21.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example22.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example23.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example24.cpp